cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1843
Views
0
Helpful
5
Replies

Fail to forward request:Please call XMLAPI via SSL(HTTPS)

RahulKadam03080
Beginner
Beginner

I am able to successfully use the XML API Create Meeting Eample in python code for the apidemoeu test site, but now it giving me  following response.

('FAILURE', 'Fail to forward request:Please call XMLAPI via SSL(HTTPS)')

5 Replies 5

nmorrow
Cisco Employee
Cisco Employee

Hello,

 

Webex requires HTTPS for all communication, as a security standard. Webex currently uses TLS 1.2, so your development environment should also support this for establishing HTTPS connections, usually meaning you should just need the latest available operating system and packages for your chosen platform. This error just means that you are suspected to have called the XML service via plain HTTP.

Earlier it was running fine on my system suddenly it starts showing this error. Is there any security update recently.

Hello,

 

     HTTPS requirement is not recent. If you can share your code without exposing personal information, it may help to figure what may have happened.

Yes, I will share it but now using postman for calling API gives the same error.  I am sending following XML code in the postman body.

<?xml version="1.0" encoding="UTF-8"?>
<serv:message xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<header>
<securityContext>
<webExID>******</webExID>
<password>******</password>
<siteName>******</siteName>
</securityContext>
</header>
<body>
<bodyContent
xsi:type="java:com.webex.service.binding.training.GetTrainingSession">
<sessionKey>******</sessionKey>
</bodyContent>
</body>
</serv:message>

 

I am sending a request with the above body and getting the following response.

 

<?xml version="1.0" encoding="UTF-8" ?>
<serv:message xmlns:serv="http://www.webex.com/schemas/2002/06/service" xmlns:com="http://www.webex.com/schemas/2002/06/common">
<serv:header>
<serv:response>
<serv:result>FAILURE</serv:result>
<serv:reason>Fail to forward request:Please call XMLAPI via SSL(HTTPS)</serv:reason>
<serv:gsbStatus>PRIMARY</serv:gsbStatus>
<serv:exceptionID>000000</serv:exceptionID></serv:response>
</serv:header>
<serv:body>
</serv:body>
</serv:message>

 

 

Thank you for confirming you are using postman, as I would have needed the server code that is being used to submit the XML, rather than the XML itself. It looks as though a Webex environment issue was identified over the weekend that is causing the api.webex.com proxy to fail to honor port 443 forwarding to the XML service.

A workaround is reportedly working, by using your site's direct XML service URL of https://sitename.webex.com/WBXService/XMLService, where sitename would be changed to your actual Webex site subdomain. The current issue seems to be with the api.webex.com proxy failing to honor port 443 forwarding to the XML service, though this is expected to see a fix soon.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: