cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

If your Cloud Collaboration question is not answered quickly, please email devsupport@webex.com for additional help

399
Views
3
Helpful
4
Replies

WebEx XML API field requirements Change?

Hello,

I'm trying to find documentation on what would have caused the conference name field to be required on an API post.

Previously, customer ran this without error-

POST https://schwabmeetingtest.webex.com/WBXService/XMLService HTTP/1.1

CorrelationId: 83491360-2ff8-4748-a27c-44708f2c71fe

Accept-Encoding: gzip, deflate

Accept: application/json

Content-Type: application/xml

Host: schwabmeetingtest.webex.com

Content-Length: 1403

Expect: 100-continue

<?xml version="1.0"?>

<message xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

  <header>

    <securityContext>

      <webExID>Chris.Zellman@schwab.com</webExID>

      <sessionTicket>AAABYS5suHYAABUYA0gAKEgyU0sAAAAEjiyFyaKYEr2qBKAMJZDQxOBya0CXfeIGzw1p/z3Or7lBSABmAQFIMlNLAAAABCoIL8UAVUmFZ36KZkOUsTsdRFE7K4T0g/CRZKH1lglSU0sAAAAEdtbAGIqUf5PTZwilX+aZx7jojF1IuZc4n5E09Ob+OF+NiuadN8s/U4bbKpqyLgz4xMUkyO5DkpaLQBhZGuxlmfdtzCS7WZcv5gYLQpmNW26Qg27+URHu8qiiM2krUTQaPLi5Tf1PX+DctfieMpzixZQOFw1PMwpmXIWKLGb6JVPdVzKUtHyNBg2fZqXXvLCFsUMolcmdSjuUI7gX7nSYZlVE3Q3rSRFDQHzWqFRkdnIcY6ssggg66QnyrqW/Rk93X0ZMQUdfQURESU5HX1NIQTI1Nl9BTEdPUklUSE1f</sessionTicket>

      <siteName>schwabmeetingtest</siteName>

    </securityContext>

  </header>

  <body>

    <bodyContent xsi:type="java:com.webex.service.binding.meeting.CreateMeeting">

      <accessControl>

        <enforcePassword>false</enforcePassword>

        <meetingPassword>a729339c</meetingPassword>

      </accessControl>

      <metaData>

        <sessionTemplate>

          <use>SIATemplate</use>

        </sessionTemplate>

      </metaData>

      <schedule>

        <startDate>01/25/2018 17:00:00</startDate>

        <timeZoneID>20</timeZoneID>

      </schedule>

      <enableOptions>

        <audioVideo>true</audioVideo>

      </enableOptions>

    </bodyContent>

  </body>

</message>

HTTP/1.1 200 OK

Date: Thu, 25 Jan 2018 18:59:24 GMT

Server:

Strict-Transport-Security: max-age=31536000; includeSubDomains;preload

Pragma: no-cache

Cache-Control: no-cache

Expires: Thu, 01 Jan 1970 00:00:00 GMT

X-Frame-Options: DENY

TrackingID: 9c597487-7d54-4432-9221-0e414843a52e

Content-Type: text/xml;charset=UTF-8

X-XSS-Protection: 1; mode=block

Content-Length: 599

<?xml version="1.0" encoding="UTF-8"?>

<serv:message xmlns:serv="http://www.webex.com/schemas/2002/06/service" xmlns:com="http://www.webex.com/schemas/2002/06/common" xmlns:meet="http://www.webex.com/schemas/2002/06/service/meeting" xmlns:att="http://www.webex.com/schemas/2002/06/service/attendee"><serv:header><serv:response><serv:result>FAILURE</serv:result><serv:reason>The input ocnference name cannot be empty</serv:reason><serv:gsbStatus>PRIMARY</serv:gsbStatus><serv:exceptionID>060065</serv:exceptionID></serv:response></serv:header><serv:body><serv:bodyContent/></serv:body></serv:message>

But now it is returning an error, requiring them to instead run this:

POST https://schwabmeetingtest.webex.com/WBXService/XMLService HTTP/1.1

CorrelationId: 83491360-2ff8-4748-a27c-44708f2c71fe

Accept-Encoding: gzip, deflate

Accept: application/json

Content-Type: application/xml

Host: schwabmeetingtest.webex.com

Content-Length: 1442

Expect: 100-continue

<?xml version="1.0"?>

<message xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

  <header>

    <securityContext>

      <webExID>Chris.Zellman@schwab.com</webExID>

      <sessionTicket>AAABYS5suHYAABUYA0gAKEgyU0sAAAAEjiyFyaKYEr2qBKAMJZDQxOBya0CXfeIGzw1p/z3Or7lBSABmAQFIMlNLAAAABCoIL8UAVUmFZ36KZkOUsTsdRFE7K4T0g/CRZKH1lglSU0sAAAAEdtbAGIqUf5PTZwilX+aZx7jojF1IuZc4n5E09Ob+OF+NiuadN8s/U4bbKpqyLgz4xMUkyO5DkpaLQBhZGuxlmfdtzCS7WZcv5gYLQpmNW26Qg27+URHu8qiiM2krUTQaPLi5Tf1PX+DctfieMpzixZQOFw1PMwpmXIWKLGb6JVPdVzKUtHyNBg2fZqXXvLCFsUMolcmdSjuUI7gX7nSYZlVE3Q3rSRFDQHzWqFRkdnIcY6ssggg66QnyrqW/Rk93X0ZMQUdfQURESU5HX1NIQTI1Nl9BTEdPUklUSE1f</sessionTicket>

      <siteName>schwabmeetingtest</siteName>

    </securityContext>

  </header>

  <body>

    <bodyContent xsi:type="java:com.webex.service.binding.meeting.CreateMeeting">

      <accessControl>

        <enforcePassword>false</enforcePassword>

        <meetingPassword>a729339c</meetingPassword>

      </accessControl>

      <metaData>

<confName>Sample Meeting</confName>

        <sessionTemplate>

          <use>SIATemplate</use>

        </sessionTemplate>

      </metaData>

      <schedule>

        <startDate>01/25/2018 17:00:00</startDate>

        <timeZoneID>20</timeZoneID>

      </schedule>

      <enableOptions>

        <audioVideo>true</audioVideo>

      </enableOptions>

    </bodyContent>

  </body>

</message>

HTTP/1.1 200 OK

Date: Thu, 25 Jan 2018 19:04:09 GMT

Server:

Strict-Transport-Security: max-age=31536000; includeSubDomains;preload

Pragma: no-cache

Cache-Control: no-cache

Expires: Thu, 01 Jan 1970 00:00:00 GMT

X-Frame-Options: DENY

TrackingID: 46e57316-fa44-4cb5-a79e-5ddb3a6ebee2

Content-Type: text/xml;charset=UTF-8

X-XSS-Protection: 1; mode=block

Content-Length: 998

<?xml version="1.0" encoding="UTF-8"?>

<serv:message xmlns:serv="http://www.webex.com/schemas/2002/06/service" xmlns:com="http://www.webex.com/schemas/2002/06/common" xmlns:meet="http://www.webex.com/schemas/2002/06/service/meeting" xmlns:att="http://www.webex.com/schemas/2002/06/service/attendee"><serv:header><serv:response><serv:result>SUCCESS</serv:result><serv:gsbStatus>PRIMARY</serv:gsbStatus></serv:response></serv:header><serv:body><serv:bodyContent xsi:type="meet:createMeetingResponse" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><meet:meetingkey>590384377</meet:meetingkey><meet:iCalendarURL><serv:host>https://schwabmeetingtest.webex.com/schwabmeetingtest/j.php?MTID=me1714b57c5bf90bc75490d2661cfdb51</serv:host><serv:attendee>https://schwabmeetingtest.webex.com/schwabmeetingtest/j.php?MTID=md4ee4842a044778654de37a198a7f05b</serv:attendee></meet:iCalendarURL><meet:guestToken>9f453b63516acf4d981454910afd4847</meet:guestToken></serv:bodyContent></serv:body></serv:message>

Can anyone point me to the correct documentation on this and other changes?

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

Re: WebEx XML API field requirements Change?

Hello,

     This is a confirmed bug and has been reported to engineering for correction in a future release.

View solution in original post

4 REPLIES 4
Highlighted
Cisco Employee

Re: WebEx XML API field requirements Change?

I believe the confName should have been pulled from the scheduling template and that the error may indicate some bug scenario. I was able to duplicate this and have reported it to engineering, we will respond back with the findings. You have already established the workaround of including a confName to override the template.

Highlighted
Cisco Employee

Re: WebEx XML API field requirements Change?

Hello,

     This is a confirmed bug and has been reported to engineering for correction in a future release.

View solution in original post

Highlighted

Re: WebEx XML API field requirements Change?

Thank you, Nathan.  Could I get the bug number?

Highlighted
Cisco Employee

Re: WebEx XML API field requirements Change?

It is an internal bug number, but I created a ticket to reference the bug, HD0009963323.

CreatePlease to create content