cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
14469
Views
0
Helpful
8
Replies
MS-JK
Beginner

AnyConnect 4.2 - no license key issue

Pulled Anyconnect - 4.2.00096 directoy from CWS Admin/Download.

Installing in Windows 10 (latest patches)

I have build a profile with web security profile editor 4.2.00096. I placed it into the mounted installation directory /Profiles/websecurity

I installed VPN + Web Security Module

When started anyconnect - I keep seeing "No License Key" next the Web Security Module

I've looked in C:\ProgramData\Cisco\Cisco AnyConnect Secure Mobility Client\Web Secuirty    - I CAN NOT find my sample profile

PS: I've looked in C:\ProgramData\Cisco\Cisco AnyConnect Secure Mobility Client\Profile   -I CAN see my VPN sample profile I've made for VPN.

Goal: I'm basially just provisioning a test PC where I'll be using the company generated key (in CWS) for authentication purposes using AnyConnect Web Sec Module.

Anyone running into this? Or am I missing something here. 

1 ACCEPTED SOLUTION

Accepted Solutions

-You can place .wso file under " c:/ProgramData/Cisco/Cisco Anyconnect Secure Mobility Client/Web Security/ "

-Please keep naming convention as "WebSecurity_ServiceProfile.wso"

-Restart "Cisco Anyconnect Secure Mobility Agent" and "Cisco Anyconnect Web Security Agent" in services.msc 

If still continue to display "no license key" . Please share the .wso file ( it's encrypted ).

Regards,

Ashok Sakthivel.

View solution in original post

8 REPLIES 8
Ashok Sakthivel
Cisco Employee

Check the company generated key (in CWS Portal) is active. 

May I know the file extension that you placed in /Profiles/websecurity ?  Is it .wso ?

Regards,

Ashok Sakthivel.

 

Company key is active. I have also tried with user keys. They are also active.

Yes .wso is the extension - I've copied both .wso and the .xml file just to make sure into the /Profiles/websecurity installation dir. 

After the install - I'm not even seeing my *.wso file anywhere in the C:\ProgramData\Cisco\Cisco AnyConnect Secure Mobility Client\Web Secuirty  directory. Which I'm assuming that is where it needs to be after the Installation. 

Thanks.

MS-JK
Beginner

Update:

Cisco's POV (auto provisioned portal) looks like it assigned me proxy IPs that are NOT on the proxy list on default web mod editor profile. 

Did the following (but still didn't help)

1) updated xml file and removed all <tower> but left one that was assigned to me by the portal. I've also updated the tower name to something different and updated <default> to reflect this change. 

2) re-opened in editor and saved into .wso

3) uninstall/reboot/re-install 

SAME ISSUE

But I did notice in Web Security - Preferences section, that not even the name changed of the tower. SO - it seems as this thing just isn't taking my profile during install!? Can I just copy it somewhere where it needs to go after install like you can with VPN profile? 

I be happy to send you the xml file if anyone likes to try it. 

 

-You can place .wso file under " c:/ProgramData/Cisco/Cisco Anyconnect Secure Mobility Client/Web Security/ "

-Please keep naming convention as "WebSecurity_ServiceProfile.wso"

-Restart "Cisco Anyconnect Secure Mobility Agent" and "Cisco Anyconnect Web Security Agent" in services.msc 

If still continue to display "no license key" . Please share the .wso file ( it's encrypted ).

Regards,

Ashok Sakthivel.

View solution in original post

MS-JK
Beginner

This worked. I copied it to the dir and also updated name of the wso file. 

Thanks!

hello jkanclirz2, where did you find the .wso file ? could you send me an email to ingeniero.ccnp@gmail.com if possible ?

best regards!

Hello, where did you find the .wso file ?

 

best regards!

kshorett
Beginner

Having this same issue on my mac.  How do I fix?

Content for Community-Ad

This widget could not be displayed.