Showing results for 
Search instead for 
Did you mean: 

jabber ipad "failed to get device configuration"

Level 1
Level 1

I have a problem setting up Video and Voice Calling.

When I select Video and Voice calling I am promted to enter my username/password/TFTP server.

When I input the information I get an error that said "failed to get device configuration."

What does that mean and how do I fix it?

13 Replies 13

Assuming an on-premise deplyment:-

have you uploaded the cop file onto CUCM?

have you created the client on CUCM - "TABxxxx"?

Have you associated to the end user?

Have you specified the TFTP server as the CUCM within CUPS Application->Jabber settings?

follow all the steps in the Jabber for Ipad deployment guide,




I too am having the same xact problem.  Upon attempting to login to the unified communications manager selection in the Cisco Jabber for iPad app I receive "failed to get device configuration."  I have followed the steps in the admin guide but no luck.  All servers in cluster have been rebooted, cop files loaded, device created, etc... but nothing.  Am I missing something?  This is being tried on a ipad while connected to Anyconnect vpn client.  The Unified Presence selection works fine.  I have read other posts that had a similiar issue but the problms wre resolved by a servr reboot.  My servers have already been rebooted........

Any help would be greatly appreciated.



I had the same problem (but on a LAN) In the end it was mis configuration of the client TABXXX settings in the call manager. Tripple check the config because there are so many fields in your call manager and it very easy to miss one.

I recommend testing via Lan first to make sure the config works and its not a firewall access problem.

Sorry I can't be more precise.

Hi RCraig,

Thanks for your response.  In your case what exact setting/field in the device config for TABXXXX was it that you had to change?




I was able to resolve my login issue by selecting my username in a field called "Digest User."  After that, everything seems to be working normally.


Strange. I have that field empty and mine works

Strange indeed.  I did test it though to make sure I wasn't going crazy...but sure enough when I set Digest User to none and then re attempt to log into Cisco Jabber for iPad it gives me the Failed to get device config error.  Once I set Digest User back to my user name, it works.  Perhaps a bug?  Just glad its working.  I'm sure Cisco is due to release an update on the App store pretty soon as this was the first version of this app.  Thanks for your suggestions, btw.


Thank you, Daniel. I had the same problem, and your solution helped me

Glad I could help! 

Daniel, thanks your trick worked for me as well.

Hello @all

I had exact the same problem and setting up the digest user helped here as well.

Thanks for providing this solution.

Kind Regards


Ilya Geraskin
Level 1
Level 1

Hello guys!

Hmm, it's in Protocol Specific Information section. Easy to miss

Hello everybody,

I had the same problem, you need associate the TAB device to the end user, y try log in again.

Best Regards!