cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2633
Views
0
Helpful
11
Replies

SRV _cisco-uds not working

iverson.justin
Level 1
Level 1

I am trying to lab up a phone only mode for jabber clients. I cannot get the android or windows jabber to auto config with SRV using _cisco-uds.  I have a cups server but would like this phone only mode to work without one.  

1 Accepted Solution

Accepted Solutions

Review the PRT to find out exactly what is happening

Yes, if you want to use MRA, you need to use SRV records.

HTH

java

if this helps, please rate

View solution in original post

11 Replies 11

Jaime Valencia
Cisco Employee
Cisco Employee

Do you already have the proper configuration in CUCM for those devices?

HTH

java

if this helps, please rate

Yes, I can get them to work when I do advanced settings and point them to CUCM.  Cisco Unified Client Services Framework work then and registers.  

Use nslookup to make sure the PC can actually get the right info, if you get the right info, you'd need to look at a PRT to find out the issue.

Many time the issue is DNS issues.

HTH

java

if this helps, please rate

Do I need to upload a jabber config .xml file to CUCM?  I am using jabber 11.5.2 on CUCM 10.5.2. Will Cisco _cisco-uds work in "phone" only mode? I am testing on android and Windows-11.5.2 ver.

Whether you need a jabber-config.xml or not, is up to you, and your requirements.

Yes, phone mode will work, assuming the user is associated a service profile which does not have IM&P

HTH

java

if this helps, please rate

I can only get it to authenticate with CUCM with this config.  Since I am using CUCM 10.5 should I use a lower windows jabber version?  I am trying to get _cisco-uds and _collab-edge to work on phone only mode.  Are there any setup documents for phone only mode and no IMP?  
FallbackAuthenticator: CUCM
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
ProductMode: Phone_Mode
TftpServer1: 10.1.1.1
CtiServer1: 10.1.1.1
CcmcipServer1: 10.1.1.1
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
ServiceDiscoveryExcludedServices: CUP,WEBEX
NOT_SPECIFIED
NOT_SPECIFIED
Telephony_Enabled: TRUE
Voicemail_Enabled: TRUE
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
NOT_SPECIFIED
EnableDPIAware: TRUE

Phone only mode just means that you will not have an IM&P in your service profile, there should be no need to hardcode anything in the bootstrap for this to work.

I'd suggest you pull a PRT and review the login process to see if you're properly resolving the SRV, and if CUCM can find the user and the associated devices.

HTH

java

if this helps, please rate

How do I go about PRT testing? Not great at DNS.  Does my CUCM need to be fully DNS integrated?  

PRT is not a test, it's problem reporting tool. Help -> Report a problem.

If you're using SRV records, you need to have everything properly configured in the DNS so you can resolve to your CUCM server.

HTH

java

if this helps, please rate

I can't even get jabber to log in when I set it manually in advanced settings
*CUCM 9 or later
* Use the following server:x.x.x.x

Only way I can get it to work is using bootstrap file.  Is there a bug with 11.5.2 Windows jabber?

side note:

Expressway requires use of SRV records correct? 

Review the PRT to find out exactly what is happening

Yes, if you want to use MRA, you need to use SRV records.

HTH

java

if this helps, please rate