Showing results for 
Search instead for 
Did you mean: 

Unity Connection JDBC?

This document was generated from CDN thread

Created by: Cisco Developer on 17-08-2009 07:44:28 PM
I'm working on a project for a client that will run on both windows and linux, to use Java to run JDBC/SQL queries for Unity Connection 7.  Has anyone achieved this?  I've looked at and configured the database proxy service (which connects via TCP 20532) with Unity Connection and tried different Informix JDBC drivers.  Any help/guidance would be greatly appreciated!!!
When attempting to establish a connection via JDBC, I keep getting SQL error code -908
com.informix.asf.IfxASFException: Attempt to connect to database server (myunityserver) failed

Subject: RE: Unity Connection JDBC?
Replied by: Paul Wilkinson on 21-08-2009 06:35:04 AM
-908 indicates that the server couldn't be contacted.  Double check the following:
1. Make sure that the DBProxy shutdown shutdown timer is non-zero.
2. Make sure that you have started the DBProxy service from the serviceabilty web page
3. Verify that the proxy is running using telnet: "telnet mycucaddress 20532" on Windows or "telnet mycucaddress:20532" on UNIX
4. Download cudli from and verify connectivity that way
5. Note that the default administrator user doesn't have permissions to access the database.  You need to create a user for that purpose. Refer to the help file in Cudli for more information.

Subject: RE: Unity Connection JDBC?
Replied by: Petter Sjolin on 24-09-2009 03:19:07 PM
I have the same problem as described above. Did the problem ever get solved?
I have double checked the list and all checks. I can connect from CUDI without a problem.
I use the following code to try to connect (and have added ifxjdbc.jar to the classpath):
DriverManager.getConnection("jdbc:informix-sqli://cuxn71:20532/UnityDirDb:INFORMIXSERVER=ciscounity", "admin", "password");
The second line throws the same exception a the first post (¿java.sql.SQLException: com.informix.asf.IfxASFException: Attempt to connect to database server (ciscounity) failed.¿, -908)
I have tested with both versions 3.00 JC3 and 3.50 JC4DE of the IBM Informix JDBC driver. But with the same result.
Any help is appreciated, I am out of ideas.

Subject: RE: Unity Connection JDBC?
Replied by: Vinay S on 18-05-2010 10:09:49 AM
Hi Paul/Petter,
                    Did any of you get this working? I am facing the same issues. Pleae help.

Subject: RE: Unity Connection JDBC?
Replied by: Steven Lass on 28-06-2011 10:59:22 AM
Has anyone gotten JDBC to Unity Connection working?  The IBM/Informix forums mention needing the DBPATH specified as a file.


Subject: RE: Unity Connection JDBC?
Replied by: Ravi Narasimhan on 06-07-2011 04:56:11 PM
after failing to get this stuff working using pure jdbc, was able to get it to work using jdbc-odbc bridge. may not work for every one. hope this helps some who can afford to run on windows.

jdbc configuration:
driver: sun.jdbc.odbc.JdbcOdbcDriver
url: jdbc:odbc:unity-ibm-informix;Database=UnityDirDB

odbc configuration

Isolation level(advanced tab): read committed



I tried to use jdbc with CUC 11.5, so far it has not worked, connection string is quite similar to what is mentioned earlier in the thread. Here is the exact string

jdbc:informix-sqli://<ip address>:20532/UnityDirDB:INFORMIXSERVER=ciscounity;user=administrator;password=<password>

actual ip address and password are not given here. The error is as follows

java.sql.SQLException: com.informix.asf.IfxASFException: Attempt to connect to database server (ciscounity) failed.

at com.informix.jdbc.IfxSqliConnect.<init>( ~[ifxjdbc-4.10.jar:4.10.8.SNAPSHOT]

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.8.0_66]

at sun.reflect.NativeConstructorAccessorImpl.newInstance( ~[?:1.8.0_66]

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance( ~[?:1.8.0_66]

at java.lang.reflect.Constructor.newInstance( ~[?:1.8.0_66]

at com.informix.jdbc.IfxDriver.connect( ~[ifxjdbc-4.10.jar:4.10.8.SNAPSHOT]

at java.sql.DriverManager.getConnection( ~[?:1.8.0_66]

at java.sql.DriverManager.getConnection( ~[?:1.8.0_66]

at [classes/:?]

Caused by: com.informix.asf.IfxASFException: Attempt to connect to database server (ciscounity) failed.

at com.informix.util.IfxErrMsg.getLocIfxASFException( ~[ifxjdbc-4.10.jar:4.10.8.SNAPSHOT]

at com.informix.asf.Connection.establishConnection( ~[ifxjdbc-4.10.jar:4.10.8.SNAPSHOT]

at com.informix.asf.Connection.<init>( ~[ifxjdbc-4.10.jar:4.10.8.SNAPSHOT]

at com.informix.jdbc.IfxSqliConnect.<init>( ~[ifxjdbc-4.10.jar:4.10.8.SNAPSHOT]

Note that connection using JdbcOdbcDriver  works


Recognize Your Peers
Content for Community-Ad