cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

CUSP Configuration Snippit with Subinterfaces

2671
Views
0
Helpful
0
Comments
Enthusiast

Cisco's documentation for Cisco Unified SIP Proxy (CUSP) doesn't explain very much about how to configure subinterfaces at the router level for the CUSP Network Module.  Here is a working interface configuration (router side) that the module is able to boot up with:


interface Loopback1
description CUSP Enterprise SIP Network
ip address 10.15.211.2 255.255.255.252
!
interface Loopback2
description CUSP CUBE SIP Network
ip address 10.15.212.2 255.255.255.252

!

interface Integrated-Service-Engine1/0
ip address 10.15.210.2 255.255.255.252
service-module ip address 10.15.210.1 255.255.255.252
service-module ip default-gateway 10.15.210.2
no keepalive
!
interface Integrated-Service-Engine1/0.1
!
interface Integrated-Service-Engine1/0.11
encapsulation dot1Q 11
ip unnumbered Loopback1
!
interface Integrated-Service-Engine1/0.12
encapsulation dot1Q 12
ip unnumbered Loopback2

!
ip route 10.15.210.1 255.255.255.255 Integrated-Service-Engine1/0
ip route 10.15.211.1 255.255.255.255 Integrated-Service-Engine1/0.11
ip route 10.15.212.1 255.255.255.255 Integrated-Service-Engine1/0.12
!
Regarding the configuration documented on CCO, the encapsulation dot1Q 1 native (or any VLAN with the keyword 'native') on the subinterfaces isn't allowed because the native VLAN traffic doesn't get its frames tagged, and tagging is the mechanism whereby IOS correlates the traffic to the NME-522 for any interfaces besides theservice-module ip interface).
While not actually required for the host validation, the static routes have to exist to get traffic to CUSP over the router's backplane.

We're not done yet! Once the router knows how to get the traffic to the NME, the NME itself has to know to be listening on said interfaces.  Here's the matching configuration for the NME:


interface GigabitEthernet 0.1
end interface


interface GigabitEthernet 0.11
ip address 10.15.211.1 255.255.255.252
end interface


interface GigabitEthernet 0.12
ip address 10.15.212.1 255.255.255.252
end interface


interface GigabitEthernet 0.13
ip address 10.15.213.1 255.255.255.252
end interface

At this point you should be able to ping each of these IP's from your network.  Note: the default gateway for all traffic is still theservice-module ip default-gateway.  Without the NME side configuration, CUSP will not allow you to configure sip listen for those IP addresses.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards