cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1601
Views
0
Helpful
1
Comments
Colby Beam
Cisco Employee
Cisco Employee

Initial Configuration

A 'single home fex' is a Nexus 2000 that only has uplinks to a single 5k. Typically you would put the uplinks from the 2k->5k in a port-channel for better performance and redundancy.

[edit]Walk through configuration

Step 1: switch(config)# feature fex <---- turn on feature
Step 2: Next we must create a fex number to allow association. To see which ones fex numbers are already in use. Check the following:

  • show fex
24.09.5010B.1# sh fex
  FEX         FEX           FEX                       FEX
Number    Description      State            Model            Serial
------------------------------------------------------------------------
100        FEX0100                Online    N2K-C2232PP-10GE   SSI14100EHK
102        FEX0102                Online      N2K-C2148T-1GE   FOX1344G3TG
  • show run fex
24.09.5010B.1# sh run fex

!Command: show running-config fex
!Time: Tue Feb 21 09:24:45 2012

version 5.1(3)N1(1a)
feature fex

fex 100
  pinning max-links 1
  description "FEX0100"
fex 101
  pinning max-links 1
  description "FEX0101"
  serial JAF1309AEQP
  diagnostic bootup level extra
fex 102
  pinning max-links 1
  description "FEX0102"

Step 3: Create a fex number:

  • switch(config)# fex 100 <--- assign a fex number (100-199)

Step 4: Next we need to see which ports we are discovering fexes on, that we want to assign. If you see multiple ports with the same serial #, this is the same fex and these need to be grouped together in a port-channel.

  • switch(config)# show interface fex <---- see which ports are connected to fexes
     Fabric      Fabric       Fex                FEX
Fex  Port      Port State    Uplink    Model         Serial
---------------------------------------------------------------
---    Eth1/8    Discovered     1    N2K-C2148T-1GE  ABCDEFGHIJ
---    Eth1/9    Discovered     1    N2K-C2148T-1GE  ABCDEFGHIJ


Step 5: Assign those ports to a port-channel, and setup the association.

  • switch(config-if)# int e1/8-9 <---- go under the interface above
  • switch(config-if)# channel-group 100 <---- assign this port to a port-channel
  • switch(config-if)# int po100 <--- go under the port-channel interface
  • switch(config-if)# switchport mode fex-fabric <---- configure this port to be a fex-fabric type port
  • switch(config-if)# fex associate 100 <----- associate it with the fex number we configured earlier // this has to match for all ports going to the same fex.
  • Fex will come online and you will see the following messages on the terminal.
2011 Oct 29 13:18:57 24.09.5010A.2 %SATCTRL-FEX100-2-SOHMS_ENV_ERROR: FEX-100 Module 1: Check environment alarms.
2011 Oct 29 13:19:12 24.09.5010A.2 %PFMA-2-FEX_STATUS: Fex 100 is online
2011 Oct 29 13:19:12 24.09.5010A.2 %NOHMS-2-NOHMS_ENV_FEX_ONLINE: FEX-100 On-line
2011 Oct 29 13:19:14 24.09.5010A.2 %PFMA-2-FEX_STATUS: Fex 100 is online

Step 6: Check the fex status

switch(config-if)# sh fex
  FEX         FEX           FEX                       FEX
Number    Description      State            Model            Serial
------------------------------------------------------------------------
100        FEX0100                Online      N2K-C2148T-1GE   XXXXXXXXXXX
  • You will now see the interfaces on the 5k. The Nexus 2000 are only configurable from the Nexus 5k as they are remote line cards (fabric extenders)
24.09.5010A.2# sh int status | eg "Eth100"
Eth100/1/1    --                 notconnec 1         full    1000    --
Eth100/1/2    --                 notconnec 1         full    1000    --
Eth100/1/3    --                 notconnec 1         full    1000    --
Eth100/1/4    --                 notconnec 1         full    1000    --
Eth100/1/5    --                 notconnec 1         full    1000    --
Eth100/1/6    --                 notconnec 1         full    1000    --
Eth100/1/7    --                 notconnec 1         full    1000    --
Eth100/1/8    --                 notconnec 1         full    1000    --
Eth100/1/9    --                 notconnec 1         full    1000    --
Eth100/1/10   --                 notconnec 1         full    1000    --
Eth100/1/11   --                 notconnec 1         full    1000    --
Eth100/1/12   --                 notconnec 1         full    1000    --
Eth100/1/13   --                 notconnec 1         full    1000    --
Eth100/1/14   --                 notconnec 1         full    1000    --
Eth100/1/15   --                 notconnec 1         full    1000    --
Eth100/1/16   --                 notconnec 1         full    1000    --
Eth100/1/17   --                 notconnec 1         full    1000    --
Eth100/1/18   --                 notconnec 1         full    1000    --
Eth100/1/19   --                 notconnec 1         full    1000    --
Eth100/1/20   --                 notconnec 1         full    1000    --
Eth100/1/21   --                 notconnec 1         full    1000    --
Eth100/1/22   --                 notconnec 1         full    1000    --

Step 7: Check the port-channel status

switch(config-if)# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members) <---you want to see P as below
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
100   Po100(SU)   Eth      NONE      Eth1/8(P) Eth1/9(P) <---- Nexus 5k - 2k does not support LACP so the protocol will show 'none'
[edit]Summary configuration // Single home fex
switch(config-if)# sh run int po100 membership

!Command: show running-config interface port-channel100 membership
!Time: Sat Oct 29 13:35:34 2011

version 5.0(3)N2(2)

interface port-channel100
  switchport mode fex-fabric
  fex associate 100

interface Ethernet1/8
  switchport mode fex-fabric
  fex associate 100
  channel-group 100

interface Ethernet1/9
  switchport mode fex-fabric
  fex associate 100
  channel-group 100
[edit]Summary vPC // dual home fex configuration
switch(config-if)# sh run int po100 membership

!Command: show running-config interface port-channel100 membership
!Time: Sat Oct 29 13:35:34 2011

version 5.0(3)N2(2)

interface port-channel100
  switchport mode fex-fabric
  fex associate 100 <-------------------- fex # has to match on both 5ks
  vpc 100 <------------------------------ vpc # has to match on both 5ks

interface Ethernet1/8
  switchport mode fex-fabric
  fex associate 100
  channel-group 100

interface Ethernet1/9
  switchport mode fex-fabric
  fex associate 100
  channel-group 100
Comments
tcampanale
Beginner
Beginner

This is in a nice format and very concise.

Thank you,

Tony.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: