Introduction
FabricPath switching allows multipath networking at the Layer 2 level without using the Spanning Tree Protocol (STP). FabricPath encapsulation facilitates MAC address mobility and server virtualization, which means that you can physically move the Layer 2 node but retain the same MAC address and VLAN association for the virtual machine. With FabricPath, you use the Layer 2 Intermediate System-to-Intermediate System (IS-IS) protocol for a single control plane that functions for unicast, broadcast, and multicast packets. There is no need to run STP because the domain is purely Layer 2. FabricPath Layer 2 IS-IS is a dynamic link-state routing protocol that detects changes in the network topology and calculates loop-free paths to other nodes in the network.
FabricPath Interfaces
FabricPath edge port - FabricPath edge ports are interfaces at the edge of the FabricPath domain. These interfaces run Classic Ethernet, or CE, and behave exactly like normal Ethernet ports.
FabricPath core port - FabricPath core ports always forward Ethernet frames encapsulated in a FabricPath header.
FabricPath VLANs
By default, when you create VLANs on the Nexus 7000, the VLAN operates in Classic Ethernet, or CE, mode. One of the first tasks you perform when configuring FabricPath is to define one or more VLANs as FabricPath-mode VLANs. Only FabricPath-mode VLANs are carried over FabricPath interfaces.
Configuring FabricPath Switching
Within the FabricPath network, the software uses Layer 2 IS-IS to transmit topology information. The switches on the edge of the network, which use conversational MAC address learning, do not have to learn all the MAC addresses in the network. You must install the FabricPath feature set before you enable FabricPath on the switch. This example shows how to install and enable the FabricPath feature set on a switch:
switch# configure terminal
switch(config)# install feature-set fabricpath
switch(config)# feature-set fabricpath
switch(config)# fabricpath switch-id 25
switch(config)# save running-config startup-config
Under the interface configuration enter the command:
switch(config-if)# switchport mode fabricpath
IS-IS Adjacency Issue
Refer to the following diagram

In this example the Switches are connecting to each other via Port Channel interfaces. Switch01 is able to establish FabricPath IS-IS adjacency to Switch03 but not with Switch02. Also Switch03 is not able to establish adjacency to Switch02. Following are the configuration on Switch01 and Switch 02.
Switch01# show running-config fabricpath
feature-set fabricpath
system default switchport fabricpath
vlan 2000-2900 mode fabricpath
interface port-channel2012
switchport mode fabricpath
interface port-channel2013
switchport mode fabricpath
fabricpath domain default
fabricpath timers allocate-delay 5
fabricpath timers linkup-delay 5
fabricpath switch-id 31
Switch01# show running-config interface p02012
interface port-channe12012
description P02012 switchport
switchport mode fabricpath
mtu 9216
Switch01# show running-config interface ethernet 16/1
interface Ethernet16/1
mtu 9216
udld aggressive
channel-group 2012 mode active
no shutdown
Switch01# show running-config interface ethernet 16/2
interface Ethernet16/2
mtu 9216
udld aggressive
channel-group 2012 mode active
no shutdown
Switch01# show running-config interface p02013
interface port-channe12013
description P02013 switchport
switchport mode fabricpath
mtu 9216
Switch01# show running-config interface ethernet 16/3
interface Ethernet16/3
mtu 9216
udld aggressive
channel-group 2013 mode active
no shutdown
Switch01# show running-config interface ethernet 16/4
interface Ethernet16/4
mtu 9216
udld aggressive
channel-group 2013 mode active
no shutdown
Switch02# show running-config fabricpath
feature-set fabricpath
vlan 2000-2900 mode fabricpath
interface port-channel2021
switchport mode fabricpath
interface port-channel2023
switchport mode fabricpath
fabricpath domain default
fabricpath timers allocate-delay 5
fabricpath timers linkup-delay 5
fabricpath switch-id 32
Switch02# show running-config interface p02021
interface port-channe12021
description P02021 switchport
switchport mode fabricpath
mtu 9216
Switch02# show running-config interface ethernet 16/1
interface Ethernet16/1
udld aggressive
channel-group 2021 mode active
no shutdown
Switch02# show running-config interface ethernet 16/2
interface Ethernet16/2
mtu 9216
udld aggressive
channel-group 2021 mode active
no shutdown
Switch02# show running-config interface p02023
interface port-channe12023
description P02023 switchport
switchport mode fabricpath
mtu 9216
Switch02# show running-config interface ethernet 16/3
interface Ethernet16/3
udld aggressive
channel-group 2023 mode active
no shutdown
Switch02# show running-config interface ethernet 16/4
interface Ethernet16/4
mtu 9216
udld aggressive
channel-group 2023 mode active
no shutdown
Resolution
Despite the PortChannel and Ethernet interface configuration being the same for all the switches in the topology; only Switch01 and Switch03 are able to make IS-IS adjacency because they have "system default switchport fabricpath" command configured. This command changes the default behavior of every interface on the switch to FabricPath. However it is not necessary to have this command configured globally. In our above example to make adjacency work for Switch02 we can either configure command "switchport mode fabricpath" under all portchannel 2023 and 2021 member interfaces or we can use the global command "system default switchport fabricpath".
References
Configuring FabricPath Switching
Fabricpath ISIS adjacency can't be formed
Nexus 7000 FabricPath