10-10-2022 09:49 AM
Hello All !
I use FabricPath network and two box Nexus 5672 in aggregation layer in DC-1:
My test design:
aggr-1 (HSRP vlan206) ----Port-Channel2----aggr-2 (HSRP vlan206)
works between them vpc+ and i can run HSRP in Vlan206, but on two boxes I see HSRP Active.
My config:
aggr-1 - Config:
# sh vlan id 206
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
206 TEST active Po2, Po17, Po18, Eth1/3, Eth1/4
Eth1/5, Eth1/6, Eth1/17, Eth1/18
Eth2/5, Eth2/6, Eth100/1/18
VLAN Type Vlan-mode
---- ----- ----------
206 enet FABRICPATH
Primary Secondary Type Ports
------- --------- --------------- -------------------------------------------
##
interface port-channel1
description ## peer-keepalive
no switchport
speed 10000
vrf member PKAL
ip address 192.0.2.1/30
dc-1-aggr-1# sh run int po2
!Command: show running-config interface port-channel2
!Time: Mon Oct 10 19:38:10 2022
version 7.3(11)N1(1)
interface port-channel2
description ## peer-link
switchport mode fabricpath
switchport trunk allowed vlan 199-206,243-244,250-254,2004
spanning-tree port type network
speed 10000
vpc peer-link
bfd fabricpath interval 50 min_rx 50 multiplier 3
##
#sh vpc:
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 1
vPC+ switch id : 1
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
vPC fabricpath status : peer is reachable through fabricpath
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : primary, operational secondary
Number of vPCs configured : 138
Peer Gateway : Enabled
Peer gateway excluded VLANs : -
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Operational Layer3 Peer-router : Enabled
Auto-recovery status : Enabled (timeout = 240 seconds)
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po2 up 1,9,199-206,243-244,249-254,2004,2006,4050
vPC status
---------------------------------------------------------------------------
id Port Status Consistency Reason Active vlans vPC+ Attrib
-- ---------- ------ ----------- ------ ------------ -----------
##
interface Vlan206
description ## TEST
no shutdown
bfd interval 50 min_rx 60 multiplier 3
no ip redirects
ip address 10.1.206.2/24
no ipv6 redirects
ip router ospf backbone area 0.0.0.0
hsrp version 2
hsrp 206
preempt
priority 200
ip 10.1.206.1
##
*:IPv6 group #:group belongs to a bundle
P indicates configured to preempt.
|
Interface Grp Prio P State Active addr Standby addr Group addr
Vlan206 206 200 P Active local unknown 10.1.206.1 (conf)
#############
aggr-2: - Config
sh vlan id 206
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
206 TEST active Po2, Po17, Po18, Eth1/3, Eth1/4
Eth1/5, Eth1/6, Eth1/17, Eth1/18
Eth2/5, Eth2/6, Eth100/1/18
VLAN Type Vlan-mode
---- ----- ----------
206 enet FABRICPATH
Primary Secondary Type Ports
------- --------- --------------- -------------------------------------------
###
interface port-channel1
description ## peer-keepalive
no switchport
speed 10000
vrf member PKAL
ip address 192.0.2.2/30
dc-1-aggr-2# sh run int po2
!Command: show running-config interface port-channel2
!Time: Mon Oct 10 19:42:52 2022
version 7.3(11)N1(1)
interface port-channel2
description ## peer-link
switchport mode fabricpath
switchport trunk allowed vlan 199-206,243-244,250-254,2004
spanning-tree port type network
speed 10000
vpc peer-link
###
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 1
vPC+ switch id : 1
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
vPC fabricpath status : peer is reachable through fabricpath
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : secondary, operational primary
Number of vPCs configured : 138
Peer Gateway : Enabled
Peer gateway excluded VLANs : -
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Operational Layer3 Peer-router : Enabled
Auto-recovery status : Enabled (timeout = 240 seconds)
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po2 up 1,9,199-206,243-244,249-254,2004,2006,4050
###
version 7.3(11)N1(1)
interface Vlan206
description ## TEST
no shutdown
bfd interval 50 min_rx 60 multiplier 3
no ip redirects
ip address 10.1.206.3/24
no ipv6 redirects
ip router ospf backbone area 0.0.0.0
hsrp version 2
hsrp 206
ip 10.1.206.1
###
# sh hsrp br
*:IPv6 group #:group belongs to a bundle
P indicates configured to preempt.
|
Interface Grp Prio P State Active addr Standby addr Group addr
Vlan206 206 100 Active local unknown 10.1.206.1 (conf)
###
aggr-1:
# sh int vl206
Vlan206 is up, line protocol is up
Hardware is EtherSVI, address is 8c60.4f2d.bf7c
Description: ## VDI-TEST
Internet Address is 10.1.206.2/24
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
# sh mac address-table vlan 206
Legend:
* - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
age - seconds since last seen,+ - primary entry using vPC Peer-Link
VLAN MAC Address Type age Secure NTFY Ports/SWID.SSID.LID
---------+-----------------+--------+---------+------+----+------------------
* 206 0000.0c9f.f0ce static 0 F F sup-eth2
* 206 001e.7a20.e55c dynamic 1800 F F Po18
* 206 001f.9e2b.970a dynamic 610 F F Po17
* 206 8c60.4f35.2c41 static 0 F F 12.0.0
##
aggr-2:
# sh int vl206
Vlan206 is up, line protocol is up
Hardware is EtherSVI, address is 8c60.4f35.2c41
Description: ## VDI-TEST
Internet Address is 10.1.206.3/24
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
# sh mac add vlan 206
Legend:
* - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
age - seconds since last seen,+ - primary entry using vPC Peer-Link
VLAN MAC Address Type age Secure NTFY Ports/SWID.SSID.LID
---------+-----------------+--------+---------+------+----+------------------
* 206 0000.0c9f.f0ce static 0 F F sup-eth2
* 206 001e.7a20.e55c dynamic 10 F F Po18
* 206 001f.9e2b.970a dynamic 10 F F Po17
* 206 8c60.4f2d.bf7c static 0 F F 11.0.0
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide