cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
243
Views
0
Helpful
3
Replies
Highlighted

Upgrading Cisco 93180YC-EX firmware

Hi,

 

I want  to upgrade the firmware for the above switches to nxos.9.3.3, most of them are currently running on version nxos.7.0.3.I4.7.bin and others are on similar major release but different minor release. 

 

is this a straight upgrade or do I need to follow a path? does anyone know where to check the upgrade paths?

 

Kind regards,

3 REPLIES 3
Highlighted
Collaborator

Hi @Mohammadqasimkhan96040 

The upgrade guides and release notes of target version is the place to check:

https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus9000/sw/93x/upgrade/guide/b-cisco-nexus-9000-nx-os-software-upgrade-downgrade-guide-93x/b-cisco-nexus-9000-nx-os-software-upgrade-downgrade-guide-93x_chapter_0111.html 

"""

  • When upgrading to Cisco NX-OS Release to 9.3(x) from any release prior to 7.0(3)I2(3) an intermediate upgrade to 7.0(3)I4(x), 7.0(3)I5(x), 7.0(3)I6(x), or 7.0(3)I7(x) is required. We recommend using Cisco NX-OS Release 7.0(3)I4(8) or 7.0(3)I7(4) as the interim release to aid in a smooth migration.

"""

 

So you can upgrade directly from 7.0.3.I4 to 9.3.

 

Stay safe,

Sergiu

 

 

Highlighted

Hi Sergiu,

 

I know its a little deviation from the original question but Wondering, how about the EPLD upgrade? am I OK to upgrade straight  9.3.3 from 7.x? is there a upgrade path available somewhere? as I looked at the release notes and can;t eem to find it in there.

is there any gotcha that I need to be aware of?

 

kind regards

Highlighted

Hi Mohammad!

There is no upgrade path for EPLD upgrades specifically. The only upgrade path you would need to worry about is the NX-OS upgrade path (which, in your particular scenario, is a straight disruptive upgrade from 7.0(3)I4(x) to 9.3(3)).

As far as caveats to the upgrade go, all caveats are documented in the "Cisco NX-OS Software Upgrade Guidelines" section of the Cisco Nexus 9000 Series NX-OS Software Upgrade and Downgrade Guide, Release 9.3(x) document. I recommend reading through this section prior to the upgrade to verify whether any of these caveats are applicable to your environment.

I hope this helps - thank you!

-Christopher