cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2980
Views
0
Helpful
16
Replies
Travis Lessing
Beginner

Connect to sandbox in RDP session

I have VMs set up in a lab environment and need an application server to be able to communicate with the sandbox, but the VPN connection fails saying that

Vpn establishment capability from a remote desktop is disabled.


Is there any way around this? Can we get a Client Profile to allow us to connect from in an RDP session?

thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Great,

Thank you! Still working with the network team. We may need to pull you into webex to try and replicate the issue first hand, since we've having difficulty replicating this issue.

One last thing to try, could you please uninstall AnyConnect and download it from here: https://developer.cisco.com/site/devnet/sandbox/anyconnect/

This will ensure that we're using the same version, and it's not an AnyConnect version issue. I don't think that it is, but it's worth a try.

I will get back to you soon with more details.

Thanks!

Jacob

View solution in original post

16 REPLIES 16
jacoadam
Contributor

Hello Travelssing,

Thanks for posting. This isn't someting we've run into before, and we can look into implementing this feature. For my clarity (and so I can replicate your issue) could you please let me know which lab you've connected too, and which network it was on?

Thanks!
Jacob

Hi Jacob,

we are connecting to Collaboration 9.1 --> CUCM Publisher 9.1 and the address it gives to connect to is

128.107.93.228:20106

Great, Thanks!

I'll have a look at this today and get back with you!

Best,

Jacob

Hello travlessing!

So I've made a reservation of the Collaboration 9.1 lab on an Windows Server 2012 VM when I was connected through RDP. When I connected the VPN on the windows client I was accessing through RDP, I had no errors, I was able to access all resources within the reservation.

The first thing I'd ask you to do is make another reservation and see if you can replicate the issue.

On top of that, it would be helpful if you provided more details on exactly how you're seeing this error. Also, what OS are you using Remote Desktop from? What version of AnyConnect are you using? Having as many details as possible will make it a bit easier to troubleshoot!

Please let me know if you've got any additional questions!

Thanks!

Jacob

Hi Jacob,

It wont let me request a new reservation while one is active (we connected from local machine without RDP to perform some of our needed testing, but still need the VM to fully test) and it will take a little time to recreate the environment, so I will try recreating in the morning tomorrow. But we the VM is 2012 R2 and the anyconnect client 4.4.03034. This is the log:

12:40:38 PM Establishing VPN session...

     12:40:38 PM Establishing VPN - Initiating connection...

     12:40:39 PM    VPN establishment capability from a remote desktop is disabled.  A VPN connection will not be established.

     12:40:39 PM AnyConnect was not able to establish a connection to the specified secure gateway. Please try connecting again.

     12:40:40 PM    Ready to connect.

That is very interesting - to be fair I am using anyconnect 4.3.04027 and don't see the error.

Just one more question - do you have "Terminal Server" enabled for that remote desktop connection? That service is what allows you to connect more than 2 remote desktop sessions to a Windows computer. It seems that may be blocked by AnyConnect, while using the standard, built in RDP service is not blocked.

Does this make sense?

Thanks!
Jacob

We tried to do a new reservation this morning and got the same error through anyconnect. We don't have Terminal Server enabled, just using the standard RDP into the server

Travis Lessing
Beginner

Hi, we are still facing the issue. Can anything be done? All the information I see online suggests that this is a server-side configuration, and requires a change to the profile in ASA.

thanks

Hello Travlessing,

I'm going to check with a wider distribution of people to see who else can replicate this issue. I will also contact our Network Team and ask them to see how they can adjust the VPN profile to allow VPNs over Remote Desktop Sessions. I will get back with you once I've got more information!

Thanks!

Jacob

Hi Jacob,

Any Luck?

Hello Travelessing,

Have made some progress. We've got our network team looking into this issue and working to enable Remote Desktop functionality.


Apologies for the slow progress - hopefully we'll have you working soon!

Thanks!
Jacob

Hello!

Could you please provide your DevNet username that has reserved these labs?

Thanks!

Jacob

edited

Great,

Thank you! Still working with the network team. We may need to pull you into webex to try and replicate the issue first hand, since we've having difficulty replicating this issue.

One last thing to try, could you please uninstall AnyConnect and download it from here: https://developer.cisco.com/site/devnet/sandbox/anyconnect/

This will ensure that we're using the same version, and it's not an AnyConnect version issue. I don't think that it is, but it's worth a try.

I will get back to you soon with more details.

Thanks!

Jacob

View solution in original post

Content for Community-Ad