cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
Avisos
Developers-novedades
2693
Visitas
35
ÚTIL
11
Respuestas
José Corniel A
Beginner

Inconvenientes DHCP-VLAN

Buenas noches estimados, nuevamente por aqui pidiendo su apoyo.

 

Para resumirlo lo mas que se pueda, tengo dos servidores DHCP basados en windows, y en mi CoreSW tengo apuntando IP Helper Address a dichos servidores, cada vlan tiene un pool configurado en el Server DHCP

 

EL PROBLEMA:  Resulta que tengo dos Vlans que estan recibiendo direcciones IP que no pertenecen a su POOL, por ejemplo:

 

Vlan16  Red  172.16.10.0/24: Observo en su POOL que esta asignando direcciones del pool 172.16.20.0 

VLAN20 Red 172.16.20.0/ 24 Observo en su POOL que esta asignando direcciones del POOL 172.16.10.0

 

No comprendo que pueda estar pasando, ya que los equipos que reciben esas direcciones , sus puertos estan asignados a las VLANS que corresponda.

 

Me pueden orientar si debo revisar en mis Switchs , o si definitivamente el inconveniente lo tiene el DHCP server, que tambien revise y veo que todos los POOL estan bien configurados y sin problemas.

 

 

Espero me haya explicado y me puedan orientar, muchas gracias de antemano!

 

Cordialmente,

11 RESPUESTAS 11
Julio E. Moisa
VIP Mentor

Hola, podria ser un bug, revisa en el servidor si existe algun parametro.

Yo te recomiendo que utilices unicamente el servidor windows como DHCP.

 

Toma en consideracion que el IP Helper se utiliza cuando el DHCP es externo o que se encuentra en otro router o servidor, si la red creada esta en el mismo router donde esta el dhcp entonces no es necesario el ip helper, porque los dispositivos a traves de broadcast buscaran el dhcp.

 

Saludos




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<
Javier Acuña
VIP Engager

Saludos @jose gracias por comunicarte con la comunidad de Cisco, lo que debes hacer es lo siguiente valida en tu router que este ejecutando la solicitud en la interface que apunta al servidor DHCP,  ubica al personal de servidores windows y que te validen el scope de ambas vlan, si las tienen bien declaradas.

Recuerda que en el Core debes tener apuntando en la VLan al IP helper  address

Para descartar la falla crea un dhcp en tu router para colocarlo en funcionamiento y verifica si este trabaja de la manera correcta.

 

Podrias compartir la Configuración de Tu Vlan ?

 

interface Vlan16
description Vlan16
ip address 172.16.10.1 255.255.255.0
ip helper-address 172.xx.xx.xx
end

 

 

Recuerda Calificar esta o cualquier Respuesta positiva de los expertos ya que esto motiva a continuar el apoyo en la comunidad

 

hiarteag
Community Manager

Gracias por la asistencia Julio y Javier 

José Corniel A
Beginner

Buen dia estimados, nuevamente les escribo para que por favor me orienten!!

 

Retomando el tema, revisando los logs activando el monitor del Swcore donde se manejan las Vlans, se observa lo siguiente:

 

076470: Apr 21 09:40:32.696: EIGRP-IPv4(1): Neighbor 172.16.10.1. not on common subnet for Vlan20

076471: Apr 21 09:40:46.035: EIGRP-IPv4(1): Neighbor 172.16.20.1 not on common subnet for Vlan16

 

Esto es lo que pueda estar ocasionando el problema? No entiendo como atacarlo...

 

 

 

Hola José,

 

Las opciones son que tengas una ip secundaria en la interfaz que forma vecindad con tu otro equipo que corre eigrp o bien esté recibiendo paquetes hello de otro segmento de red que no pertenecen a la otra punta. Puedes leer este documento en donde te explica que sucede y cómo corregirlo.

https://www.cisco.com/c/es_mx/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/13674-15.html

 

Espero que la información haya sido útil y si no tienes más preguntas recuerda cerrar el topic, seleccionando la respuesta como "Respuesta correcta"
**Please rate the answer if this information was useful***
**Por favor si la información fue util marca esta respuesta como correcta**
José Corniel A
Beginner

Estuve buscando informacion al respecto, pero no veo un ejemplo de mi caso,  si mi Core maneja las vlans e internamente no tengo un EIGRP en conflicto...

Saludos Jose Corniel, podrías compartirnos la configuración de las vlans y el EIGRP entre el Core y el Sw de la capa acceso.

 

 

Atentos a tus comentarios se despide.

Que tal estimados, les indico la configuracion real que esta funcionando actualmente. 

 

 

Lo que no entiendo es por que hay dos procesos EIGRP, siempre ha estado asi y no me habia alertado esos errores. adicionalmente les adjunto la topologia real;

 

top.PNG

 

 

 

router eigrp 172
network 170.10.0.0
network 172.20.0.0
network 172.20.25.0 0.0.0.255
passive-interface default
no passive-interface Vlan32
no passive-interface Vlan33
!
!
router eigrp 1
network 170.10.0.0
network 172.20.0.0
network 172.20.25.0 0.0.0.255
passive-interface Vlan32
passive-interface Vlan33

 

VLANS en conflicto configuracion

 

interface Vlan72
description == Planta de Embutidos ==
ip address 172.20.72.2 255.255.255.0
ip helper-address 172.20.5.31
ip helper-address 172.20.5.13
standby 72 ip 172.20.72.254
standby 72 priority 150
standby 72 preempt

 

interface Vlan11
ip address 172.20.11.1 255.255.255.0
ip access-group nonetwork1 in
ip helper-address 172.20.5.31
ip helper-address 172.20.5.13
ip accounting output-packets

 

EdAdmin-P01#sh eigrp pro
EdAdmin-P01#sh eigrp protocols
EIGRP-IPv4 Protocol for AS(172)
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
NSF-aware route hold timer is 240
EIGRP NSF disabled
NSF signal timer is 20s
NSF converge timer is 120s
Router-ID: 172.21.30.10
Topology : 0 (base)
Active Timer: 3 min
Distance: internal 90 external 170
Maximum path: 4
Maximum hopcount 100
Maximum metric variance 1

EIGRP-IPv4 Protocol for AS(1)
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
NSF-aware route hold timer is 240
EIGRP NSF disabled
NSF signal timer is 20s
NSF converge timer is 120s
Router-ID: 172.21.30.10
Topology : 0 (base)
Active Timer: 3 min
--More--
083181: Apr 22 08:18:51.831: EIGRP-IPv4(1): Neighbor 172.20.11.1 not on common subnet for Vlan72
Distance: internal 90 external 170
Maximum path: 4
Maximum hopcount 100
Maximum metric variance 1

 

 

EdAdmin-P01#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(172)
EIGRP-IPv4 Neighbors for AS(1)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 172.20.1.27 Vl1 12 12w2d 6 200 0 37760
0 170.10.40.104 Vl170 12 12w2d 6 200 0 48120

 

 

 

Siguen los inconvenientes AYUDA!

José Corniel A
Beginner

 Buenas tardes estimados,

 

Todo este inconveniente fue generado por un host conectado que estaba haciendo LOOPs en la red. Es bastante extraño pero el host instalado por otro personal tenia dos tarjetas de red y tambien no pertenecia a nuestros segmentos. Proveniente de una red de camaras.. Al desconectarlo todo volvio a la normalidad.

 

Muchas gracias por el apoyo!

Muchas  José Corniel, por documentarnos tu falla, este dispositivo tenia alguna dirección ip definidas como principal en la Vlan Layer 3 ?

 

Saludos Cordiales.

Slotvegas
Beginner

Muchas gracias por toda la información