cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
Avisos
Ask Me Anything - Webex Bots
38806
Visitas
0
ÚTIL
15
Respuestas
Luis Garzonr
Beginner

Acceder a a PC/Servidor mediante Escritorio Remoto con RV042

Buenas tardes a todos,

Compré un Router Cisco RV042-V03, con 2 WAN y 4 Puertos LAN. Estoy intentando configurar este router para poder acceder a un servidor desde internet a traves de escritorio remoto de windows (fuera de la red local) mediante las IP's publicas asignadas por mis ISP (proveedores de servicio de internet), pero desafortunadamente no lo he logrado. Este router lo compré con el fin de que mi servidor tenga siempre internet para yo poder conectarme a este desde fuera, mediante RDP con cualquiera de las ip's publicas habilitadas; en el caso que falle alguno de los servicios de mis proveedores de internet.

Situación actual:

* Red local: Tengo un servidor con windows server 2008 configurado con la siguiente IP estática:

     Ip address: 192.168.0.111

     Subnet: 255.255.255.0

     Gateway: 192.168.0.1

     DNS1: 200.75.51.xxx

     DNS2: 200.75.51.xxz

- Tengo dos proveedores de internet (ISP) con las siguientes configuraciones en sus modems:

     ISP1

     Subnet: 255.255.255.0

     Gateway: 192.168.0.1

     DNS1: 200.75.51.xxx

     DNS2: 200.75.51.xxz

     Tengo 2 ip publicas apuntando a mi servidor y a un DVR, de la siguiente forma

     IP publica 190.27.80.XXX a mi servidor 192.168.0.111 (se puede acceder desde escritorio remoto)

     IP publica 190.45.90.XXX apunta a mi DVR 192.168.0.200 (el cual se puede acceder desde un explorador de internet)

     ISP2

     Subnet: 255.255.255.0

     Gateway: 190.146.64.1

     DNS1: 200.118.2.XXX

     DNS2: 200.118.2.XXX

     Igualmente tengo una IP publica disponible para utilizar y poder acceder a mi servidor

* Router Cisco en modo Gateway:

     LAN Settings

     Device IP address: 192.168.0.10

     Subnet: 255.255.255.0

     WAN settings:

               WAN1 (ISP2):

                    WAN connection type: Static

                    WAN IP address: 190.146.64.XX y el resto de configuracion es la misma descrita anteriormente para el ISP2

      y lo mismo para la WAN2 con el ISP1.

Con esta configuracion es posible que los PC's conectados a la red local tengan acceso a internet (los equipos estan por DHCP y el router les asigna la IP a estos). La gateway del servidor la cambie a la 192.168.0.10 (la LAN del Router) para que tenga acceso a internet, pero ahora no puedo acceder a este desde escritorio remoto desde fuera ni desde la red local, mediante la IP publica ni con la IP estatica del servidor. Si le doy ping al servidor desde un PC dentro de la red local, este me responde correctamente y ademas puedo ver los archivos del servidor. He intentado configurar one-to-one NAT para que el router redireccione al servidor, pero no me ha funcionado, no se como hacerlo ya que soy nuevo en este tema. Cúal seria la configuracion correcta de mis equipos para que esto funcione, y si es posible que este router me sirva para lo que necesito?

Muchas gracias y espero sus prontas opiniones sobre este tema.

2 SOLUCIONES ACEPTADAS

Soluciones aceptadas
jonatrod
Rising star

Hola Luis, soy parte de la comunidad de soporte de Cisco,si quieres accesar desde internet a tu servidor y a tu grabador, debes de seguir una serie de pasos muy simples con el fin de redireccionar tus puertos.

1. Para el acceso RDP, primero asegurate que tu(s) ISP no tengan el puerto 3389 bloqueado, el cual vamos a utilizar para el acceso remoto

2. Vamos a ir a la interfaz virtual del router y camos a Firewall>General y habilitamos la opción de "Remote management" y deshabilitamos la opción de "Block Wan Request".

3. Vamos a Firewall>Access rules>add a new rule.  Aquí vamos a crear las dos reglas de direccionamiento, una para tu grabador y otra para tu acceso remoto.

A) Acceso remoto:

     Click en Service management:

     Service Name: RDP

     Protocol: TCP

     Port Range: 3389 to 3389

     Add to list > Save settings > Exit

   Ya creada la regla volvemos a Firewall > Access rule y llenamos los espacios correspondientes

     Action: Allow

     service RDP[TCP/3389-3389]

     Source interface: La ip pública por la que vas a accesar

     Source IP: Any

     Destination IP: IP de tu servidor

B) Grabador: Suponiendo que lo vas a agregar en el puerto HTTP (80)

     Action: Allow

     service HTTP[TCP/80-80]

     Source interface: La ip pública por la que vas a accesar

     Source IP: Any 

     Destination IP: IP de tu grabador

4. Dar click en Save settings

Y de esta forma ya debería de funcionar, espero te sea de utilidad

Por favor califica las respuestas útiles con estrellas, y si la respuesta te fue útil marcala como Respondida

Saludos

Johnnatan Rodriguez Miranda.

Cisco Network Support Engineer.

“Please rate useful posts so other users can benefit from it” Greetings, Johnnatan Rodriguez Miranda. Cisco Network Support Engineer.

Ver la solución en mensaje original publicado

Hola Luis, con respecto a tu servidor, asegurate que el firewall no este bloqueando los “Request” RDP que vienen desde la WAN, ya que podría ser que acepte conexiones locales y que el firewall bloquee las conexiones que vienen desde afuera (WAN), puedes hacer algunas pruebas con el firewall abajo, sin embargo no te recomiendo que le dejes el firewall desactivado por mucho tiempo, la segunda opción, como te comenté anteriormente contacta a tu ISP y averigua que puertos tienes bloqueados, algunos ISP bloquean estos puertos por seguridad.

Con respectoa tu grabador, intenta crear una regla similar pero con una pequeña diferencia,lo primero que vamos a hacer Luis será borrar la regla que habiamos creado para el grabador, y creamos la misma regla pero en vez de utilizar el puerto 80, vamos a utilizar el puerto 8081.

Click en Service management:

  Service Name: DVR

  Protocol: TCP

  Port Range: 8081 to 8081

  Add to list > Save settings > Exit

Ya creada la regla volvemos a Firewall > Access rule y llenamos los espacios correspondientes

  Action: Allow

  service DVR[TCP/8081-8081]

  Source interface: La ip pública por la que vas a accesar

  Source IP: Any

  Destination IP: IP de tu grabador.

Y para accesar a tu grabador, en el browser de tu explorador de internet, ponemos la ip de tu grabador , dos puntos y seguidamente el puerto 8081, de la siguiente forma:  http://xx.xx.xx.xx:8081 , y nuevamente te recuerdo llamar a tu ISP y preguntar por los puertos.

Gracias

Por favor califica las respuestas útiles con estrellas, y si la respuesta te fue útil marcala como Respondida

Saludos

Johnnatan Rodriguez Miranda.

Cisco Network Support Engineer.

“Please rate useful posts so other users can benefit from it” Greetings, Johnnatan Rodriguez Miranda. Cisco Network Support Engineer.

Ver la solución en mensaje original publicado

15 RESPUESTAS 15
jonatrod
Rising star

Hola Luis, soy parte de la comunidad de soporte de Cisco,si quieres accesar desde internet a tu servidor y a tu grabador, debes de seguir una serie de pasos muy simples con el fin de redireccionar tus puertos.

1. Para el acceso RDP, primero asegurate que tu(s) ISP no tengan el puerto 3389 bloqueado, el cual vamos a utilizar para el acceso remoto

2. Vamos a ir a la interfaz virtual del router y camos a Firewall>General y habilitamos la opción de "Remote management" y deshabilitamos la opción de "Block Wan Request".

3. Vamos a Firewall>Access rules>add a new rule.  Aquí vamos a crear las dos reglas de direccionamiento, una para tu grabador y otra para tu acceso remoto.

A) Acceso remoto:

     Click en Service management:

     Service Name: RDP

     Protocol: TCP

     Port Range: 3389 to 3389

     Add to list > Save settings > Exit

   Ya creada la regla volvemos a Firewall > Access rule y llenamos los espacios correspondientes

     Action: Allow

     service RDP[TCP/3389-3389]

     Source interface: La ip pública por la que vas a accesar

     Source IP: Any

     Destination IP: IP de tu servidor

B) Grabador: Suponiendo que lo vas a agregar en el puerto HTTP (80)

     Action: Allow

     service HTTP[TCP/80-80]

     Source interface: La ip pública por la que vas a accesar

     Source IP: Any 

     Destination IP: IP de tu grabador

4. Dar click en Save settings

Y de esta forma ya debería de funcionar, espero te sea de utilidad

Por favor califica las respuestas útiles con estrellas, y si la respuesta te fue útil marcala como Respondida

Saludos

Johnnatan Rodriguez Miranda.

Cisco Network Support Engineer.

“Please rate useful posts so other users can benefit from it” Greetings, Johnnatan Rodriguez Miranda. Cisco Network Support Engineer.

Hola Jonathan, gracias por tu respuesta.

Hice todo lo que me indicaste en la configuración de mi router. La configuración del firewall-general quedó de la siquiente forma:

Y las Access Rules como muestro a continuación:

1. Con esta configuración puedo accesar a través de Escritorio Remoto a mi servidor utilizando la IP pública de mi ISP1 (WAN1) estando conectado a mi red local, pero cuando intento hacerlo desde fuera (conectado a una red WiFi distinta a la local) el servidor no me da respuesta. El módem de mi ISP1 me lo dejaron configurado en modo bridge, al menos eso fue lo que me dijeron. Estaba pensando si de pronto habría que decirles que me configuren este módem redireccionando esa IP pública mediante NAT o DMZ a la IP LAN de mi router?

2. En cuanto a mi DVR, cuando escribo la misma IP pública en el navegador de internet (estando conectado a mi red local, porque desde fuera no da respuesta), se abre es la página de inicio de configuración del router RV042. A qué se devera esto?

Gracias por tu apoyo,

Hola Luis, con respecto a tu servidor, asegurate que el firewall no este bloqueando los “Request” RDP que vienen desde la WAN, ya que podría ser que acepte conexiones locales y que el firewall bloquee las conexiones que vienen desde afuera (WAN), puedes hacer algunas pruebas con el firewall abajo, sin embargo no te recomiendo que le dejes el firewall desactivado por mucho tiempo, la segunda opción, como te comenté anteriormente contacta a tu ISP y averigua que puertos tienes bloqueados, algunos ISP bloquean estos puertos por seguridad.

Con respectoa tu grabador, intenta crear una regla similar pero con una pequeña diferencia,lo primero que vamos a hacer Luis será borrar la regla que habiamos creado para el grabador, y creamos la misma regla pero en vez de utilizar el puerto 80, vamos a utilizar el puerto 8081.

Click en Service management:

  Service Name: DVR

  Protocol: TCP

  Port Range: 8081 to 8081

  Add to list > Save settings > Exit

Ya creada la regla volvemos a Firewall > Access rule y llenamos los espacios correspondientes

  Action: Allow

  service DVR[TCP/8081-8081]

  Source interface: La ip pública por la que vas a accesar

  Source IP: Any

  Destination IP: IP de tu grabador.

Y para accesar a tu grabador, en el browser de tu explorador de internet, ponemos la ip de tu grabador , dos puntos y seguidamente el puerto 8081, de la siguiente forma:  http://xx.xx.xx.xx:8081 , y nuevamente te recuerdo llamar a tu ISP y preguntar por los puertos.

Gracias

Por favor califica las respuestas útiles con estrellas, y si la respuesta te fue útil marcala como Respondida

Saludos

Johnnatan Rodriguez Miranda.

Cisco Network Support Engineer.

“Please rate useful posts so other users can benefit from it” Greetings, Johnnatan Rodriguez Miranda. Cisco Network Support Engineer.

Muchas gracias Jonathan, he logrado configurar el router para que sea este el que administre las ip's de mis equipos. Tu información me fue de gran ayuda! Siempre es importante revisar las reglas de acceso del Firewall del router y del servidor que en mi caso era lo que me hacia falta. Gracias!!

Buen dia ojala me pueda apoyar en informarme como hizo eso yo no puedo direccionar el puerto del escritorio remoto y al recosar el rputer no me reconoce las ip de las maquinas vamos no me administra las ip, ojala me pueada apoyar saludos

Buena tarde, cómo tiene configurado el router? agregó las reglas de acceso en el firewall del router para cada WAN con el puerto destinado a escritorio remoto (3389)?, también debe asegurarse que exista una regla en el firewall del equipo al que desea accesar por escritorio remoto, que no bloquee el puerto 3389 por conexiones entrantes. Los modems de sus proveedores de Internet, no deben tener ninguna restricción para ningún puerto, estos deben estar en modo bridge y tener un pool de Ips, únicamente necesita 1 de cada modem que sera la de navegación.

si ya tengo todo configurado de hecho me intencion es cambiar un balanceador que ya tenia, de otra marca, funciona bien, mi intencion es mejorar, solo que al configurar el ruteador RV042G no hace la redireccion del puerto y al revisar los dispositivos que tengo en mi DHCP no hay ninguno y tengo mas de 10 computadoras conectadas, no se si sea problema del ruteador pero no puedo ver mis equipos, saludos

Cerciórese que la ip del router, debe ser la ip de navegación de sus demás equipos, por ejemplo si su router tiene ip 192.168.0.4 la ip de navegación/ o puerta de enlace sea 192.168.0.4 como DNS primario puede poner la misma ip 192.168.0.4 y la secundaria 192.168.0.5, pruebe con alguna equipo pasando la configuración de DHCP a estática y hace la prueba si le da navegación a internet. 

aun no puedo, el mismo router lo lleve a otra red y funciono perfecto, compre otro router pues mi intencion es hacer una vpn y no puedo configurarlo, la misma configuracion en el nodo de guadalaja no funciona, ya probe con otra maquina y no, si cambio a otro router de otra marca si funciona, que otra configuracion debo tener en cuenta? saludos

Revise si los puertos si los tiene habilitados en el router, en el menu como los muestra la imagen adjunta. Si el menu no es igual, debe buscar una opción que diga forwarding, de esta forma puede habilitar los puertos que desee, que deberán ser los mismos que puso como reglas de acceso en el Firewall del router. (a mi personalmente me faltaba hacer esto cuando estaba configurando el router, una vez lo hice, funcionó perfecto y no he tenido problemas con este)

 

Con el port Forwarning no permite enmascarar el 3389, es peligroso dejarlo así. Para enmascarar mejor se usa el Upnp _attachment de post anterior-

muchas gracias por sus aportes todas las configuraciones que me recomendaron eran correctas y precisas, el problema que tenia era con mi proveedor de internet no estaba configurado de manera correcta, aunque si tenia navegacion y podia accesar al internet no tenia control de mis ip, configure corectamente mi puerto wan y logre la conexion sin problemas, muchas gracias nuevamente

¿Le aparece la función UPnP ?

Eso se hace con la función UPnP, como muestra el ejemplo en donde enmascara el puerto 3389 por razones de seguridad

19O.

 

Crear
Reconozca a un colega
Content for Community-Ad