cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
Avisos
Ask Me Anything - Webex Bots
2713
Visitas
55
ÚTIL
20
Respuestas
Cisco Moderador
Community Manager

Pregunte al Experto- Mejores Prácticas en el Protocolo Spanning Tree

pregunte-stp-cordova_900x150.png

ATE-Participa
 

Aclare todas sus dudas relacionadas al protocolo Spanning Tree, desde cómo funciona y cómo se utiliza, hasta su configuración, implementación y la resolución de sus problemas comunes. El protocolo Spanning tree fue desarrollado para evitar bucles y tramas duplicadas mediante el bloqueo de puertos estratégicos, con el fin de que exista solo un camino lógico entre todos los destinos.

 

Haga sus preguntas del 29 de Octubre al 16 de Noviembre del 2018.

 

Detalles del especialista 

 

luis-cordova.jpgLuis Cordova es trabaja, actualmente, como coordinador del área de conectividad y redes en el Instituto Profesional CIISA de Santiago Chile. También es instructor para los cursos de CCNA y Main Contact de la Academia de Cisco en Chile y del Academy Support Center IP CIISA. Luis es egresado del Instituto Profesional CIISA, Instituto de Ciencias Tecnológicas. 

 

Luis puede no poder responder a todas las preguntas, debido al volumen esperado durante este evento. Recuerde que también puede hacer sus preguntas en nuestra categoría de Routing & Switching https://supportforums.cisco.com/t5/routing-y-switching/ct-p/5551-routing-and-switching

 

 

** ¡Los puntos de utilidad fomentan la participación! **
Por favor asegúrese de dar unospecial-programs.png a las respuestas a sus preguntas.

20 RESPUESTAS 20
Time-Space
Beginner

Hola!!!

 

actualmente estoy trabajando con una implementeación Wireless donde:

  • La red inalambrica la propagan LAPs, los cuales estan firmados a una WLC
  • Los clientes son alámbricos por lo que se hace uso de AP en modo de operación WGB para proporcionar conectividad a la red wireless (LAPs).

Mi pregunta es la siguiente.

Si quisiera agregar redundancia de capa 2 para los clientes, o sea, agregar otro WGB como se comportaría el Spanning-Tree?? entiendo que los BPDUs viajan encapsulados en el túnel CAPWAP desde el WGB hacia la WLC mi duda es: ¿como regresan o como se compartan eso BPDUs una vez que la WLC desencapsula el Frame?

 

Agradezco sus comentarios.

Saludos

Hola,

He estado investigando sobre tu consulta en diferentes manuales de Cisco, tanto en inglés y español.

Te dejo este link que habla sobre los AP WGB y otro que habla sobre el CAPWAP:

 

https://www.cisco.com/c/es_mx/support/docs/wireless/aironet-340-series/8018-workgroup-bridge-faq.pdf

https://www.cisco.com/c/en/us/support/docs/wireless/4400-series-wireless-lan-controllers/69561-wlc-faq.html

 

En el primer link encontré este detalle, el que te podría ayudar con tu consulta:

 

Q. ¿Qué es significada por el Bridge Loop? ¿Cuáles son las posibles causas para que un Bridge Loop ocurra?
A. Si el Workgroup Bridge está conectado con el LAN cableado y comunica con un Punto de acceso en el mismo LAN, un problema de red conocido como Bridge Loop puede ocurrir. Desconecte el Workgroup Bridge del LAN cableado inmediatamente después que usted lo configura para evitar un Bridge Loop. Un Bridge Loop puede también ocurrir si dos o más Bridges están conectados con el mismo concentrador remoto. Conecte siempre solamente un Workgroup Bridge con un concentrador remoto para prevenir este Bridge Loop.

 

Espero eso te sirva la información.

 

Saludos

juan soporteco
Beginner

buen Día Luis,

 

De antemano gracias por tu tiempo y que se brinde este espacio, la consulta es la siguiente, en un red hibrida Cisco y 3COM cual seria la mejor practica ante eventos de capada 2 (loops) y equipos como los 3 COM no tengan disponible spanning tree, en la arquitectura que actualmente laboro tengo esta integración a nivel de Core y me ha traido algunos problemas, mis equipos Cisco (4500) por default traen este protocolo habilitado pero del lado de 3COM experimento problemas por lo que troncales criticas quedan en err-disabled por "loopback" y ha generado altos impacto en la operación.

No se que otros detalles podamos incluir, adicionalmente a esto, ya que cuento con una topologia de este tipo, imaginete un Core adicional 4500 conectado al 4500 pero "down" si habilito esta troncal hay otra cascada disponible activa actualmente, si habilito la que esta down se genera "loop" la idea es que quede en "ALTN BLK" para que sea un enlace de contingencia, pense que esto se lograba automáticamente, pero estoy pensando en modificar el "costo" para que quede en el estado que quiero y por ultimo la prioridad en la interfaz que tengo actualmente Down. 

 

espero me haya echo entender y cualquier novedad estaria atento, nuevamente muchas gracias.

 

Hola Juan:

 

He estado investigando leyendo sobre el error que mencionas y encontré este link:

 

https://www.cisco.com/c/en/us/support/docs/lan-switching/spanning-tree-protocol/69980-errdisable-recovery.html#anc6

 

Sobre el el error en específico dice esto:

  

  • A loopback error occurs when the keepalive packet is looped back to the port that sent the keepalive. The switch sends keepalives out all the interfaces by default. A device can loop the packets back to the source interface, which usually occurs because there is a logical loop in the network that the spanning tree has not blocked. The source interface receives the keepalive packet that it sent out, and the switch disables the interface (errdisable). This message occurs because the keepalive packet is looped back to the port that sent the keepalive:

  •  

    Keepalives are sent on all interfaces by default in Cisco IOS Software Release 12.1EA-based software. In Cisco IOS Software Release 12.2SE-based software and later, keepalives are not sent by default on fiber and uplink interfaces. For more information, refer to Cisco bug ID CSCea46385 (registered customers only) .

    The suggested workaround is to disable keepalives and upgrade to Cisco IOS Software Release 12.2SE or later.

     

    Espero que te sirva para empezar con una solución.

 

Saludos

7bjhernandez
Beginner

Requiero saber sobre el comando 

Spabbing-tree mode pvst

Al momento q ejecuto el siguiente comando show spanning-tree 

Aparece el protocolo ieee y estoy utilizando pvst 

 

Cuando utilizo el pvst debo utilizar los comandos siguiente en mi topologia de todo mi switch de acceso o en donde debo de utilizarlos:

Bacbonefast

Uplinkfast

Tambien puede comentar donde se deben utilizar los siguientes comandos:

Portfast

LoopGuard

RootGuard

BPDUguard

BPDUFilter

Algún ejemplo q me pueda compartir por favor .gracias

 

Saludos 

 

Hola,

 

Cuando el switch te muestra spanning-tree mode pvstp indica que está habilitado para trabajar el protocolo spanning-tree en vlans diferentes, pudiendo tener cada una su propio puente raiz, por ejemplo.

Spanning-tree es un protocolo IEEE(802.1D), por lo que, independiente que trabaje por vlan, sigue siendo IEEE.

Sobre los comandos mencionados, te dejo estos links que me parecieron súper informativos:

 

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst6500/ios/12-2SX/configuration/guide/book/stp_enha.html

 

https://learningnetwork.cisco.com/thread/14883

 

Espero que te sirvan de guia.

 

Saludos

Buenos días, por favor si me pudiera comentar como puedo yo controlar el tráfico de STP. Es decir necesito no dejar al algoritmo la esencia de decidir que camino tomar. Necesito específicamente que tome el camino que yo indique. Por favor si pudiera poner un ejemplo solo con 3 switch. He probado en Packet Tracer y no resulta. Por favor me confirma si en PT siempre no podremos demostrar esto.

 

Hugo Oviedo - Perú

Hola Hugo,

 

Creo que la forma mas sencilla de lograr cambiar la asignación de puertos es cambiando la prioridad spanning-tree.

Esto se puede probar en PT.Captura de pantalla 2018-11-02 a la(s) 15.15.20.png

 

 

Como puedes ver, el camino para el trafico es de switch A a switch C, además, el puerto f0/2 de switch C está en BLK.

Si nuestra intención es que el trafico sea por los switch A, B y C, basta con cambiar la prioridad spanning-tree de la vlan1(puedes seleccionar caminos diferentes para cada vlan) en el switch B, haciendo que este se convierta en el puente raíz.

El switch puente raíz no tiene puertos BLK y los puertos de los switch vecinos que apuntan hacia el quedan en FWD.Captura de pantalla 2018-11-02 a la(s) 15.21.48.png

 

 

Como ves, el comando spanning-tree vlan <nº> root primary hizo que la prioridad spanning-tree para esa vlan bajara 2 escalones(cada escalón para modificar la prioridad debe ser de 4096, pero, si reemplazas primary por secondary la prioridad solo bajara un escalón), quedando el switch B como puente raíz para la vlan1.

Te sugiero probar cambiando las prioridades para lograr que el trafico tome el camino que tu deseas.

 

Saludos

 

 

Gracias por compartir tu conocimiento y ayudar a otros miembros @luis_cordova

Muchas gracias por tomarte la molestia de ilustrar gráficamente lo indicado, mi escenario es algo similar a lo que indicas pero actualmente, el camino activo seria SWA----SWB----SWC, y SWA------SWC esta Down, cuando lo habilito es cuando se genera el bucle indicado, y esta de por medio un switch 3com y las conexiones entre los Switches son a nivel de Core por lo que en realidad son enlaces tipo " trunk" pero con adyacencias OSPF activas.

 

indico topología en imagen y cualquier duda si la necesitas quedo muy atento y nuevamente muchas gracias por el apoyo..

Hola Juan,

 

Efectivamente, si levantas el enlace entre A y C se crearía un escenario en el que habrían loops de capa 2, con sus consecuencias.

Y eso es precisamente lo que spanning-tree busca evitar bloqueando puertos y dejando solo un camino lógico entre destinos.

Si no respondí tu duda, te ruego ser un poco más específico con lo que necesitas lograr, con el fin de ver si me es posible ayudarte.

 

Saludos

 

Muchas gracias por tu feedback, si en esencia es así como funciona, es decir en este momento entre A y C se tiene lógicamente Down el enlace, teoricamente si yo levanto este enlace "en rojo" entre A y C, la logica de spanning tree es que para todas las vlans quede en state "BLK" y que el camino siga siendo el mismo.

 

pero lo que me han indicado es que cuando se levanta este enlace se genera el "loop" y no debería dada la convergencia de spanning tree, entonces lo que estaba pensando era modificar el costo de la interfaz tengiga a "10"

recordando que el costo por Default es de "4"

En mi caso algo asi:

 

SWA#sh run int po5
Building configuration...

Current configuration : 144 bytes
!
interface Port-channel5
description ENLACE_COREC
switchport
switchport trunk allowed vlan x,y
switchport mode trunk

spanning-tree cost 10 >>> adicional
shutdown
end

 


COREA#SH RUN INT Te1/1/5
Building configuration...

Current configuration : 169 bytes
!
interface TenGigabitEthernet1/1/6
description ENLACE_COREC
switchport trunk allowed vlan x,y
switchport mode trunk

spanning-tree cost 10 >>> adicional
shutdown
channel-group 5 mode on
end

SWA#SH RUN INT Te2/1/5
Building configuration...

Current configuration : 169 bytes
!
interface TenGigabitEthernet2/1/6
description ENLACE_COREC
switchport trunk allowed vlan x,y
switchport mode trunk

spanning-tree cost 10 >>> adicional
shutdown
channel-group 5 mode on


end

SWA#

 

 De igual manera del lado del Portchannel del Switch C, con ello manipulo el protocolo y en el momento que lo levante no tendria el loop dado que spanning tree detectara este como un enlace secundario, corrigeme si me equivoco, quedo atento muchas gracias.

Hola Juan,

 

Si tu intención es que el enlace entre A y C quede como secundario, podrías intentar primero cambiando las prioridades, con lo que, incluso, podrías dejar tal camino como primario para algunas vlan.

Por ejemplo, si tienes las vlan 10 y 20, podrías dejar el camino A, B y C para la VLAN 10 y el camino A y C para la VLAN 20.

En la respuesta a Hugo explique un proco cómo lograrlo.

 

Saludos

jhoel_lucero
Beginner

Buenas noches, quisiera absolver algunas dudas con respecto a STP implementado en una topología con Nexus con Vpc.

Si tenemos 2 switches Nexus con un Vpc domain, tengo la siguientes consultas:

 

- ¿Qué pasa con el STP dentro del Vpc?

- ¿Si en algún momento se rompe el Vpc domain, como se comportarían los dispositivos Nexus en lo que respecta al STP si ambos switches Nexus aún siguen pasando las Vlans por el enlace de servicio, pero el enlace peerkeepalive se cayó entre los Nexus?

Crear
Reconozca a un colega
Content for Community-Ad