cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
2934
Visitas
30
ÚTIL
10
Respuestas

Puerto en error

Marisol Navarro
Level 1
Level 1

Buen día. Espero me puedan ayudar. Tengo un puerto en estado "err-disabled". Apago y prendo la interfaz y el puerto se recupera en un estado de "notconnect" pero el problema esta que cada que le conecto un dispositivo el puerto vuelve al estado de "err-disabled". Mi pregunta es como puedo corregir este error. Gracias y saludos!!!

10 RESPUESTAS 10

luis_cordova
VIP Alumni
VIP Alumni

Hola @Marisol Navarro 


Hay algunas razones por las que un puerto puede quedar en ese estado.

Por ejemplo una configuración errónea de duplex o hasta un cable muy largo o defectuoso.

En este link puedes encontrar un artículo que trata del tema.

https://www.cisco.com/c/es_mx/support/docs/lan-switching/spanning-tree-protocol/69980-errdisable-recovery.html#anc8

 

Espero que te sea de utilidad.

 

Saludos

Hola Marisol,

En que plataforma estas observando este mensaje?

Si es en switch es porque pueda que tengas configurado bpduguard habilitado, tienes port security y ya no soporta mas direcciones MAC.

 

Si nada de esto esta configurado, el problema podria ser un bug en la imagen y te tocara actualizar. Puedes compartir la configuracion del puerto si es posible.

 

Saludos.




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hola que tal, el puerto lo tengo configurado para voz/IP, pero cada que conecto el equipo telefónico cisco, el puerto se viene abajo en estado de error

 

switchport access vlan 20
switchport mode access
switchport nonegotiate
switchport voice vlan 10
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust device cisco-phone
mls qos trust dscp
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY

Hola Marisol

Al parecer lo que esta al otro extremo de ese puerto, esta generando BPDU y eso te deshabilita el puerto. Algunas computadoras generan BPDUs y se genera ese problema, pero si estas segura que es una PC puedes quitar el BPDUGuard y monitorear a ver si sucede el problema o actualizar la bios de esa PC, quedo a las ordenes. Saludos.

 

switchport access vlan 20
switchport mode access
switchport nonegotiate
switchport voice vlan 10
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust device cisco-phone
mls qos trust dscp
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY

 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hilda Arteaga
Cisco Employee
Cisco Employee

hola @luis_cordova y @Julio E. Moisa gracias por la pronta ayuda a @Marisol Navarro 

Diana Karolina Rojas
Cisco Employee
Cisco Employee

Hola Marisol, 

 

Hay muchas razones por las que puedes tener este inconveniente pero en el "show log" de tu switch te tiene que aparecer el log con el error especifico que te esta bajando esa interfaz, por favor revísalo y envíanos el log para poder ayudarte con mas precisión. Si es un teléfono y una maquina lo que se esta conectando entonces no deberías tener problemas con el BPDU a menos que sea un modelo muy viejo de teléfonos IP ¿Qué modelo de switch y de teléfonos estas usando?

***Por favor no olvides calificar y/o marcar como solución las respuestas útiles, tu calificación promueve nuestra participación.***

 

Saludos,

Hola, es un teléfono Cisco 7841

Javier Acuña
Spotlight
Spotlight

Hola saludos, para este caso valida en la interface del puerto con el siguiente comando.

 

sh port-security interface gigabitEthernet x/x
Port Security : Disabled
Port Status : Secure-down
Violation Mode : Shutdown
Aging Time : 0 mins
Aging Type : Absolute
SecureStatic Address Aging : Disabled
Maximum MAC Addresses : 1
Total MAC Addresses : 0
Configured MAC Addresses : 0
Sticky MAC Addresses : 0
Last Source Address:Vlan : aaaa.bbbb.cccc:dddd
Security Violation Count : 0

 

este comando te dará el estado de Violation del seguridad de puerto si al apagar y encender el puerto no no se quita el error,

elimina la mac del puerto utilizando el siguiente comando.

clear mac address-table dynamic interface gigabitEthernet x/x

procede a reiniciar el puerto y debería corregir el error

 

utiliza el comando sh inter status en el puerto y valida que tenga un estado conocido si se encuentra en estado failure reinicia el SW.

 

Recuerda Calificar esta respuesta ya que esto motiva a continuar apoyando a la comunidad

 

Hola @Javier Acuña gracias por compartir la información

Gracias por el aporte.