Showing results for 
Search instead for 
Did you mean: 

phpmyadmin from Docker Hub - problems



Is IOX 100% Docker compatible?

I'm trying to run phpmyadmin as a docker from my Catalyst 9300 (running v17.03.01).

I pull the image from here:

Saving it, and uploading it to usbflash1:

After running
app-hosting install appid phpmyadmin package usbflash1:phpmyadmin.tar
it does not show up when i run the command:

show app-hosting list

But I can still activate and start it. But it never shows up in any list.. in CLI. I cannot uninstall it either, since the switch claim the appid does not exist. BUT in the switch Web UI it does show up.. strange.

I said I could start it up, but only without arguments.

If I add arguments like this:
app-resource docker
run-opts 1 "-e PMA_HOST= 8080:80 phpmyadmin"
it does not work.
I'm not able to start it, and the CLI does not give me an error.

The Web GUI does, however, and it looks like this:

2020-09-21 08:30:08,495 [pdservices:ERROR] [Thread-11] [ - _call_hook_script()] Error returned by post-stop hook /opt/cisco/caf/scripts/ returncode: 127, message: /bin/sh: 5A52880781F755608BF815FC910DEB46F53EA312: command not found

What can be causing this?

The first docker app I tried (IPerf) worked like a charm. This one, not so much.

Here is the full appid settings from the switch:

app-hosting appid phpmyadmin
app-vnic AppGigabitEthernet trunk
vlan 2 guest-interface 1
guest-ipaddress netmask
app-default-gateway guest-interface 1
app-resource docker
run-opts 1 "-e PMA_HOST= -p 8080:80 phpmyadmin:latest"






1 Reply 1

Cisco Employee
Cisco Employee


A Distinguished Engineer here at Cisco has created a GitHub Repo explaining How to Application Host [create a Docker container] Syslog-NG in a Cisco Catalyst 9000 series switch.

His appid settings for your consideration:

app-hosting appid syslogng
 app-vnic management guest-interface 0
  guest-ipaddress netmask
 app-default-gateway guest-interface 0
 app-resource docker
  run-opts 1 "-v $(APP_DATA):/data"
  run-opts 3 "--restart=unless-stopped -p 514:514/udp -p 601:601/tcp"
 app-resource profile custom
  vcpu 1
  cpu 3700
  memory 1792
  persist-disk 200

See the repo here --->


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers