Showing results for 
Search instead for 
Did you mean: 

Data 2 missing


I have some troubles with ESA on first boot.

I cannot connect over IP address and in System Logs I see error.

Sat Jan 31 09:17:47 2015 Critical: An application fault occurred: ('egg/ configure_interfaces|845', "<type 'exceptions.ValueError'>", 'interface not found', '[egg/ run|1052] [egg/ configure_interfaces|845]')


So, I connect over serial and create revert.

After revert management (data 1) network is working fine but data 2 is missing.

Data 2 on HW appliance is blinking (it doesnt look like HW issue) so how can I get Data 2...

Cisco Employee

You should be able to do one

You should be able to do one of two ways:

1) run ifconfig > NEW and follow the wizard prompts to add in 'Data 2' as desired:

> ifconfig



Currently configured interfaces:

1. Management ( on Management:


Choose the operation you want to perform:

- NEW - Create a new interface.

- EDIT - Modify an interface.

- GROUPS - Define interface groups.

- DELETE - Remove an interface.

[]> new


Please enter a name for this IP interface (Ex: "InternalNet"):

[]> Data 2


Would you like to configure an IPv4 address for this interface (y/n)? [Y]> 


IPv4 Address (Ex: ):



The IP address must be 4 numbers separated by a period.  Each number must be a value from 0 to 255. (Example:


IPv4 Address (Ex: ):


... <continue on> ...

2) Manually edit your saved XML and add in 'Data 2' for <Ports> and <Ethernet Settings>, mimicking what you have already in for the 'Data 1' sections:


      <port_name>Data 2</port_name>


        <jack>Data 2</jack>






      <ethernet_interface>Data 2</ethernet_interface>






Save your edited XML and reload that XML onto the appliance.



Hi, I tried both. If I go



I tried both. If I go from CLI then I dont have Ethernet Interface Data 2.


When I try to import modified XML.

ErrorConfiguration file was not loaded. Parse Error on element "port_name" line number 31 column 18 with value "Data 2": The network port name must be "Data 1", or start with "VLAN" or "Loopback".
Cisco Employee

Can you send me a copy of

Can you send me a copy of your configuration file?  Run this from supportrequest on the CLI please.

> supportrequest


Please Note:

If you have an urgent issue, please call one of our worldwide Support Centers ( Use this command to open a technical support request for

issues that are not urgent, such as:

- Request for information.

- Problem for which you have a work-around, but would like an alternative solution.


Do you want to send the support request to [Y]> n


Do you want to send the support request to additional recipient(s)? [N]> y


Please enter the email address(es) to which you want to send the support request.  Include anyone in your organization that should be included on future

correspondence for this issue. Separate multiple addresses with commas.



... <continue through the prompts> ...


Hi, I send you email beacuse



I send you email beacuse I have ticket that is open about this issue.


Cisco Employee

To summarize the resolution

To summarize the resolution on the issue - after discussing direct w/ Juraj and getting tunnel access to the appliance, we determined that there is an issue w/ the NIC loading at the OS layer.  End-case, hardware issue on the appliance.

Even with hardcoding the MAC into the configuration for Data2, and assuring that the port and ethernet settings are present, issue still persisted.  So - further review from remote access tunnel was needed to review the appliance.