cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4971
Views
14
Helpful
6
Replies
Beginner

Error Message on SFTP get

          I am testing an SFTP get job to an external site, I get the following message;

FTP JOB Failed : No known hosts provided - use SecureFTPConnection.KnownHosts to add some (safe), or set ServerValidation to None (unsafe).

Is this referencing a file I need to add site info for?  What am I missing?

thanks

Everyone's tags (4)
6 REPLIES 6
Highlighted

Error Message on SFTP get

Bill,

What are you running? 6.x or 5.3.1?

In 5.3.1, It looks like you are chosing the "Private Key File" option under the "Authentication Type". This is on the FTP tab. If your not doing SSH SFTP then you don't need this option. Best to use "User/Password"

But if you are doing SSH SFTP then you'll need to generate a key, point to your private key and send to the client your public key. It is almost the same concept as PGP, but at the SSH level. (i just went through this process and it was very painful. I needed to upgrade from 5.3.1.374 to 5.3.1.438 first and update our UNIX agent to

3.1.0.14 in order to get that to work.)

The example below is for User/Password option.

For the run tab, I use the following:

Agent (local host) = Our UNIX box agent. UNIX boxes have FTP services installed on them, talk to your admin to see if it is active and running.

Local User = nothing, blank

FTP Host = the site you are FTPing to like ftpsite.site.com:22  (the 22 or 21 port number is some times needed)

FTP User = the user id you'll log onto the ftpsite with. You'll need to create this user in your "Users" list as a runtime.

For the FTP tab:

Protocol = SFTP

FTP Operation = Get file

Format = ? depends on what you are getting, normally Binary

What is the filename you are picking up. you can even use vaiables. test.file.

New Filename = The name it will be on your server.

Local Path = Where you are puting the file on your server

Remote Path = Where the file is on the ftpsite

Then run. Hope this helps.

Mike

Highlighted
Beginner

Error Message on SFTP get

Thanks Mike, I am using 6.1. This is an SSH job.   I have tried running with user/password or passphrase, with or without the port specified and I get the same output regardless.   I am using windows servers as the local host.

I do not have the SSH adaptor but the documentation does not indicate what fucntionality it adds or if this is what I need to complete the setup of an SSH job.  

Is anyone using the SSH adaptor for a windows environment, is this required to allow my job to work?

Highlighted
Beginner

Error Message on SFTP get

Is this the first time you are performing an SFTP using this Windows Agent?

The default behavior for SFTP changed with the 3.x Tidal agents.  In 2.x Tidal agent the default behavior was to not verify Known Host Keys.  The defalt behavior for 3.x Tidal agents is to verify Known Host keys.  You can change 3.x Tidal agents back to the 2.x behavior with a setting in the tagent.ini file.  This is what the message "set ServerValidation to None (unsafe)." is referring to.

In your \Tidal\Agent\bin directory look for file "tagent.ini".  Create it if necessary.  To not require Known Host Key verification you need to add "SSLVLDCRT=n" to the file.  Example file follows:

[config]
SSLVLDCRT=n

[TIDAL_AGENT_1]

After making this change, cycle the agent service.  Then try your job again.

Good luck.

Highlighted
Beginner

Error Message on SFTP get

Thank you Tracy,

Yes this is my first attempt of SFTP with Tidal, I'm fairly new to Tidal.

I did add the line to the tagent.ini file and did get a different message below;

FTP JOB Failed : Failed to recognize key format. Supported formats are OpenSSH, SSH.com and PuTTY.

I am assuming this translates to I need to add an SSH client to the server initiating the job?

Highlighted
Beginner

Error Message on SFTP get

Got it to work.

In additional to the tagent.ini file we had to make a few edits to our job syntax, by removing some unrequired "\"'s, and removing the local user- leaving that field blank.  

thank Tracy and Michael for all the help!

Highlighted
Beginner

Re: Error Message on SFTP get

In my experience with SFTP using SSH2 only, you should use a local user because the key file path and local path on GET or PUT need to authenticate on Windows. What I have found is sometimes if you edit the job you may have to also reapply the Pass Phrase one more.
This widget could not be displayed.