Showing results for 
Search instead for 
Did you mean: 

Telnet to router works 4 times and fails 5th time

I have a simple TEO 2.2 workflow to telnet to a router. For this I created a target that was failing initially on ‘expect sequence’....later when I corrected the expect sequence, TEO allowed me to create the target and the workflow for telnetting to the router using this target worked for at least 4 tries....and the 5th try onwards the workflow is failing once again on ‘expect sequence’....I can’t understand this as this worked just fine for 4 times...I have captured the 4 outputs that passed and the 5th, 6th...that failed....quite surprised at the inconsistent behavior.

Plesae see attached file (src_shot_1.bmp) for expect sequence that I configured for this terminal target. Also attached is the log file (log.txt) with debug turned ON. In my test, telnet was performed to port 2002.

From the same VM as my TEO, I do the following to telnet to the router successfully:

telnet 2002



I could log into the router without any user name or password. The successful prompt is R2>

Will appreciate prompt help please as I have spent a considerable amount of time debugging this.



Shaun Roberts
Cisco Employee
Cisco Employee
case opened and solved on this. He was using a telnet/console port type router connection.
You have to send an enter first to get to the prompts. To do that you should configure an
expect statement to expect "\W{0}" and then make a user response send an enter or carriage return.
--Shaun Roberts
Principal Engineer, CX
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: