Showing results for 
Search instead for 
Did you mean: 

7940G - Really stuck

Level 1
Level 1

Hello there,

I decided that it would be a good idea to learn how to use the Cisco IP phones (home learning), so I baught a second hand 7940G. When I got it it was abviously still configured for the previous owners network, so I did a factory reset and told it NOT to keep the network config. But I now keep getting error:

When it tries to boot now it keeps getting stuck on "Protocol Invalid Application"

I have tried resets 1 2 3 4 5 6 7 8 9 * 0 # also *6 hold #. after it does resetting and trying to boot showing configuring VLAN and IP etc it goes back to the error. It looked like after the error there was a small 0 and and "A" and I thought it could be a small padlock? so i tried **# but it do anything.

I am using Trixbox for the VOIP PBX, as it is free and I can't afford to pay out for CCM etc.

Please can anybody help?


2 Replies 2

Adrian Saavedra
Level 7
Level 7

Hi Guy,

Are you using the SIP firmware in the 7940?


- Adrián.

Cisco Employee
Cisco Employee

This is a well known issue. Refer to the following URL's for more details on the cause -

Here are some links that you may want to take a reading:

The workaround to get the phones to complete the registration is as follows:

1. Configure option 150 in the native VLAN scope on the DHCP server.

2. Remove the "voice vlan" command from the switchport and leave the switchport as an access port on the native VLAN.

3. Reboot the phone. The phone should register and upgrade its load using an IP address on the native VLAN.

4. Add the "voice vlan" command back to the switchport.

5. Reboot the phone. The phone will now come up with an IP address on the voice VLAN.