cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
308
Views
0
Helpful
1
Replies

Browser Compatability with CUCM 8.5

Wendy Szarwak
Level 1
Level 1

I am managing a CUCM platform on 8.5.1.13900-5.  I recently upgraded my Browser to IE11 and now I noticed the CUCM drop-down menus no longer work. Is IE11 a supported browser?

1 Reply 1

No.

Cisco's officially-supported browser is Firefox.  Chrome and IE11 do not work well with CUCM < 9, as well as several other Cisco products.