cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

216
Views
0
Helpful
3
Replies
bringrose
Beginner

Cisco 7961's with Vodia PBX

I have multiple Cisco 7961's and I can not get them to register on a Vodia PBX, below I have added the current config that I am trying to use. My problem is that I can use this config (with altered names, passwords and proxy) with a local Elastix box however I can not get it to work with the external domain.

I can use the proxy, username and password with the blink softphone and it connects and registers correctly with the Vodia PBX Server

PLEASE HELP this thing is driving me crazy (or crazier)

<device>
<deviceProtocol>SIP</deviceProtocol>
<sshUserId>cisco</sshUserId>
<sshPassword>cisco</sshPassword>
<devicePool>
<dateTimeSetting>
<dateTemplate>D/M/Y</dateTemplate>
<timeZone>Tasmania Standard/Daylight Time</timeZone>
<ntps>
<ntp>
<name>dk.pool.tp.org</name>
</ntp>
</ntps>
</dateTimeSetting>
<callManagerGroup>
<members>
<member priority="0">
<callManager>
<ports>
<ethernetPhonePort>2000</ethernetPhonePort>
<sipPort>5060</sipPort>
<securedSipPort>5061</securedSipPort>
</ports>
<processNodeName>{DOMAIN OF PBX}</processNodeName>
</callManager>
</member>
</members>
</callManagerGroup>
</devicePool>
<sipProfile>
<sipProxies>
<registerWithProxy>true</registerWithProxy>
</sipProxies>
<enableVad>false</enableVad>
<preferredCodec>g711ulaw</preferredCodec>
<natEnabled>true</natEnabled>
<phoneLabel>Glenn</phoneLabel>
<sipLines>
<line button="1">
<featureID>9</featureID>
<featureLabel>Glenn</featureLabel>
<proxy>USECALLMANAGER</proxy>
<port>5060</port>
<name>102</name>
<displayName>102</displayName>
<authName>102</authName>
<authPassword>39MH1SODJu5WIdjc</authPassword>
</line>
<line button="2">
<featureID>21</featureID>
<featureLabel>Ben</featureLabel>
<speedDialNumber>101</speedDialNumber>
<featureOptionMask>1</featureOptionMask>
</line>
</sipLines>
<dialTemplate>dialplan.xml</dialTemplate>
<softKeyFile>7961softkeys.xml</softKeyFile>
</sipProfile>
<commonProfile>
<phonePassword></phonePassword>
</commonProfile>
<loadInformation>SIP41.8-4-2S</loadInformation>
<versionStamp>1143565489-a3cbf294-7526-4c29-8791-c4fce4ce4c37</versionStamp>
<directoryURL></directoryURL>
<servicesURL></servicesURL>
</device>

3 REPLIES 3
Leo Laohoo
VIP Community Legend

<loadInformation>SIP41.8-4-2S</loadInformation> 

This here tells me the phone is loaded with 8.4(2) firmware.

<proxy>USECALLMANAGER</proxy> 

This is an incorrect setting.  Only phones loaded with 9.X firmware will support this setting.  Use the IP address of the PABX instead.

Also add the this: <transportLayerProtocol>2</transportLayerProtocol>

Hi Leo,

I have updated my config file as you recommended and downloaded a the SIP41.9-4-2SR1-1S firmware factory reset the phone 3497612850*#, have reconfirmed that it is working in blink however the phones (I have tested on multiple) are not registering to the server

Cheers,

Ben

<device>
<deviceProtocol>SIP</deviceProtocol>
<sshUserId>cisco</sshUserId>
<sshPassword>cisco</sshPassword>
<devicePool>
<dateTimeSetting>
<dateTemplate>D/M/Y</dateTemplate>
<timeZone>Tasmania Standard/Daylight Time</timeZone>
<ntps>
<ntp>
<name>dk.pool.tp.org</name>
</ntp>
</ntps>
</dateTimeSetting>
<callManagerGroup>
<members>
<member priority="0">
<callManager>
<ports>
<ethernetPhonePort>2000</ethernetPhonePort>
<sipPort>5060</sipPort>
<securedSipPort>5061</securedSipPort>
</ports>
<processNodeName>168.1.104.103</processNodeName>
</callManager>
</member>
</members>
</callManagerGroup>
</devicePool>
<sipProfile>
<sipProxies>
<registerWithProxy>true</registerWithProxy>
</sipProxies>
<enableVad>false</enableVad>
<preferredCodec>g711ulaw</preferredCodec>
<natEnabled>true</natEnabled>
<phoneLabel>Glenn</phoneLabel>
<sipLines>
<line button="1">
<featureID>9</featureID>
<featureLabel>Glenn1</featureLabel>
<proxy>168.1.104.103</proxy>
<port>5060</port>
<name>102</name>
<displayName>102</displayName>
<authName>102</authName>
<authPassword>39MH1SODJu5WIdjc</authPassword>
</line>
<line button="2">
<featureID>21</featureID>
<featureLabel>Ben</featureLabel>
<speedDialNumber>101</speedDialNumber>
<featureOptionMask>1</featureOptionMask>
</line>
</sipLines>
<dialTemplate>dialplan.xml</dialTemplate>
<softKeyFile>7961softkeys.xml</softKeyFile>
</sipProfile>
<commonProfile>
<phonePassword></phonePassword>
</commonProfile>
<loadInformation>SIP41.9-4-2SR1-1S</loadInformation>
<transportLayerProtocol>2</transportLayerProtocol>
<versionStamp>1143565489-a3cbf294-7526-4c29-8791-c4fce4ce4c37</versionStamp>
<directoryURL></directoryURL>
<servicesURL></servicesURL>
</device>

Leo Laohoo
VIP Community Legend

<loadInformation>SIP41.9-4-2SR1-1S</loadInformation> 

This is the firmware loaded, 9.4(2)SR1. 

<proxy>168.1.104.103</proxy> 

So the value of this XML tag should be "USECALLMANAGER".

Talk to the provider and determine if the router should enable ALG and/or NAT.

Content for Community-Ad