Showing results for 
Search instead for 
Did you mean: 
Walkthrough Wednesdays

cucm 8.5.1 SCCP45.9-1-1SR1S phones cannot load firm

I installed 7 new 7965G phones at a remote site, and only 1 downloaded the firmware successfully ( even though the line text display in cucm does not match the phone ).

I have tried to factory reset the phones but they are still not downloading the firmware. The phone boots up to the upgrading screen and then it sits there for a minute - shows upgrading, with mac-address of the phone - does nothing then a blue screen and reboots does the same thing. The file is located in the TFTP directory

I could not find any bug in this release or anything to indicate an issue with this code.

Anyone have any suggestions before I start looking at a firmware upgrade?


Cisco Employee

++ If this is new phone and was not registered to any 7.x cluster before, then it cannot be ITL issue.

++ Check the current firmware in phones and check the default firmware for 7945 in the CCM, make sure it is single step firmware upgrade, You have to be in some 8.3 firmware I think,  if you have to upgrade to 9.x firmware. So make sure it is not the compatability issue.

++ If you are not sure, give the default frimware version for 7945 in your CCM and current firmware sitting in your phone, lets check if it can upgrade directly .

            From the relase notes

Note For all SCCP firmware upgrades from firmware release versions earlier than 8.3(3) to version 8.5(2)SR1 or greater, you must first upgrade your firmware to version 8.5(2). Once you have upgraded to version 8.5(2), you can upgrade your IP Phone to version 9.1(1)SR1 or later.

Note This section applies to the Cisco Unified IP Phone 7975G, 7971G-GE, 7970G, 7965G, 7962G, 7961G-GE, 7961G, 7945G, 7942G, 7941G-GE, 7941G, 7911G, and 7906G.


Thanks for your replies.

The problem ended up being TFTP option 150 in the DHCP pool on that particular Voice VLAN was not installed. This threw me off at first because I upgraded the firmware while at Head Office, not thinking to check the DHCP options at that time.

Thanks again.

Content for Community-Ad

Spotlight Awards 2021