Showing results for 
Search instead for 
Did you mean: 

SPA 2102 registration failure upon change of external IP

Level 1
Level 1



My ISP provides a dynamic IP address.  The external IP address it assigns to me is on a 24 hour lease.  They have their DHCP server configured to not renew leases, as it is their policy to force users to change their external IP address at least once in every 24-hour period.  My SPA-2102 is connected to a port on my router.  Every day when the external IP address changes the SPA 2102 fails to see the changed IP address for several minutes, I estimate about 15 or so, consequently registration with the SIP server fails, meanwhile the ATA keeps sending out SIP packets presumably including the wrong external IP address and of course gets no reply.

After a while the SPA 2102 notices that the external IP address has changed and it picks up the new external IP address.  Even after it has done so the registration still fails.  If I use the web interface to reboot the SPA, it still doesn't successfully register even after the reboot.  The only way I force it to register successfully is to change the SIP port it uses.  Once I do that it registers successfully again.  Of course, this means that every day I have to manually change the SIP port, which isn't very satisfactory.

I can create the same conditions by disconnecting and then connecting my internet connection thereby forcing a change in the external IP address.  This is very frustrating.  It seems to me that this must be a bug in the firmware, although if that was so I would expect to see other posts on forums, but I can find anyone else reporting this problem.

Any recommendations or thoughts would be most welcome!


4 Replies 4

Level 1
Level 1

My SPA-2102 worked fine for 9 months. Now it's started exhibiting this problem.

I've created a trouble ticket with Cisco support; it is case #619500465.

I've spoken to two Cisco techs so far; they both tell me that they have not heard of this problem before. They both assure me that this behavior is not normal.

If the problem can't be resolved by replacing the Ethernet cable and updating to the latest firmware, they will consider the SPA-2102 as defective and replace it.

Hi Jeff,

Nice to hear from you.  I am still experiencing this problem, I have learnt just to live with it.

I haven’t looked for new firmware for some time. Receiving your post has prompted me to do so. I note that the latest firmware is 5.2.12. I am still using 5.2.10. I have to check to see if I can use this firmware which I can’t do for several days as I shall travel this evening.

I’ll endeavour to do so and let you know what the outcome is, although it will take a bit of time.

Level 1
Level 1

I upgraded the SPA-2102 to firmware 5.2.12; the problem persists.

I purchased a second SPA-2102 and substituted it for the first; the problem also occurs with the new SPA-2102.

So far, I've replaced the cable modem, Ethernet cable, SPA-2102, and firmware.  The problem persists. There is no other hardware here. That's it. Just a cable modem and a SPA-2102.

Now here's an interesting data point: I've moved the SPA-2102 to a friend's house about a mile away. It works fine there with his cable modem (same cable provider).  The one difference is that his network has an intermediate router:

  [cable modem] <-> [Linksys router] <-> [SPA-2102]

With this setup, the SPA-2102 acquires an IP address from the router; this address never changes.

So long as the SPA-2102 keeps a constant IP address, it works fine.

Hi Jeff,

Interesting development here.  I had another issue with my Netgear router.  Since changing the firmware for a custom developed firmware details of which can be found, this problem has disappeared.  Although the SPA-2102 can serve as the modem/router, I have mine sitting connected to my Netgear router.

Anyhow, seems that you have already found a solution that works for you, but I thought it would be useful to get this information out there in case anyone else is looking for this solution.

Best wishes,