cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5087
Views
5
Helpful
16
Replies

EIGRP IPv6 Link-Local Only Routing

LeonardW
Beginner
Beginner

Hey guys,

 

I have a question in regard to link local only routing like described in RFC7404.
In my Setup I use VLAN Interfaces for End-Host Networks which just have a link-local address and advertise the GUA Prefix via RAs with just the "on-link" flag set.

 

interface Vlan1000
ipv6 address FE80::1000:A link-local
 ipv6 nd prefix 2001:db8:cafe:1000::/64 infinite infinite no-autoconfig

So in the routing-table we just have a connected route, not a local route because there is no "real" IPv6 address on the SVI configured.

 

 

C   2001:db8:cafe:1000::/64 [0/0]
     via Vlan1000, directly connected

The point is, that I wanna advertise these connected routes through EIGRP, but it doesn't work.

 

 

router eigrp LAB
 !
 address-family ipv6 unicast autonomous-system ASN
  !
  af-interface default
   authentication mode md5
   authentication key-chain EIGRP
   passive-interface
  exit-af-interface
  !
  af-interface FastEthernet1/0/47
   summary-address 2001:db8:cafe:1000::/52
   no passive-interface
  exit-af-interface
  !
  topology base
   redistribute connected
  exit-af-topology
  eigrp stub connected summary
 exit-address-family
!

It starts working since I configure a ULA or GUA address on the interface (and I get a Local Receive Route in the RIB).

 

 

C   2001:db8:cafe:1000::/64 [0/0] 
via Vlan1000, directly connected L 2001:db8:cafe:1000::/128 [0/0] via Vlan1000, receive

Also the "redistribute connected" command doesn't help.

Is there any option to advertise these routes without configuring real addresses on the interfaces?

 


Thank you for your help and if there are some more information necessary I will share them here. :)

 

 

 

 

1 Accepted Solution

Accepted Solutions

Harold Ritter
Cisco Employee
Cisco Employee

Hi Leonard,

 

RFC7404 is about configuring only link local addresses on infrastructure links. You still have to configure globally unique addresses on customer facing subnets.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

16 Replies 16

Rolando Valenzuela
Enthusiast
Enthusiast

I think it is related with the fact that you are using interface VLAN instead of a real interface, but using real interfaces worked for me as showed here: https://www.cisco.com/c/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/113267-eigrp-ipv6-00.html

 

hostname ROUTER-A
!
ipv6 unicast-routing
!
interface Loopback1
no ip address
ipv6 address 2001::1/64
ipv6 enable
ipv6 eigrp 100
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
media-type rj45
ipv6 address FE80::1 link-local
ipv6 enable
ipv6 eigrp 100
!
ipv6 router eigrp 100
eigrp router-id 1.1.1.1

Results:

 

ROUTER-B#show ipv6 route
IPv6 Routing Table - default - 4 entries

D 2001::/64 [90/130816]
via FE80::4, GigabitEthernet0/1

 

Regards

Hey Rolando,

thank you for your Reply.
The concept you had build isn't really reflect my problem.
I can get EIGRP Neighborships (also possible through SVIs) and can also advertise routes when a IPv6 address (GUA or ULA) is configured on an Interface like you Loopack1.

 

You had build my case if you remove the IPv6 address from your loopback and just advertise the prefix through your Router Advertisements with the following command:

ipv6 nd prefix 2001::1/64

So if you have your Lo1 configured like this:

interface Loopback1
no ip address
ipv6 nd prefix 2001::1/64
ipv6 enable
ipv6 eigrp 100

Can you then see the route on Router-B?

:)

Hello LeonardW

I configured the interface like you asked and no, the route it is not advertised, but with the following setup it is.

interface Loopback1
no ip address
ipv6 address 2001::1/64
ipv6 enable
ipv6 nd prefix default no-advertise
ipv6 eigrp 100

What exactly are you trying to accomplish?

 

ipv6 nd ra suppress -> The router won't send periodical RA messages

ipv6 nd prefix default no-advertise -> The router won't publish the prefix in message RA that it send answering host RS

Hey Rolando,

I try to accomplish that it isn't needed to configure a address on the End-Host facing Interfaces and just advertise the Prefix in the RAs to the Hosts and per EIGRP to the neighboring routers. :)

Harold Ritter
Cisco Employee
Cisco Employee

Hi Leonard,

 

RFC7404 is about configuring only link local addresses on infrastructure links. You still have to configure globally unique addresses on customer facing subnets.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hey Harold,

thanks for your reply, I had thought that that this could be the reason... and that I had maybe misunderstood the RFC a little bit.
Still interesting if this would be possible because from a technical perspective it should be, or am I wrong?

If someone could explain why it isn't possible it would be cool. Has this something to do that the Router needs a Receive entry in the FIB?
Actually because of the fact that the LL Address is the base for the resolution of the gateway MAC it should work and with static routing it is also working.

Independent from this I would say that the topic is solved. :)

Hi Leonard,

 

> Still interesting if this would be possible because from a technical perspective it should be, or am I wrong?

 

Not sure what you mean here. Could you please explain what you are trying to achieve? It is certainly possible to deploy RFC7404 with EIGRPv6, as it relies on LLA to establish the session between routers. Therefore the infrastructure links do not need to have GUA assigned at all (except for the loopback interface). But at the end of the day, the user subnets need a global address in order to get global connectivity.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Yeah, okay... RFC7404 is just talking about infrastructure links. All right!

My question now is, why it isn't also possible to have just a LLA on the Client-Facing Default Gateway. Where is the technical restriction there?
To advertise these subnets through EIGRPv6.
Yeah, it is possible to build neighborships just with LLAs, but it isn't advertise Networks which are just defined in the RAs.
Like here:

interface Vlan1000
ipv6 address FE80::1000:A link-local
!NO ipv6 address like ULA or GUA ipv6 nd prefix 2001:db8:cafe:1000::/64 infinite infinite no-autoconfig

 

But at the end of the day, the user subnets need a global address in order to get global connectivity.

Yeah, the End-Clients need a address with globale scope, that's clear, but why the Gateway in the End-User network need this too?

 

 

Is this descripton better? :)

Hi Leonard,

 

This will not work, as eigrpv6 will not insert the prefix in its topology table.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Yeah, but why?
I just try to understand where the technical restriction is there. :)

Hi Leonard,

 

Not sure why eigrpv6 will not redistribute the connected route, but I fail to see any advantage of not configuring the GUA on the interface if you are going to inject it in eigrp anyway.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hey Harold,

my Idea was just that the config and the routing table looks simpler if there is no ULA/GUA on the SVI. :)
And if it is not really necessary from a technical perspective, why should I care about?
Yeah, there are some reasons, maybe for Traceroutes or ICMPv6 responses, but basically everything works also without.

But if you need to route to that specific subnet configured using the "ipv6 nd" command, you need to have the route in the routing table anyway. And as far as the the configuration is concerned, it is not that big of a deal to add the "ipv6 address" under the interface.

 

Regards,

 

 

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

>But if you need to route to that specific subnet configured using the "ipv6 nd" command, you need to have the route in the >routing table anyway.

That's the point, the "C" route is created as soon as this "ipv6 nd" command is configured.
In my eyes it doesn't makes sense to configure then a additional "ipv6 address" under the interface to get a "L" Route.

 

>And as far as the the configuration is concerned, it is not that big of a deal to add the "ipv6 address" under the interface.

Yeah, it's not a big deal, but still additional config and also a additional entry in the RIB, so if we could waive this, the config and the RIB could be more "nice".

But anyway. I think this could end in a endless discusion.
Thanks for your help. :)

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: