cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1802
Views
0
Helpful
1
Replies

How to config 4PE with SRv6 in IOS-XR

Kagamigawa
Spotlight
Spotlight

https://www.ietf.org/id/draft-ietf-bess-ipv6-only-pe-design-00.html#name-test-3-e2e-ipv6-only-pe-ce-

5.3.  Test-3 E2E IPv6-Only PE-CE, Global Table over IPv6-Only Core (4PE), 4to6 Softwire 

                               ________
     IPv6-Only       _____    /        \                 IPv6-Only
      PE / CE       /     \__/          \___              PE / CE
  +----+  +----+   /                        \        +------+   +-----+
  |    |  |    |  |                          |_      |      |   |     |
  |    |  |    |  |                             \    |      |   |     |
  | CE |--| PE |--\         IPv6-Only Core      |----|  PE  |---|  CE |
  |    |  |    |    \0=========Underlay =======0|    |      |   |     |
  +----+  +----+     \                        __/    +------+   +-----+
  IPv6 BGP peer       \     MPLS / SR domain /         IPv6 BGP peer
  IPv4 forwarding      \__         __       /          IPv4 forwarding
  IPv6 forwarding         \_______/  \_____/           IPv6 forwarding



Cisco, Juniper, Arista, Nokia, Huawei code and platform and test results.

Cisco: Edge Router- XR ASR 9910 IOS XR 7.4.1, Core Router- NCS 6000 7.2.2, CRS-X 6.7.4

Juniper: Edge Router- MX platform MX480, MX960, Core Router- PTX Platform PTX5000, PTC10K8 (JUNOS and EVO) Release 20.4R2

Tested v4 edge over v6 core in a virtual setup using vMX platforrm and 20.4R2 and LDPv6 as underlay, but there were some data plane forwarding issues. Tested same setup on latest release 21.4 and it worked. Investigating what the minimum version is for this setup to work.

Arista:

Nokia: Edge and Core-7750 Service Router, Release R21

Huawei: Edge and Core-VRPv8, Release VRP-V800R020C10

 

According to the description in this article, the current ios-xr system can achieve 4PE

I used the following platforms for testing:

Build Information:
Built By : ingunawa
Built On : Wed Aug 4 04:18:28 PDT 2021
Built Host : iox-ucs-012
Workspace : /auto/srcarchive17/prod/7.4.1/xrv9k/ws
Version : 7.4.1
Location : /opt/cisco/XR/packages/
Label : 7.4.1-0

 

Here is the topology diagram:

topo.png

configurations:

hostname PE1
logging console informational
!
interface Loopback0
 ipv6 address 2001:db8:cafe:aaaa::1/128
!
interface GigabitEthernet0/0/0/1
 ipv6 enable
!
interface GigabitEthernet0/0/0/2
 ipv4 address 10.224.72.1 255.255.255.0
!
router isis underlay
 is-type level-2-only
 net 49.0192.0168.0255.0001.00
 log adjacency changes
 address-family ipv6 unicast
  metric-style wide
  segment-routing mpls
 !
 interface Loopback0
  address-family ipv6 unicast
   prefix-sid index 1
  !
 !
 interface GigabitEthernet0/0/0/1
  address-family ipv6 unicast
  !
 !
!
end
hostname P
!
interface Loopback0
 ipv6 address 2001:db8:cafe:bbbb::1/128
!
interface GigabitEthernet0/0/0/1
 ipv6 enable
!
interface GigabitEthernet0/0/0/2
 ipv6 enable
!
router isis underlay
 is-type level-2-only
 net 49.0192.0168.0255.0002.00
 log adjacency changes
 address-family ipv6 unicast
  metric-style wide
  segment-routing mpls
 !
 interface Loopback0
  address-family ipv6 unicast
   prefix-sid index 2
  !       
 !
 interface GigabitEthernet0/0/0/1
  address-family ipv6 unicast
  !
 !
 interface GigabitEthernet0/0/0/2
  address-family ipv6 unicast
  !
 !
!
end
hostname PE2
logging console informational
!
interface Loopback0
 ipv6 address 2001:db8:cafe:cccc::1/128
!
interface GigabitEthernet0/0/0/1
 ipv6 enable
!
interface GigabitEthernet0/0/0/2
 ipv4 address 10.224.4.1 255.255.255.0
!
router isis underlay
 is-type level-2-only
 net 49.0192.0168.0255.0003.00
 log adjacency changes
 address-family ipv6 unicast
  metric-style wide
  segment-routing mpls
 !
 interface Loopback0
  address-family ipv6 unicast
   prefix-sid index 3
  !
 !
 interface GigabitEthernet0/0/0/1
  address-family ipv6 unicast
  !
 !
!
end

mpls forwarding table on PE1:

RP/0/RP0/CPU0:PE1#show mpls forwarding 
Wed Dec  1 07:56:33.239 UTC
Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes       
Label  Label       or ID              Interface                    Switched    
------ ----------- ------------------ ------------ --------------- ------------
16002  Pop         SR Pfx (idx 2)     Gi0/0/0/1    fe80::5209:abff:fe00:704   \
                                                                   10282       
16003  16003       SR Pfx (idx 3)     Gi0/0/0/1    fe80::5209:abff:fe00:704   \
                                                                   3970        
24000  Pop         SR Adj (idx 1)     Gi0/0/0/1    fe80::5209:abff:fe00:704   \
                                                                   0           
24001  Pop         SR Adj (idx 3)     Gi0/0/0/1    fe80::5209:abff:fe00:704   \
                                                                   0           

When I try to commit bgp configuration on PE1 , I got an error

router bgp 64512
 bgp router-id 192.168.255.1
 bgp log neighbor changes detail
 address-family ipv4 unicast
  redistribute connected
  allocate-label all
 !
 address-family ipv6 unicast
 !
 neighbor-group 4PE
  remote-as 64512
  update-source Loopback0
  address-family ipv4 labeled-unicast
  !
 !        
 neighbor 2001:db8:cafe:cccc::1
  use neighbor-group 4PE
 !
!
% Failed to commit one or more configuration items during a pseudo-atomic operation. Al
l changes made have been reverted. Please issue 'show configuration failed [inheritance
]' from this session to view the errors
RP/0/RP0/CPU0:PE1(config-bgp-nbr)#RP/0/RP0/CPU0:Dec  1 07:58:11.791 UTC: bgp[1078]: %RO
UTING-BGP-3-INIT_GET_VALUE : Failed to obtain Instance ID: bpm/info/default/inst-id dur
ing initialization: 'sysdb' detected the 'warning' condition 'A SysDB client tried to a
ccess a nonexistent item or list an empty directory'
Wed Dec  1 07:59:17.924 UTC
!! SEMANTIC ERRORS: This configuration was rejected by 
!! the system due to semantic errors. The individual 
!! errors with each failed configuration command can be 
!! found below.


router bgp 64512
 neighbor-group 4PE
  address-family ipv4 labeled-unicast
!!% Change would result in neighbor (2001:db8:cafe:cccc::1) being activated with an invalid address family

What caused this?

 

1 Reply 1

Harold Ritter
Cisco Employee
Cisco Employee

This question has been posted and answered in another section of the Cisco Community.

 

https://community.cisco.com/t5/routing/how-to-config-4pe-with-srv6-in-ios-xr/m-p/4511232#M359117

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Review Cisco Networking for a $25 gift card