Showing results for 
Search instead for 
Did you mean: 

iPXE on UCS-C220-M5 using IPv6 doesn't work


Hi Team,

I am trying to use iPXE on a Cisco UCS C220-M5 machine. The machine uses the NIC model- UCS VIC 1457. Whatever I do I cannot get networking up using IPv6 from within iPXE.  I tried to use both SLAAC and Stateful DHCPv6 approach for obtaining IPv6 address, but both don't work. In order to make sure it is not an IPv6 setup issue, I tried to obtain an IPv6 address using both approaches from within a Linux VM. This worked.  

When I initiate a PXE boot over IPv6 the below steps happen:

  1. PXE boot over IPv6 is kickstarted.
  2. DHCPv6 server (isc-dhcp-server6 service running in an ubuntu VM) provides an IPv6 address along with the details of bootfile-url - ipxe.efi (Router Solicitation, Router advertisement, Request, DHCPv6 Solicit, DHCPv6 Advertise, DHCPv6 Request and DHCPv6 Reply related messages can be seen in the log).
  3. The UCS machine downloads and loads ipxe.efi (and along the journey the IPv6 address obtained in step 2 is released).
  4. As soon as NBP is loaded, it attempts to set up network - and this fails 

 Screen Shot 2022-03-15 at 1.59.47 pm.png

When I try to manually setup ipv6 address from iPXE console, what I can see is: Router Solicitation and Router Advertisement steps as mentioned in works. But further steps (DHCPv6 Solicit, DHCPv6 Advertise, DHCPv6 Request and DHCPv6 Reply) doesn't happen. 


I cannot find any cisco related ipxe driver in . Could this be a cisco NIC compatibility issue with ipxe?


Would appreciate any help with this. I am kind of stuck with the issue for the past many weeks.


0 Replies 0
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers