cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3574
Views
10
Helpful
6
Replies

NX OS DHCPv6 Relay Agent Prefix Delegation works but no static routes are created

MHasart
Beginner
Beginner

Hello,
I observed the following behaviour of a Nexus 3172 PQ-XL with nx os 9.2.2: the device relays dhcpv6 packets towards a configured server and sends the answer to the client. Everything works as expected. In contrast the implementation of the dhcpv6 relay agent in ios and ios xe, it seems, that no static route is created when a packet containing an identity association for prefix delegation with a valid prefix is proceeded.
Is this behavior a bug (or missing feature) or miss any configuration for the dhcpv6 relay agent?

6 Replies 6

Hi,

Could you please share the configuration you are using to test and show me the output for the static route?

Thanks.

Note:  We are getting the devices "down range" from the N7K to use SLAAC for their /64 address
assignment, however when the down range device does a PD request of the DHCP6 server, it gets
assigned a /64 prefix. However, unlike the same operation on an ASR1001, the Prefix-Delegation does
not seem to go into the static routing table nor is it redistributed via (in this case) OSFPv3.

---

Cisco Nexus Operating System (NX-OS) Software

Software
BIOS: version 2.12.0
kickstart: version 6.2(24)
system: version 6.2(24)

cisco Nexus7000 C7009 (9 Slot) Chassis ("Supervisor Module-2")



interface Vlan98
ip access-group CE-IPv4-inbound in
ipv6 traffic-filter CE-IPv6-inbound in
ip access-group CE-IPv4-outbound out
ipv6 traffic-filter CE-IPv6-outbound out
no ip redirects
ip address 60.180.90.233/29
ipv6 address 2600:2100:112:1::feed:1/64
ipv6 link-local fe80::98:feed:1
ipv6 nd other-config-flag
no ipv6 redirects
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 3 xxxxxxxxxxxxxxxx
ip ospf cost 2000
ip ospf passive-interface
ip router ospf 101 area 0.0.0.0
ospfv3 cost 2000
ospfv3 passive-interface
ipv6 router ospfv3 101 area 0.0.0.0
ip dhcp relay address 140.90.80.115
ip dhcp relay information trusted
ip dhcp smart-relay
ipv6 dhcp relay address 2604:21c0::feed:200
description TOWER:: TowerTEST_HE2 Public Network
no shutdown




For instance, the downrange device gets a valid IPv6 address on vlan98, and is assigned the
prefix 2600:2100:112:82b::/64

The only route in the routing table within the above /48 is the 2600:2100:112 itself...

 

Hello,

 

can you post the configs of both the ASR and the Nexus ?

What we use on the ASR is the following (note that each tower is issued a /48 to break down into /60's issued to customers):

ipv6 unicast-routing
ipv6 dhcp iana-route-add

!

interface TenGigabitEthernet0/1/0.96
description TOWER:: public : livermore
encapsulation dot1Q 96
ip dhcp relay information trusted
ip dhcp relay information option-insert
ip dhcp relay information check-reply
ip address x.x.x.1 255.255.252.0
ip helper-address 147.90.x.x
ip helper-address 208.80.x.x
no ip redirects
no ip proxy-arp
ip verify unicast source reachable-via rx
ip access-group CE-IPv4-inbound in
ip access-group CE-IPv4-outbound out
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 xxxxxxxxxx
ip ospf cost 2000
ipv6 address FE80::FEED:96:1 link-local
ipv6 address 2604:xxxx:xxxx:1::FEED:1/64
ipv6 enable
ipv6 nd managed-config-flag
ipv6 nd other-config-flag
ipv6 nd router-preference High
no ipv6 redirects
no ipv6 unreachables
ipv6 dhcp relay destination 2604:xxxx::FEED:1
ipv6 verify unicast source reachable-via rx
ipv6 traffic-filter CE-IPv6-inbound in
ipv6 traffic-filter CE-IPv6-outbound out

gbrewster
Beginner
Beginner

@mdella000 Did you ever get this figured out? We are having the exact same problem. 

No, actually spent quite a bit of time on the N7K working with v6, v7.1, v7.2, and v7.3. Also tried v8.1 but none of them correctly tracked the PD announcement from the KEA DHCP server.  If we used the Nexus itself as the PD issuer, then it worked fine. But doing so eliminated our central repository of PDs across our ISP network,  Currently we're working with either the ASR series or with Juniper software to be our network PD issuing routers (ie, the DHCP relay point w/M+O flags).

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: