cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

193
Views
0
Helpful
6
Replies
Highlighted

Epas soap im&p 11.5 group delete not working

Hi everyone, i need some help here.

 

I'm using the soap epas webservices to manage the contact list of the end users, until now add or delete contacts works perfectly, also add a group which is created when a contact is added to a new group. The problem remains on the delete of an empty group, as the documentation says: when all the contacts of the groups are deleted then also the group is deleted, but on my clients the groups remains empty.

 

This is the soap message that i'm using to delete the contacts which works well:

 

<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:urn="urn:cisco:epas:soap">
<soap:Header>
<urn:session-key>nnnnnnnnnn</urn:session-key>
</soap:Header>
<soap:Body>
<urn:delete-contact>
<!--1 or more repetitions:-->
<urn:group name="Cisco - Roma">
<!--1 or more repetitions:-->
<urn:persona-id domain="cisco.com">user1</urn:persona-id>
<urn:persona-id domain="cisco.com">user2</urn:persona-id>
<urn:persona-id domain="cisco.com">user3</urn:persona-id>
</urn:group>
</urn:delete-contact>
</soap:Body>
</soap:Envelope>

 

Any advice to do some troubleshooting would be very helpfull

 

And thanks !!!

Everyone's tags (6)
6 REPLIES 6
Cisco Employee

Re: Epas soap im&p 11.5 group delete not working

Hi,

There is no Delete Group operation.  Instead, delete all the contacts in the group, and the group should automatically be deleted after you've deleted the last contact in it. 

You may have to restart your client to see the change.

Delete all contacts -> restart your client -> then check if the contact group is deleted.

Regards,
Anusha B R

Re: Epas soap im&p 11.5 group delete not working

Hi Anusha, thanks for your response, I had done what you told me but after the restart, I’m still seeing the empty groups.

This is the soap answer that I receive when I delete the last contact of the group, and the contact is deleted as it should

 

<env:Envelope xmlns:env="http://www.w3.org/2003/05/soap-envelope" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<env:Body>
<epas:delete-contact-resp xmlns:epas="urn:cisco:epas:soap">
<epas:status ret-code="0" persona-id="contactx" group="Usa" domain="cisco.com">succeeded</epas:status>
</epas:delete-contact-resp>
</env:Body>
</env:Envelope>

 

but after the restart of the jabber client (Windows or iOS) the group is still there without contacts.

If I run a select to the “groups” table, the groups without any contact is not present on that table, if a run a select to the “rosters” table, I can see that the deleted contact is no present on the that table too.

 

Is there another table that I can check to troubleshoot my issue? Or if exist another way to make a troubleshooting to find out the problem should be very helpful; can you please help me with this?

 

Cisco Employee

Re: Epas soap im&p 11.5 group delete not working

Theorizing that the group is de facto gone from the IM&P point of view after your delete operations, but somehow kept around by the client itself, it would be interesting to see what happens if you reset Jabber on the PC and then reconnected it, and then tried installing the Jabber account on another PC.

 

Perhaps an enhancement is needed in the client to clean up empty groups when the last contact is removed...

Re: Epas soap im&p 11.5 group delete not working

Hi mate, thanks for the advice, this the test that I have done, using Soapui, I have deleted the last user from the group “Torino” (see screenshot), then I have created the group “test1” adding one contact to the group, then I have delete the contact from “test1”.

 

To test the client cache theory, I used a laptop from a colleague, where I made the logon for the first time, so my Windows and Jabber local profile has been created without any luck, I’m still seeing the empty groups on the new pc and for sure this info has been downloaded from the server.

 

As always, I'm available to make any test to find out where the problem is, thanks

Re: Epas soap im&p 11.5 group delete not working

Hello everyone,

Any update on this? Anyone?

Maybe if this is a problem on my installation, perhaps I can open a tac for this?

If it is possible can I have an advice on how to handle this kind of tac? Is there a specific area where I must address my request?

Cisco Employee

Re: Epas soap im&p 11.5 group delete not working

You can open a ticket with DevNet Developer Support from here: https://developer.cisco.com/site/support/

We'll be able to work with you to get detailed troubleshooting traces, escalations questions/issues into engineering as needed, etc.  My guess is that this is a limitation of how the API works, but perhaps we can identify a workaround or a possible enhancement/defect to improve it.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here