cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
715
Views
5
Helpful
4
Replies

Egress cos marking on 7600 ES20G card

tomasimatel
Level 1
Level 1

Hi all, one of our network providers demands that all frames going through their systems be marked with cos S-tag value 0, everything else is dropped.

So, we need to set that mark on packets leaving our 7600, but we are having a hard time configuring QoS on it. We are trying this config:

class-map match-all todos
match any
!
policy-map cos0
class todos
set cos 0
!
interface TenGigabitEthernet4/0/0
 no ip address
 no mls qos trust
interface TenGigabitEthernet4/0/0.101
 encapsulation dot1Q 2031 second-dot1q 101
 ip address 10.0.58.29 255.255.255.252

But when I issue the command service-policy:

Router(config-if)#int te4/0/0.101
Router(config-subif)#service-policy output cos0
Queueing must be defined in class-default in a flat policy on this interface

I've searched for help using class-default but couldn't get it to work, could somebody please throw some light on it? Thanks

Tomas

1 Accepted Solution

Accepted Solutions

Hello

Thanks for the information. This kind of configuration is not supported on ES20 linecard:

http://www.cisco.com/c/en/us/td/docs/routers/7600/install_config/ES20_config_guide/es20-config-guide/bald_qos.html#wp1374723

Marking policy in the egress direction is only supported with another queueing action in the class-default policy on the ES20. below is a sample config

class-map match-all todos
match any
!
policy-map cos0
class todos
set cos 0
class class-default
shape average 100000

!

interface TenGigabitEthernet4/0/0
 no ip address
 no mls qos trust
interface TenGigabitEthernet4/0/0.101
 encapsulation dot1Q 2031 second-dot1q 101
 ip address 10.0.58.29 255.255.255.252
service-policy output cos0

Hope this answers your question.

Regards

Vinit

PS: Please mark the question as answered if your query has been answered.

Thanks
--Vinit

View solution in original post

4 Replies 4

Vinit Jain
Cisco Employee
Cisco Employee

Could you please share the show version | in image and show module 4 command output.

Thanks

Vinit

Thanks
--Vinit

Hi Vinit, here is the info you asked, thanks and regards.

Router#show version | in image
System image file is "sup-bootdisk:c7600s72033-adventerprisek9-mz.153-1.S.bin"
Router#show module 4
Mod Ports Card Type                              Model              Serial No.
--- ----- -------------------------------------- ------------------ -----------
  4    2  ESM20G                                 7600-ES20-10G3CXL  JAE1139XYYK

Mod MAC addresses                       Hw   Fw            Sw           Status
--- ---------------------------------- ----- ------------- ------------ -------
  4  001b.d588.b040 to 001b.d588.b0bf  1.1   12.2(33r)SRB  15.3(1)      Ok

Mod  Sub-Module                  Model              Serial       Hw     Status
---- --------------------------- ------------------ ----------- ------- -------
  4  ESM20G Distributed Forwardi 7600-ES20-D3CXL    JAE114522ZM  1.0    Ok
 4/0 1x10GE XFP Port             7600-ES20-2X10G    JAE1145214G  1.0    Ok
 4/1 1x10GE XFP Port             7600-ES20-2X10G    JAE1145214G  1.0    Ok

Mod  Online Diag Status
---- -------------------
  4  Pass
 4/0 Pass
 4/1 Pass

Hello

Thanks for the information. This kind of configuration is not supported on ES20 linecard:

http://www.cisco.com/c/en/us/td/docs/routers/7600/install_config/ES20_config_guide/es20-config-guide/bald_qos.html#wp1374723

Marking policy in the egress direction is only supported with another queueing action in the class-default policy on the ES20. below is a sample config

class-map match-all todos
match any
!
policy-map cos0
class todos
set cos 0
class class-default
shape average 100000

!

interface TenGigabitEthernet4/0/0
 no ip address
 no mls qos trust
interface TenGigabitEthernet4/0/0.101
 encapsulation dot1Q 2031 second-dot1q 101
 ip address 10.0.58.29 255.255.255.252
service-policy output cos0

Hope this answers your question.

Regards

Vinit

PS: Please mark the question as answered if your query has been answered.

Thanks
--Vinit

Thanks Vinit, that did the trick, we'll try tomorrow night to see if it works against our provider equipment.

Just one more doubt, is there a way to make CoS marking work on LAN cards like WS-X6704-10GE? Thanks

Tomas