05-10-2016 12:52 AM
I have one CE router R9, PE router R7, P router R6
in R9, I try to traceroute 150.1.0.6, it first reach 150.1.0.9(R7), then all are * * *, there is no vpn label, may I know how to correct the error and generate VPN label, previously I can generate transport label, after using VRF, now everything mess up.
R9 is using VRF:
interface Loopback0
ip address 150.1.0.9 255.255.255.0
!
interface FastEthernet0/0
ip vrf forwarding R9_R7
ip address 155.1.0.9 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
++++++++++++++++++
R7 configuration:
ip vrf R9_R7
!
no ip domain lookup
!
mpls label range 700 799
multilink bundle-name authenticated
!
interface Loopback0
ip address 150.1.0.7 255.255.255.0
!
interface FastEthernet0/0
ip vrf forwarding R9_R7
ip address 155.1.0.7 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 155.1.76.7 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 150.1.0.6 remote-as 100
neighbor 150.1.0.6 update-source Loopback0
!
address-family ipv4
neighbor 150.1.0.6 activate
no auto-summary
no synchronization
exit-address-family
+++++++++++++++++++++
R6 configuration:
interface Loopback0
ip address 150.1.0.6 255.255.255.0
!
interface FastEthernet0/0
ip address 155.1.68.6 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 155.1.76.6 255.255.255.0
duplex auto
speed auto
!
router ospf 1
mpls ldp autoconfig
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 150.1.0.7 remote-as 100
neighbor 150.1.0.7 update-source Loopback0
neighbor 150.1.0.8 remote-as 100
neighbor 150.1.0.8 update-source Loopback0
no auto-summary
+++++++++++++++++++++
05-10-2016 05:45 AM
Hello jolinchewjb ,
In MPLS VPN environments, the CE will not be able to communicate with the P routers or the core MPLS routers in the network. This is due to the fact that the core routers are VRF-unaware and hence will not understand VPN labels. They solely just forward packets based on the transport label.
Tracerouting from the CE router to a P router inside an MPLS core network will not work. Unless you configure the P router as a PE router as well.
Thx,
Victor Hugo Acevedo
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide