02-07-2024 12:27 AM
I have configured HSRP for High Availability but now from VPC I'm not able to reach vpc.
Below is my routers and switch configuration. Thank you
R1
!
!
interface GigabitEthernet1
ip dhcp client client-id ascii 9MGT16SBA3J
ip address dhcp
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet2
ip address 10.20.5.2 255.255.255.0
standby 1 ip 10.20.5.1
standby 1 priority 200
standby 1 preempt
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet3
no ip address
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet4
no ip address
negotiation auto
no mop enabled
no mop sysid
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http client source-interface GigabitEthernet1
!
ip route 0.0.0.0 0.0.0.0 172.29.129.254
!
!
!
!
!
end
R1#
R1#
R2
!
!
interface GigabitEthernet1
ip dhcp client client-id ascii 9CCEW1X8XMQ
ip address dhcp
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet2
ip address 10.20.5.3 255.255.255.0
standby 1 ip 10.20.5.1
standby 1 priority 150
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet3
no ip address
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet4
no ip address
negotiation auto
no mop enabled
no mop sysid
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http client source-interface GigabitEthernet1
!
ip route 0.0.0.0 0.0.0.0 172.29.129.254
!
!
!
!
SWITCH
!
interface GigabitEthernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
negotiation auto
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
negotiation auto
!
interface GigabitEthernet0/2
switchport mode access
negotiation auto
spanning-tree portfast edge
!
interface GigabitEthernet0/3
negotiation auto
!
interface GigabitEthernet1/0
negotiation auto
!
interface GigabitEthernet1/1
negotiation auto
!
interface GigabitEthernet1/2
negotiation auto
!
interface GigabitEthernet1/3
negotiation auto
!
interface Vlan50
ip address 10.20.50.5 255.255.255.0
!
ip default-gateway 10.20.50.1
ip forward-protocol nd
!
ip http server
Solved! Go to Solution.
02-08-2024 12:07 AM
did you config NAT overload ?
MHM
02-07-2024 04:25 AM
Share the topolgy'
Abd you tag the issue with mpls but I dont see any related of config with mpls.
MHM
02-07-2024 11:59 PM
02-08-2024 12:07 AM
did you config NAT overload ?
MHM
02-08-2024 12:15 AM
02-08-2024 12:52 AM
I have applied NAT Overload it work perfect even HSRP when I shutdown the inside interface it switch to R2 automatically and internet traffic did not drop. Thank you MHM.
Below is R1 working configuration.
interface GigabitEthernet1
ip dhcp client client-id ascii 9MGT16SBA3J
ip address dhcp
ip nat outside
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet2
ip address 10.20.5.2 255.255.255.0
ip nat inside
standby version 2
standby 1 ip 10.20.5.1
standby 1 priority 200
standby 1 preempt
shutdown
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet3
no ip address
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet4
no ip address
negotiation auto
no mop enabled
no mop sysid
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http client source-interface GigabitEthernet1
!
ip nat inside source list 50 interface GigabitEthernet1 overload
ip route 0.0.0.0 0.0.0.0 172.29.129.254
!
!
ip access-list standard 50
10 permit 10.20.5.0 0.0.0.255 log
!
!
!
!
!
control-plane
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide