Hi
I am preping up coming upgrade from brocade to Cisco and we have flat network 20 sites daisy chained with fiber link running OSPF area 0 including backbone. We would like to implement mpls VPN and create 10- 15 vlan vrf lite instance- we want to do with minimumm down time. I cannot create sub-interfaces between sites per vrf instead I labbed up using peering sites with EBGP multi-hop using router loopback PE to CE
R1CE------R2CE-------R3PE-------R4PE-----R5CE------R6CE
R3-R4= IBGP- MPLS VPNV4-
R1CE peered with R3 with ebgp-multihop using Lo0
R6CE peered with R4 with ebgp-multihop uisngLo0
R2 and R5 pure mpls ldp not configured with ebgp-multihop yet
peering ebgp and Ibgp established OK.
created Vrf RED/ospf vrf instance on R1,R3,R4, and R6 and redistributed bgp address family:
R1:
ip vrf RED
rd 65000:100
route-target export 65000:100
route-target import 65000:100
router ospf 10 vrf RED
!
router bgp 65008
bgp router-id 8.8.8.8
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 65000
neighbor 2.2.2.2 ebgp-multihop 255
neighbor 2.2.2.2 update-source Loopback0
!
address-family ipv4
redistribute connected
redistribute static
neighbor 2.2.2.2 activate
exit-address-family
!
address-family ipv4 vrf RED
redistribute connected
redistribute static
redistribute ospf 8
exit-address-family
network 10.10.10.0 0.0.0.255 area 0
!router ospf 8 vrf RED
capability vrf-lite
redistribute bgp 65008 subnets
!
R6:
ip vrf RED
rd 65000:100
route-target export 65000:100
route-target import 65000:100
!
router ospf 7 vrf RED
capability vrf-lite
redistribute connected
redistribute static
redistribute bgp 65007 subnets
!
router ospf 1
mpls ldp sync
mpls ldp autoconfig
router-id 7.7.7.7
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 65007
bgp router-id 7.7.7.7
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 65000
neighbor 3.3.3.3 ebgp-multihop 255
neighbor 3.3.3.3 update-source Loopback0
!
address-family ipv4
redistribute connected
redistribute static
neighbor 3.3.3.3 activate
exit-address-family
!
address-family ipv4 vrf RED
redistribute connected
redistribute static
redistribute ospf 7
exit-address-family
!
R1: sh ip route vrf RED
Gateway of last resort is not set
20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 20.20.20.0/24 is directly connected, Loopback1
L 20.20.20.1/32 is directly connected, Loopback1
!
PER3:
ip vrf RED
rd 65000:100
route-target export 65000:100
route-target import 65000:100
address-family ipv4 vrf RED
R3#
R3#
R3#sh run | sec bgp
ipv6 multicast rpf use-bgp
router bgp 65000
bgp router-id 3.3.3.3
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 2.2.2.2 remote-as 65000
neighbor 2.2.2.2 update-source Loopback0
neighbor 7.7.7.7 remote-as 65007
neighbor 7.7.7.7 ebgp-multihop 255
neighbor 7.7.7.7 update-source Loopback0
!
address-family ipv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 2.2.2.2 next-hop-self
neighbor 7.7.7.7 activate
exit-address-family
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 2.2.2.2 next-hop-self
exit-address-family
!
address-family ipv4 vrf RED
exit-address-family
!
PE4:
ipv6 multicast rpf use-bgp
router bgp 65000
bgp router-id 2.2.2.2
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 3.3.3.3 remote-as 65000
neighbor 3.3.3.3 update-source Loopback0
neighbor 8.8.8.8 remote-as 65008
neighbor 8.8.8.8 ebgp-multihop 255
neighbor 8.8.8.8 update-source Loopback0
!
address-family ipv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
neighbor 3.3.3.3 next-hop-self
neighbor 8.8.8.8 activate
exit-address-family
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
neighbor 3.3.3.3 next-hop-self
exit-address-family
!
address-family ipv4 vrf RED
redistribute connected
redistribute static
exit-address-family
!ip vrf RED
rd 65000:100
route-target export 65000:100
route-target import 65000:100
address-family ipv4 vrf RED
redistribute connected
redistribute static
!