cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1195
Views
0
Helpful
2
Replies

XR not sending a vrf Loopback

Hello All ,

                I am really having a very strange case , XR2 is a vpnv4 route refelctor . In the same time it is having a vrf FOO with a loop back configured in it . XR2 is having a multihop ebgp session with R4 . Problem is XR2 is sending the the Lo1 route to its iBGP peers but not to its EBGP peer !!! . And below is the logs I am getting

RP/0/0/CPU0::Nov 11 14:27:39.736 : bgp[139]: [upd] (vpn4u): No unreachable (not advertising imported path to non-CE neighbor) sent to sub-group 0.2 with v4Addr:10.0.0.20:1:172.16.0.19/32

RP/0/0/CPU0::Nov 11 14:27:39.737 : bgp[139]: [upd] (vpn4u): Skip UPDATE to sub-group 0.2 for v4Addr:10.0.0.20:1:172.16.0.5/32 (0), path , imported path table TBL:default (1/128)

RP/0/0/CPU0::Nov 11 14:27:39.737 : bgp[139]: [upd] (vpn4u): No unreachable (not advertising imported path to non-CE neighbor) sent to sub-group 0.2 with v4Addr:10.0.0.20:1:172.16.0.5/32

RP/0/0/CPU0::Nov 11 14:27:39.738 : bgp[139]: [upd] (vpn4u): Skip UPDATE to sub-group 0.2 for v4Addr:10.0.0.20:1:172.16.0.2/32 (0), path , imported path table TBL:default (1/128)

RP/0/0/CPU0::Nov 11 14:27:39.739 : bgp[139]: [upd] (vpn4u): No unreachable (not advertising imported path to non-CE neighbor) sent to sub-group 0.2 with v4Addr:10.0.0.20:1:172.16.0.2/32

RP/0/0/CPU0::Nov 11 14:27:39.739 : bgp[139]: [upd] (vpn4u): No unreachable (no label found) sent to sub-group 0.2 with v4Addr:10.0.0.20:1:172.16.0.20/32

RP/0/0/CPU0::Nov 11 14:27:39.740 : bgp[139]: [upd] (vpn4u): Updgen - TBL:default (1/128) UG: 0.4 SG: 0.2 msg: 3 pfx: [tot] adv/wdn/sup/skp/be [13] 3/0/0/10/0 ver: 0 -> 14 res ver: 0 -> 14 limits: wr/tot 50000/250000

RP/0/0/CPU0::Nov 11 14:27:39.740 : bgp[139]: [upd] (vpn4u): Generated 3 updates for update sub-group 0.2 (average size = 84 bytes, maximum size = 84 bytes)

RP/0/0/CPU0::Nov 11 14:27:39.741 : bgp[139]: [upd] (vpn4u): Updates replicated to neighbor 10.0.0.4

RP/0/0/CPU0:XR2#

Note that 172.16.0.20 is the Lo1 ip address that belong to vrf FOO

below is the config

===============================================================

interface Loopback1

vrf FOO

ipv4 address 172.16.0.20 255.255.255.255

ipv6 address 2001:172:16::20/128

!

interface Loopback0

ipv4 address 10.0.0.20 255.255.255.255

ipv6 address 2001:10::20/128

!

interface GigabitEthernet0/2/1/1.205

ipv4 address 10.0.205.20 255.255.255.0

ipv6 address 2001:10:0:205::20/64

dot1q vlan 205

!

interface GigabitEthernet0/2/1/1.220

ipv4 address 10.0.220.20 255.255.255.0

ipv6 address 2001:10:0:220::20/64

dot1q vlan 220

!

interface GigabitEthernet0/2/1/1.207

vrf FOO

ipv4 address 172.16.207.20 255.255.255.0

ipv6 address 2001:172:16:207::20/64

dot1q vlan 207

!

interface GigabitEthernet0/2/1/1.208

vrf FOO

ipv4 address 172.16.208.20 255.255.255.0

ipv6 address 2001:172:16:208::20/64

dot1q vlan 208

!

!

interface GigabitEthernet0/2/1/1.1920

ipv4 address 10.19.20.20 255.255.255.0

ipv6 address 2001:10:19:20::20/64

dot1q vlan 1920

vrf FOO

address-family ipv4 unicast

import route-target

1000:1

2000:1

!

export route-target

1000:1

!

!

!

route-policy PASS

pass

end-policy

!

router bgp 1000

address-family vpnv4 unicast

!

neighbor 10.0.0.2

address-family vpnv4 unicast

route-reflector-client

!

neighbor 10.0.0.5

remote-as 1000

update-source loopback0

address-family vpnv4 unicast

route-reflector-client

!

neighbor 10.0.0.19

remote-as 1000

update-source loopback0

address-family vpnv4 unicast

route-reflector-client

!

neighbor 10.0.0.4

remote-as 2000

ebgp-multihop

update-source loopback0

address-family vpnv4 unicast

next-hop-unchanged

route-policy PASS in

route-policy PASS out

!

vrf FOO

rd 10.0.0.20:1

address-family ipv4 unicast

network 172.16.0.20/32

==================================================

2 Replies 2

Hi George,

i guess you are doing Inter-AS Option C.. It may seem you are having some issues with label binding. double-check all your LDP neighbors and prefixes you need to redistribute in your IGB or to advertise by BGP+Label up to the PE.

Alessio

Adam Vitkovsky
Level 3
Level 3

Hello George,

Very interesting indeed,

It might be one of the XR super fancy features and obstructions.

So it refuses to advertise locally originated prefix to MP-eBGP peer, question is why.

No unreachable –that’s a good thing right?

(not advertising imported path to non-CE neighbor) –a reason or a hint here would help a lot

What do you see as a next hop localy on this router for the prefix 172.16.0.20 please?

Maybe try to set the nex-hop manualy via route-policy asociated with the network 172.16.0.20/32 cmd.

So you indeed don’t see it being advertised with cmd “sh bgp vpnv4 u neighbors 10.0.0.4 advertised-routes” right?

adam

adam