cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

This community is for technical, feature, configuration and deployment questions.
For production deployment issues, please contact the TAC! We will not comment or assist with your TAC case in these forums.
Please see How to Ask the Community for Help for other best practices.

873
Views
0
Helpful
8
Replies
Highlighted

ACS 5.1 not support ODBC and Oracle

Hi Netpro

Form my familiar and careless with old ACS version I bought ACS appliance 5.1 two unit to work in HA function. After installation and tried to configured to use with external database with ORACLE I did't not see anything. I tried to read the document and I didn't see any keyword that said this version support ODBC or Oracle. So anyone can help me what is the workaround solution for ACS to work with ODBC and Oracle.

Thanks

Pichet

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Sure Pichet,

ACS 4.2 can be installed on the CSACS-1120-K9 appliance by simply re-imaging it (so not really a downgrade) with a dedicated DVD.

You can obtain such a DVD through an official TAC case:

http://tools.cisco.com/ServiceRequestTool/create/launch.do

Regards,

Fede

--

If  this helps you and/or answers your question please mark the question as  "answered" and/or rate it, so other users can easily find it.

View solution in original post

8 REPLIES 8
Highlighted
Cisco Employee

Hi Pichet,

There is currently no support for ODBC in ACS 5.x.

If you requirement is to have ODBC integrated, this can still be done with ACS 4.2 for example.

Regards,

Fede

--

If  this helps you and/or answers your question please mark the question as  "answered" and/or rate it, so other users can easily find it.

Highlighted

Thank for reply and let me ask another question can I downgrade CSACS-1120-K9 from version 5.1 to 4.2 with existing license?

Thanks you

Pichet

Highlighted

Sure Pichet,

ACS 4.2 can be installed on the CSACS-1120-K9 appliance by simply re-imaging it (so not really a downgrade) with a dedicated DVD.

You can obtain such a DVD through an official TAC case:

http://tools.cisco.com/ServiceRequestTool/create/launch.do

Regards,

Fede

--

If  this helps you and/or answers your question please mark the question as  "answered" and/or rate it, so other users can easily find it.

View solution in original post

Highlighted

Hi Fede

My name is ittichai who are get the problem with ACS5.1 also. So, my problem is our customer are using Oracle is the database, then, i must using ACS5.1 to query the database on Oracle. As I know ACS 5.1 is not support ODBC which is support on v3x and v4x ACS. It is important feature to sync other database like SQL or Oracle. Anyway I may ask you that why ACS 5.1 is cutting off this feature and how i implement ACS5.1 with Oracle without ODBC feature.

Many thanks

Ittichai A.

Highlighted

Hi Ittichai,

ODBC support in ACS 5.1 has not been included as a design decision.

There are no ways to integrate ODBC with ACS 5.1: you may need to consider deploying ACS 4.2 instead (also installable on a 1120 appliance).

Regards,

Fede

--

If  this helps you and/or answers your question please mark the question as  "answered" and/or rate it, so other users can easily find it.

Highlighted

Hi Fede

Well, that is the bad news for me. Because our customer is done to order ACS5.1 appliance alredy. So, do you have other way or idea to do ACS 5.1 query on Orcacle? Right now i don't have any idea or recommendation from cisco. I hope that you or cisco may have some idea for me

Many thanks

Ittichai

Highlighted

Hi Ittichai,

There are no ways to integrate Oracle with ACS 5.1, as this is not mentioned among the supported external identity stores:

http://www.cisco.com/en/US/docs/net_mgmt/cisco_secure_access_control_system/5.1/user/guide/users_id_stores.html#wp1053043

For your current order of 1120 appliances, you could re-image them with ACS 4.2 if the Oracle databse is something you need to have at any cost.

Regards,

Fede

--

If  this helps you and/or answers your question please mark the question as  "answered" and/or rate it, so other users can easily find it.

Highlighted

Hi Federico

     I have some question to ask you that, now i have change the model to 1120 and re-image to be 4.2 already. But i still not see ODBC external database on external user database configuration on ACS. So, I need to know that how i turn it on from 1120 with version 4.2 .

Best Regrads

Ittichai

Content for Community-Ad