cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

This community is for technical, feature, configuration and deployment questions.
For production deployment issues, please contact the TAC! We will not comment or assist with your TAC case in these forums.
Please see How to Ask the Community for Help for other best practices.

688
Views
0
Helpful
2
Replies
sam.braughton
Beginner

ACS4.2 Internal DB Replication - not replicating AAA clients

I'm attempting to set up a new ACS4.2 server. ACS is installed, replication partner configured, etc. Master and new slave server are both running ACS4.2(0) Build 124. (Master shows "Patch 12", slave shows no patch info)

Replication settings on the new ACS server are identical to those on my current secondary ACS server that receives replicated data correctly.

Problem: I manually replicate from master ACS server to the new ACS server. Logs on both servers indicate a successful replication. Users, User Groups, Network Device Groups (NDG) all replicate correctly. However, there are zero devices in each of the NDG's.

Master is configured to send, new slave configured to receive:

  User and Group Database

  Network Configuration Device tables

  Distribution Table

  Interface Configuration

  Interface Security Settings

  Password validation settings

I've also tried replicating Network Access Profiles instead of Network Configuration Device tables. Still no AAA clients in the NDGs.

I need my AAA clients replicated.  Should I be replicating different/additional components? Am I missing some setting elsewhere in ACS?

1 ACCEPTED SOLUTION

Accepted Solutions
andamani
Cisco Employee

hi,

Please apply patch 12 on ACS slave as well.

Try replication and let me know the results.

Also on the Network Configuration do you see the NDG name? or just no AAA clients under each NDG.

Regards,

Anisha

View solution in original post

2 REPLIES 2
andamani
Cisco Employee

hi,

Please apply patch 12 on ACS slave as well.

Try replication and let me know the results.

Also on the Network Configuration do you see the NDG name? or just no AAA clients under each NDG.

Regards,

Anisha

View solution in original post

Thank you Anisha. Your solution worked.

The patch level was the problem. After applying patch 12 to my new ACS server, the replication worked as it should. All my AAA clients replicated into the already-existing NDGs.

Yes, the NDGs had been named correctly prior to the patch. The only thing that did not replicate before the patch were the actual AAA clients inside those NDGs.

Thanks again for the help.

-Sam

Content for Community-Ad