cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
645
Views
0
Helpful
10
Replies

Cisco ACS integrated with windows AD issue

peter.peng
Beginner
Beginner

Hi Sir:

    I had setup the windows AD in the Cisco ACS. I had tested it and test result is ok. Why I have below "Disconnect " message.

10 Replies 10

nspasov
Cisco Employee
Cisco Employee

Hi there. Can you tell me:

1. What version of ACS you are running?

2. What type of domain controller do you have?

3. The type of browser used to manage ACS

4. Do you have the proper domain permissions for the ACS account when trying to join ACS to your domain?

Thank you for rating helpful posts!

Hi Neno:

   Below is my client status.

   Long time ago. The ACS works normally. After he export the ACS configure and import to new

   ACS. Then it works abnormally. He don't know why. 

   But I will ask my client about these four question. 

  ps. Could you provide me any recommendation ? Does it has any troubleshooting procedure or logs that I can capture it ?

Hi Sir:

    I found client's ACS adclient daemon didn't run. I also tried to restart daemon and restart ACS. But it didn't work.

Process 'database' running
Process 'management' running
Process 'runtime' running
Process 'adclient' Execution failed
Process 'view-database' running
Process 'view-jobmanager' running
Process 'view-alertmanager' running
Process 'view-collector' running
Process 'view-logprocessor' running

Hmm, that will definitely cause your problem :)

So you tried both:

1. Restart ACS completely

2. Tried to stop and stop the ACS application with:

application stop acs
application start acs

If yes I have the following questions:

1. Still would like to know the version and patch level of the ACS installation. You could be hitting a bug like these ones:

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCuy89193

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCtr35827

2. Can you confirm that the time is working properly on the server? I need you to check and confirm that the clock is showing the correct data and time, the NTP server is configured, NTP is synchronizing. 

Thank you for rating helpful posts!

Hi Sir:

    We had also tried to app stop/start acs. But it didn't work.

ps: The ACS version 5.2.

Looks like you might be hitting the second bug that I listed. Did you try the workaround commands suggested in the bug?

Workaround:
'acs start adclient' after 'acs stop adclent'

Thank you for rating helpful posts!

Hi Sir:

    My workaround is:

   1.acs start adclient' after 'acs stop adclent

   2. shutdown and restart ACS server.

   3.But it didn't work.

Hmm, I am afraid I am out of suggestions here. You can try to upgrade to a later version with a recent patch. It might not be a bad idea to reach out to Cisco TAC and get some feedback from them. They can also deploy a root patch and be able to have a more in-depth look under the covers. 

Thank you for rating helpful posts!

Hi Neno: I got it. I will try to upgrade it to 5.6. Thanks a lot.

Sounds good. Please let us know what the outcome is!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers