cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

This community is for technical, feature, configuration and deployment questions.
For production deployment issues, please contact the TAC! We will not comment or assist with your TAC case in these forums.
Please see How to Ask the Community for Help for other best practices.

3768
Views
15
Helpful
11
Replies
tiehom
Beginner

Cisco ISE instalation error

I am trying to install Cisco ISE2.0 on the hyper-v environment, i have encountered with an error message that say

Error: Unsupported hardware detected!

Cisco UDI (Unique Device Identifier) not found on this appliance.

Exiting Installation.

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Muhammed,

we faced the same issue with KVM and ISE, but we could solve them. Please try the following steps:

 

1) shutdown your VM

 

2) search for the configuration file of your VM:
root@*****:~# cd /etc/libvirt
root@*****:/etc/libvirt# find -name *.xml
./qemu/PSNTEST04102.xml
./qemu/PANTEST04102.xml

 

3) edit the file of your VM:    ->>virsh edit PSNTEST04102

 

4) please add the following directly above <os>

 

<sysinfo type='smbios'>
<system>
<entry name='product'>KVM</entry>
</system>
<baseBoard>
<entry name='product'>KVM</entry>
</baseBoard>
</sysinfo>

 

5) add: 

<smbios mode='sysinfo'/> 

in to <o>

 

smbios.pngI

 

View solution in original post

11 REPLIES 11
Marvin Rhoads
VIP Community Legend

ISE 2.0 is not supported on Hyper-V. That support was introduced in ISE 2.2.

2.0 release note citation:

 http://www.cisco.com/c/en/us/td/docs/security/ise/2-0/release_notes/ise20_rn.html#pgfId-44741

2.2 release note citations:

http://www.cisco.com/c/en/us/td/docs/security/ise/2-2/release_notes/ise22_rn.html#pgfId-627714

http://www.cisco.com/c/en/us/td/docs/security/ise/2-2/release_notes/ise22_rn.html#pgfId-713506

I am also getting this error even when installing on Ubuntu 16.10 KVM with afore mentioned procedure. am using ISE 2.2

Any help will be much appreciated...

KVM installation was only tested on Ubuntu 14.04 LTS.

You may be able to get it to work though - can you confirm you are using the installation file "ise-2.2.0.470.SPA.x86_64.iso"?

Yeah ISO file is that one....i confirm that...let me test on 14.04 LTS also..

Checked on Ubuntu 14.04...not working there also..Please can anyone from Cisco help us with this because have a client who cannot move away from KVM on Ubuntu.

If you require Cisco support, please open a TAC case and an engineer will be assigned to work with you.

If using a non-supported hypervisor, make sure to have the 'KVM' string in the product field of SMBIOS info.

Dmidecode utility reads from SMBIOS. If the "system-product" string does not contain “KVM”, the readUDI will be unable to determine the type of virtualization and 'validate_platform_info()' in ks.cfg will fail, displaying the following error message.
ERROR: UNSUPPORTED HARDWARE DETECTED!

https://www.cisco.com/c/en/us/td/docs/security/ise/2-1/install_guide/b_ise_InstallationGuide21/b_ise_InstallationGuide21_chapter_010.html#ID-1417-000002e3

How I can change the "system-product" to KVM on Ubuntu?

root@ubuntu:/# dmidecode -s 'system-product-name'
HP Z800 Workstation

 

Thank you

you can not change the dmidecode. What you can do is to change the smbios of your VM. For that please have a lot to my commect below.

Hi Muhammed,

we faced the same issue with KVM and ISE, but we could solve them. Please try the following steps:

 

1) shutdown your VM

 

2) search for the configuration file of your VM:
root@*****:~# cd /etc/libvirt
root@*****:/etc/libvirt# find -name *.xml
./qemu/PSNTEST04102.xml
./qemu/PANTEST04102.xml

 

3) edit the file of your VM:    ->>virsh edit PSNTEST04102

 

4) please add the following directly above <os>

 

<sysinfo type='smbios'>
<system>
<entry name='product'>KVM</entry>
</system>
<baseBoard>
<entry name='product'>KVM</entry>
</baseBoard>
</sysinfo>

 

5) add: 

<smbios mode='sysinfo'/> 

in to <o>

 

smbios.pngI

 

View solution in original post

DMel
Beginner

FYI....this fix still works even for ISE 3.0 on KVM.

I am currently installing ISE 3.0 on KVM on Ubuntu 20.04.

Content for Community-Ad