cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1478
Views
0
Helpful
3
Replies

Guest CWA Redirection doesn't Work in Android Phone

jatiwari
Cisco Employee
Cisco Employee

Hi Experts,

I am deploying Guest Access with ISE 2.4 Patch 8 and WLC 8.5.140.

Guest redirection works well with IOS, MAC and Windows however, doesn't go to redirection URL in Android Phones; doesn't get pop-up window.

Any pointer will be appreciated!

 

Regards,

Jay

1 Accepted Solution

Accepted Solutions

Surendra
Cisco Employee
Cisco Employee
You can try opening up the browser and check if it is getting redirected at all. Since it is working with other devices and not with android alone, there are 2 possibilities :


1. Incorrect policy hit for Android devices.
2. DNS resolution of the URL that android captive portal is trying to reach out

Your DNS server should be capable of resolving the following since Android captive portal in most of the versions try to reach out to the them :

clients3.google.com
connectivitycheck.gstatic.com
connectivitycheck.android.com

View solution in original post

3 Replies 3

Surendra
Cisco Employee
Cisco Employee
You can try opening up the browser and check if it is getting redirected at all. Since it is working with other devices and not with android alone, there are 2 possibilities :


1. Incorrect policy hit for Android devices.
2. DNS resolution of the URL that android captive portal is trying to reach out

Your DNS server should be capable of resolving the following since Android captive portal in most of the versions try to reach out to the them :

clients3.google.com
connectivitycheck.gstatic.com
connectivitycheck.android.com

hslai
Cisco Employee
Cisco Employee

Adding to Surendra's ...

Android devices may vary quite a bit, depending on not only the Android platform versions, but also the makes and models of the client device hardware. I found this interesting -- nginx - Why isn't Android's Captive Portal detection triggering a browser window? - Unix & Linux Stack Exchange

IIRC we also saw it help in some cases by turning off the cellular connections.

RaffyLindogan
Beginner
Beginner

Hi mate,

 

1. Did you recently change the Guest certificate or renewed it? Cause reload of ISE would fix it.

2. Disabling cookie on browser also works.

 

I have come across similar issue and it worked by doing either of the 2.

 

Cheers,

 

Raffy

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers