cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

ISE Sendquick SMS Provider configuration example

geeyc5113
Beginner
Beginner

I have an issue when try to configure http protocol in SMS gateway.  The purpose is to let the Guest to obtain the credential via sms after self-registration approval.

I tried this "http://x.x.x.x/cmd/system/api/sendsms.cgi?tar_num=6012xxxxxxx&tar_msg=testing" in web browser, my mobile phone can receive the message, so that I assume the sendquick should be fine.

However, when I enter http://x.x.x.x/cmd/system/api/sendsms.cgi?tar_num=$mobilenumber$

and tar_msg=$Message$ at encoded URL,

when the sponsor hit approve, the sendquick receive the message from ISE in server log, I can see my phone number and the credential, but at the end it show "Missing basic data" and the message failed to send to my mobile phone.

I have tried to tick and untick the HTTP Post, the result is the same.

Is there any parameter that I miss up in ISE configuration?  Anybody can help?

1 ACCEPTED SOLUTION

Accepted Solutions

Hi, Just an update.  I have successful configured and tested the sms gateway.

Here is the screenshot.

sms gateway setting-new.png

At URL there, I enter full command

http://10.2.2.5/cmd/system/api/sendsms.cgi?tar_num=$mobilenumber$&tar_mode=text&tar_msg=$message$

While at Data (URL encoded portion), I just enter $message$.

It works.

View solution in original post

6 REPLIES 6

Jason Kunst
Cisco Employee
Cisco Employee

Since we haven't tested this please work through with tac to see if can come up with a solution

Then we can document this use case

Hi, Thanks for the feedback.  I have found something from tcpdump.  From the tcp dump, the Full request URI as following

[Full request URI: http://10.2.2.5/cmd/system/api/sendsms.cgi?tar_num=+60124102943&tar_mode=utf-8tar_msg%3DHello+%2C+Your+account+details%3A+Username%3A+geeyc+Password%3A+7858]

When I copy the underline and put at browser, I got Error missing input and I saw the message still arrive at SMS gateway but showing missing basic data.  I notice that the tar_msg missing the '=' symbol.  when I manually add in '=' to the above link, which is

http://10.2.2.5/cmd/system/api/sendsms.cgi?tar_num=+60124102943&tar_mode=utf-8tar_msg=%3DHello+%2C+Your+account+details%3A+Username%3A+geeyc+Password%3A+7858


The message successful sent out from sms gateway but the with '=' in front of the message.


Any idea why the "=" missing from the line?  Here is my configuration.  I have tested either HTTP POST or HTTP GET method, the results are same.  SMS gateway setting.png

Please debug through TAC and escalation team