cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
511
Views
0
Helpful
3
Replies

Bandwidth segmentation for internet circuit

We have a Cisco ASR 1002 router and a stack of Cisco 3850 switches that then feed 90+ buildings.  every bldg operates on a separate VLAN.

We have one 1gig circuit feeding the router.  we want to regulate how much bandwidth a vlan can use.

what would be the best path to implement to accomplish this?

3 Replies 3

Hello,

here is a sample configuration for three Vlans. Each Vlan gets 100MB, if there is excess bandwidth available, the other Vlans get whatever is left:

access-list 110 permit ip 192.168.10.0 0.0.0.255 any
access-list 120 permit ip 192.168.20.0 0.0.0.255 any
access-list 130 permit ip 192.168.30.0 0.0.0.255 any
!
class-map match-all VLAN_10_CM
match access-group 110
class-map match-all VLAN_20_CM
match access-group 120
class-map match-all VLAN_30_CM
match access-group 130
!
policy-map CHILD_SHAPER
class VLAN_10_CM
priority 102400
class VLAN_20_CM
priority 102400
class VLAN_30_CM
priority 102400
class class-default
fair-queue
!
policy-map PARENT_SHAPER
class class-default
shape average 1024000
service-policy CHILD_SHAPER
!
interface GigabitEthernet0/0
service-policy output PARENT_SHAPER

@Georg Pauwen I'm presuming you're showing usage of a hierarchical policy in case there's an overall bandwidth sub-limit on the gig inteface's gig bandwidth, correct?  (NB: to OP, if there's no bandwidth sub-limit, you don't need parent and child policies.)

 "Each Vlan gets 100MB"

Each VLAN has "priority 102400", which I recall is Kbps, so it's, as noted, 102.4 Mbps, but "shape average 1024000" I recall (?) that numeric is in bps, or it's 1 Mbps.

Some of how to structure a CBWFQ policy is "personal taste", but I would not recommend using priority (LLQ) classes, principally because LLQ is used for really, really time sensitive traffic, like VoIP, so, personally, I keep it in reserve for just that purpose.  Also those priority classes all get directed to just one egress FIFO queue, which re-creates the global FIFO egress issues when not using CBWFQ.

"priority 10240" might be replaced by (two lines) "bandwidth #" and "shape (or police) #".  NB: priority or bandwidth and shape/police might only be used within an egress policy, but using "police #" can also be use for an ingress (or egress [w/o bandwidth, you cannot have different dequeuing ratios between classes]) policy.

Lastly, Georg's has FQ in a defined class-default (in the child policy), but perhaps a simple "drop" would be a better choice, so that any traffic w/o a defined class doesn't "leak" out.

 

Joseph W. Doherty
Hall of Fame
Hall of Fame

The "gig circuit", that's a WAN link?  If physical hand-off is gig, then is all gig bandwidth available or is there a capped sub limit? Internet connection?  LAN connection between ASR and Cisco stack?  Do you manage device(s) on other side of link from ASR?

On an ASR, you have an enhanced version of QoS vs. your 3850, but depending on what you really want/need to accomplish, either and/or both might accomplish it.

Controlling/managing bandwidth, is most effectively done at interface egress.  Some control/managing bandwidth can also be done at interface ingress, but it has effectiveness limitations.