cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1126
Views
0
Helpful
8
Replies

Can't fetch c2928 configuration

tira li
Level 1
Level 1

Hi All,

       I'm new to LMS recently, and I help my customer add 8 C2928 switches.  However, LMS can't get these equipment's configuration. I checked the equipment's snmp、telnet 、enable password setting , they all are the same as the lms credential setting(except one,which snmp don't be set) and make sure that they all can comunicate with lms server . I have set the longer time and more counters for timeout.

       My lms is 4.0.1 and the version can support c2928. I have a try to removal these devices and add them manually again, lms still can't get the configuration.

      LMS suggeststhat we can check the dcmaservice.log for detail, but i couldn't understand it.

      plz for your help, thx in advance.

Best Regards,

Tira

1 Accepted Solution

Accepted Solutions

Hi,

Never got that far, never found the configuration file for the client. As I suspect its somewhere in the Jar files.

Was able to upgrade, so did no further investigations.

I suspect this needs a TAC case and Bug/Conf fix.

Regards

Ian

View solution in original post

8 Replies 8

Vinod Arya
Cisco Employee
Cisco Employee

There are too many devices failing for Config archive as per teh log file. As per LMs, each device is a single entity and failure could be due t individual events.

Every device needs to be t/shooted as individual. If you target one devices first to be t/shooted, probably many would have the same issue.

i see the Telnet and SSH is failing currently :

[ Wed Sep 19  11:03:54 CST 2012 ],ERROR,[Thread-240],com.cisco.nm.xms.xdi.transport.cmdsvc.LogAdapter,error,19,Unknown authentication method: keyboard-interactive

[ Wed Sep 19  11:03:55 CST 2012 ],ERROR,[Thread-230],com.cisco.nm.xms.xdi.transport.cmdsvc.LogAdapter,error,19,Unknown authentication method: keyboard-interactive

Also, when LMS is trying to connect through the snmp credentials it is failing:

com.cisco.nm.lib.snmp.futureapi.SnmpReqTimeoutException: SnmpRequestTimeout on 10.34.2.10 while performing SnmpGet at index = -1

Please check if the crendential configured in LMS are correct. You can run a cerdential Verification job to do so from :

Inventory > Job Browsers: Device Credential Verification

Alos, please enable debug if the devices are failing and share failure reason it shows with job. You can enable debug from :

Admin > System: Debug Settings > Config and Image Management Debugging

-Thanks

-Thanks Vinod **Rating Encourages contributors, and its really free. **

hi Vinod,

        Thx for your reply. the device(10.34.2.10) doesn't be set the correct snmp which I knew, so we can temporarily ignore it. Then i deleted all issued C2928 and just added one(10.34.2.2). I have verified the device credential as given below

       

      here is the dcmaservice.log as attachment, you can check it from the message as given below:

     [ Wed Sep 19  17:00:22 CST 2012 ],INFO ,[Thread-6],com.cisco.nm.rmeng.dcma.configmanager.ConfigManager,deleteDevice,623,Deleting 6 devices

       ********

Unfortunately the debug is not enabled for the config management. Please do the following :

     a. Enable debug for configMgmt.

     b. Delete the content of existing dcmaservice.log. to have fresh logs collected.

     c. Rerun the archive job and send me the dcmaservice.log.

-Thanks

-Thanks Vinod **Rating Encourages contributors, and its really free. **

Hi,

I had the same issue on 3.2.1 as below. This is an issue with the LMS Java SSH Client which has the Keyboard-interactive enabled, which is casuing the Router to respond with the displayed line, whcih the LMS Client does not like.

[ Wed Sep 19  11:03:54 CST 2012  ],ERROR,[Thread-240],com.cisco.nm.xms.xdi.transport.cmdsvc.LogAdapter,error,19,Unknown  authentication method: keyboard-interactive

[ Wed Sep 19   11:03:55 CST 2012  ],ERROR,[Thread-230],com.cisco.nm.xms.xdi.transport.cmdsvc.LogAdapter,error,19,Unknown  authentication method: keyboard-interactive

You can show the issue using Putty.

Look at the SSH Auth options and you will see the Keyboard-interactive oprion which if you enable you see the router respond. If you disable it does not.

I have upgraded to LMS 4.2.2 and no longer see the issue and all 2900 Routers back up.

Hope this helps

Ian

https://supportforums.cisco.com/message/3701405#3701405

Hi lan,

     thx for your information. could you know how to disable the LMS java SSH client's Keyboard-interactive?. The lms version is 4.0.1 and my customer just has about 4.0 license.

Thanks

Tira

Hi,

Never got that far, never found the configuration file for the client. As I suspect its somewhere in the Jar files.

Was able to upgrade, so did no further investigations.

I suspect this needs a TAC case and Bug/Conf fix.

Regards

Ian

Hi,

    however, the LMS4.0.1 can fetch two C2928, that's so  strange!

Regards,

Tira

Hi  Vinarya,

       According to your steps, here is the dcmaservice.log  for your reference. In addition, plz ignore the ip 10.34.2.10 in the log. The one need to be set again the snmp string and telnet username by customer's engineer.

Thanks

Tira

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: