cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
672
Views
0
Helpful
11
Replies
Highlighted
Beginner

Cannot connect to another VLan using static IP address, also no internet

Hello guys, I am new to Cisco. Please help me.

 

1. I have a Cisco Core Switch: Vlan 1: 199.164.42.1,  Vlan 14: 172.25.48.1

 

2. Then, I have a switch 199.164.42.9 with the following:

Port 5 is mainly used for manually configured devices on Vlan14.

Port 7 is a test port.

 

3. Using my laptop through Port 7 I am able to connect by using a static IP address:

IP: 199.164.42.200

Subnet: 255.255.255.0

Default Gateway: 199.164.42.1

DNS: 199.164.42.14

DNS: 8.8.8.8

 

4. Using the same config on my laptop I am not able to connect through Port 5.

 

Also please check ports mode:

 p5.PNGp7.PNG

I cannot understand why. Thank you very much!

Everyone's tags (5)
11 REPLIES 11
Highlighted
Beginner

Re: Cannot connect to another VLan using static IP address, also no internet

What I tried so far on interface 0/5.

 

I checked: 

Port Vlans allowed on trunk
Gi0/5 14,100

 

Then I added Vlan1 to Interface 5

(config-if)#switchport trunk allowed vlan add 1

 

Result: 

Port Vlans allowed and active in management domain
Gi0/5 1,14,100

 

ISSUE: Still cannot connect to the port with manual IP address:

199.164.42.x

255.255.255.0

199.164.42.1

DNS:

199.164.42.14

8.8.8.8

 

I cannot even ping 199.164.42.14

 

Highlighted
Beginner

Re: Cannot connect to another VLan using static IP address, also no internet

show interface trunk

 

Port Mode Encapsulation Status Native vlan
Gi0/5 on 802.1q trunking 14
Gi0/13 on 802.1q trunking 1
Gi0/17 auto 802.1q trunking 1

 

Port Vlans allowed on trunk
Gi0/5 1,14,100
Gi0/13 1-4094
Gi0/17 1-4094
Gi0/21 1-4094
Gi0/23 1-4094
Gi0/24 1,16,100
Gi0/25 1-4094

Port Vlans allowed and active in management domain
Gi0/5 1,14,100
Gi0/13 1,7,11-12,14-16,21-22,80,100
Gi0/17 1,7,11-12,14-16,21-22,80,100

 


Port Vlans in spanning tree forwarding state and not pruned
Gi0/5 1,14,100
Gi0/13 1,7,11-12,14-16,21-22,80,100
Gi0/17 1,7,11-12,14-16,21-22,80,100
Gi0/21 1,7,11-12,14-16,21-22,80,100
Gi0/23 1,7,11-12,14-16,21-22,80,100
Gi0/24 1,16,100
Gi0/25 1,7,11-12,14-16,21-22,80,100

 

 

Also I saw that VLAN1 is not tagget to port Gi0/5, tried to add with with switchport access vlan 1. Didnt work.
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/8, Gi0/9, Gi0/10, Gi0/11
Gi0/12, Gi0/14, Gi0/18, Gi0/19
Gi0/20, Gi0/22
7 Plant active

Highlighted
Beginner

Re: Cannot connect to another VLan using static IP address, also no internet

After I understood the issue, I was able finally to add the Vlan 1 to port Gi0/5

By using following commands:

 

#configure

#interface range gi0/5

#switchport mode access

#switchport access vlan 1

#no shut

#exit

 

The result:

#show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/5, Gi0/8, Gi0/9, Gi0/10
Gi0/11, Gi0/12, Gi0/13, Gi0/14
Gi0/18, Gi0/19, Gi0/20, Gi0/22

 

image.png

As it works on my laptop, tomorrow will do a live test, will connect a device that it was not working before. Hope it does.

 

Highlighted
Beginner

Re: Cannot connect to another VLan using static IP address, also no internet

even that the ping is working and I could access the other network, I saw that the trunk status of the port is: NOT-TRUNKING, I guess it means that other VLan data will not be allowed to pass through:

 

#show interfaces gi0/5 trunk

 

Port Mode Encapsulation Status Native vlan
Gi0/5 off 802.1q not-trunking 14

Port Vlans allowed on trunk
Gi0/5 1

Port Vlans allowed and active in management domain
Gi0/5 1

Port Vlans in spanning tree forwarding state and not pruned
Gi0/5 1

Highlighted
Beginner

Re: Cannot connect to another VLan using static IP address, also no internet

I got the trunking!

 

BUT NOT ACCESS TO VLAN1 :(

 

TAN-SW2-MAINOFFICE#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
TAN-SW2-MAINOFFICE(config)#interface gi0/5
TAN-SW2-MAINOFFICE(config-if)#switchpor mode trunk

 

NO PING on VLAN1, VLAN14 works fine....

Highlighted
Beginner

Re: Cannot connect to another VLan using static IP address, also no internet

What I realized: 

 

1. I need to add Port gi0/5 to VLAN1

2. I can add it only using:

#configure

#interface range gi0/5

#switchport mode trun and this is enough

 

What I didnt know, is following:

 

#show vlan br - shows access ports
#show int trunk - show trucked interfaces/ports

Highlighted
Beginner

Re: Cannot connect to another VLan using static IP address, also no internet

Anyone to help, I got confused and stopped here:

 

Still cannot ping 199.164.42.1 on VLAN1.

 

Here is what port 5 looks like:

image.png

#show interfaces trunk

Port Mode Encapsulation Status Native vlan
Gi0/5 on 802.1q trunking 14

 

#show vlan br

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/8, Gi0/9, Gi0/10, Gi0/11, Gi0/12, Gi0/14, Gi0/18, Gi0/19
Gi0/20, Gi0/22

 

 

Highlighted
Beginner

Re: Cannot connect to another VLan using static IP address, also no internet

My last try was:

 

I read about mode dynamic auto, which allows the port to be either trunked or static.

 

(config-if-range)#switchport mode dynamic auto

 

Result:

#show interfaces trunk

Port Mode Encapsulation Status Native vlan
Gi0/5 auto 802.1q trunking 14

Port Vlans allowed on trunk
Gi0/5 1,14,100

 

Also I was able to ping both VLANS: 1 and 14 !!!! which is very nice !!

image.png

Highlighted
Beginner

Re: Cannot connect to another VLan using static IP address, also no internet

with my computer worked fine, but when connecting the other switches that are on VLAN 14, they didnt come up :(

Highlighted
Beginner

Re: Cannot connect to another VLan using static IP address, also no internet

setting back to switchport mode trunk, the devices appeared online. I dont understand :( . With this one I cannot connect to the other VLAN1.

 


#show interfaces trunk

Port Mode Encapsulation Status Native vlan
Gi0/5 on 802.1q trunking 14

Port Vlans allowed on trunk
Gi0/5 1,14,100

Highlighted
Beginner

Re: Cannot connect to another VLan using static IP address, also no internet

VLAN 14 WORKS:

image.png

VLAN 1 DOES NOT WORK:

image.png

Content for Community-Ad