cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
247
Views
0
Helpful
2
Replies

Cant Ping on 2 Routers at the Same Time? (Bad Configuration?)

EvgenijL
Level 1
Level 1

Hello,

I'm currently working on a networking task for my vocational training, but I'm struggling with IPv6 setup and static routing. I don’t have much experience with networking, so I'm hoping someone here can help me out.

Network Overview:
In the setup (see attached image), there are:

  • 2 routers (named "RT-HH-01" for Hamburg and "RT-HL-01" for Lübeck),
  • 2 switches (each connected to its respective router),
  • 2 clients connected to each switch (each in its own VLAN).

The task specifies:

  • Only IPv6 should be used, with static IP addresses and routing.
  • VLANs:
    • Hamburg (HH) switch has VLAN 10 for Client 1 and VLAN 20 for Client 2.
    • Lübeck (HL) switch has VLAN 30 for Client 1 and VLAN 40 for Client 2.
  • The connection between the routers uses GigabitEthernet0/0/0, and the connections from routers to switches use GigabitEthernet0/0/2 on both sides.

Current Issue: The weird part is that only one router at a time can successfully ping its connected devices (clients and switch gateway). When I turn both routers off and then turn them back on, only the router I start first works correctly (for example, if I start Router HH first and then Router HL, Router HH can ping its clients and gateway). However, the other router is unable to ping any devices and receives timeouts for all ping attempts.

I suspect there may be an issue with the configuration or possibly a conflict between the routers, but I'm not sure what could be causing it. Any advice on what to check or reconfigure would be greatly appreciated!

Running Config Router HH:

RT-HH-01#show running-config

Building configuration...

 

Current configuration : 1202 bytes

!

version 15.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname RT-HH-01

!

!

!

!

!

!

!

!

ip cef

ipv6 unicast-routing

!

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface GigabitEthernet0/0/0

no ip address

duplex auto

speed auto

ipv6 address FD00:0:1::1/64

!

interface GigabitEthernet0/0/1

no ip address

duplex auto

speed auto

shutdown

!

interface GigabitEthernet0/0/2

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0/2.10

encapsulation dot1Q 10

no ip address

ipv6 address 2001:DB8:1:10::1/64

!

interface GigabitEthernet0/0/2.20

encapsulation dot1Q 20

no ip address

ipv6 address 2001:DB8:1:20::1/64

!

interface GigabitEthernet0/2/0

switchport mode access

!

interface GigabitEthernet0/2/1

switchport mode access

!

interface GigabitEthernet0/2/2

switchport mode access

!

interface GigabitEthernet0/2/3

switchport mode access

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

ip flow-export version 9

!

ipv6 route 2001:DB8:4::/48 FD00:0:2::2

ipv6 route 2001:DB8:4::/48 FD00:0:1::2

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

Running Config Switch Hamburg:

Switch#sho running-config

Building configuration...

 

Current configuration : 1276 bytes

!

version 15.0

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Switch

!

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

interface FastEthernet0/1

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/2

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

switchport trunk allowed vlan 10,20

switchport mode trunk

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

no ip address

!

!

!

!

line con 0

!

line vty 0 4

login

line vty 5 15

login

!

!

!

!

end


Running Config Router HL: 

RT-HL-01#show running-config

Building configuration...

 

Current configuration : 1208 bytes

!

version 15.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname RT-HL-01

!

!

!

!

!

!

!

!

ip cef

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface GigabitEthernet0/0/0

no ip address

duplex auto

speed auto

ipv6 address FD00:0:1::2/64

!

interface GigabitEthernet0/0/1

no ip address

duplex auto

speed auto

ipv6 address FD00:0:3::1/64

shutdown

!

interface GigabitEthernet0/0/2

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0/2.30

encapsulation dot1Q 30

no ip address

ipv6 address 2001:DB8:2:30::1/64

!

interface GigabitEthernet0/0/2.40

encapsulation dot1Q 40

no ip address

ipv6 address 2001:DB8:2:40::1/64

!

interface GigabitEthernet0/2/0

switchport mode access

!

interface GigabitEthernet0/2/1

switchport mode access

!

interface GigabitEthernet0/2/2

switchport mode access

!

interface GigabitEthernet0/2/3

switchport mode access

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

ip flow-export version 9

!

ipv6 route 2001:DB8:3::/48 FD00:0:1::1

ipv6 route 2001:DB8:3::/48 FD00:0:3::2

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

Running Config Switch HL:

Switch#show ru

Switch#show running-config

Building configuration...

 

Current configuration : 1242 bytes

!

version 15.0

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Switch

!

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

interface FastEthernet0/1

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/2

switchport access vlan 40

switchport mode access

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

switchport trunk allowed vlan 30,40

switchport mode trunk

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

shutdown

!

!

!

!

line con 0

!

line vty 0 4

login

line vty 5 15

login

!

!

!

!

end

2024-11-07 09_16_51-Cisco Packet Tracer - H__Berufsschule Lernfeld 9.pkt.png

2 Replies 2

FredericFF271
Level 1
Level 1

Since they’re using the same subnet (FD00:0:1::/64) on this link, confirm that each router has a unique IPv6 address on this interface within that /64 range. For example, on Router HH, it’s FD00:0:1::1/64, and on Router HL, it should be FD00:0:1::2/64. This way, they’ll know how to communicate directly. Each router has some ipv6 route commands, which tell it how to reach networks on the other router. It’s important these routes have the correct “next-hop” IPs. So on Router HH, the command should use Router HL’s interface address (FD00:0:1::2) as the next hop, and Router HL should use FD00:0:1::1 for Router HH. You’ve got the VLAN subinterfaces set up on both routers for each client network (e.g., GigabitEthernet0/0/2.10 and .20 on Router HH). Just make sure that the encapsulation settings match on both sides and that everything aligns with your switch trunk settings. Use show ipv6 neighbors on each router can give you a clear picture of whether they’re recognizing each other. Make sure each router can see the other in its neighbor table and that pings go through as expected

Martin L
VIP
VIP

attach your pt file here in zip format; also u can use CLN forum for your studies https://learningnetwork.cisco.com/s/discussions

Regards, ML
**Please Rate All Helpful Responses **

 

Review Cisco Networking for a $25 gift card