cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
991
Views
8
Helpful
4
Replies

cisco pi 2.2 cpu monitoring dont work on som switch (3650 4948)

david_nyring
Level 1
Level 1

hey

i can't see any cpu utilization and memory utilization   on my WS-C4948-10GE and  WS-C3650-24TD, both is completed in last inventory collection status

we have WS-C3650-48PS that is working perfect with cpu monitoring and ram

when i go in the device to system -> memory pool i can see processor memory so thats why i think thats it is only a cpu reading problem, but when cpu reading fail i just also dont show memory utilization

ios version

WS-C3650-48PS      03.03.05SE

WS-C3650-24TD      03.03.03SE

WS-C4948-10GE      15.0(2)SG8

 

i have PI 2.2 with patch 2.2.1 and device packet 2

can some on confirm if pi is using snmp oid  1.3.6.1.4.1.9.9.109.1.1.1.1.8 (cpmCPUTotalEntry) to read cpu ?

or even better a solution/ider why it dont work :D

 

regard 

David

4 Replies 4

Scott Plank
Level 1
Level 1

Since the CPU monitoring on the 48-port 3650 is working, and the 24-port 3650 is not - have you tried upgrading the 24-port to the same code level as the 48-port? That would probably be the first thing I would do, just to eliminate mismatched IOS XE versions as a potential variable.

I'm afraid I can't offer a suggestion on the 4948, other than to say that there is a slightly newer maintenance release - 15.0(2)SG9 available for it. You might double-check your SNMP config, and make sure the view that you have configured on the device is not preventing CPU polling.

i also relly like to try updating the the WS-C3650-24TD but when i just have a hunch that maybe this is cause of the issue i will not be a loved to upgrade the ios on this switch until some on can say it will help it out, sadly but that the company policy on that point :)

the 4948 i can duo with what please me its just a test switch but sadly its seems that it is 2 difference issue with the monitoring of the cpu :(

Ashok Kumar
Cisco Employee
Cisco Employee

Hi,

Try Deploy/Undeploy the Device - Health (default) template, but it doesn’t solve our problem.

 

---------------------------------------------------------------------------------------------------------------------------------------------

Device - Health (default) -Deploy/Undeploy

[1] Go to Deploy > Configuration Deployment > Monitoring Deployment > My Templates > Device - Health (default)

[2] Click on Undeploy & deploy

---------------------------------------------------------------------------------------------------------------------------------------------

 


- Ashok

************************************************************************************************************

Please rate the useful post or mark as correct answer as it will help others looking for similar information

************************************************************************************************************

thx this help on the WS-C4948-10GE to work perfectly now.

i sad to say that i dindt have the same effect on my WS-C3650-24TD now it show the memory utilization grahp perfect, but it still the same story about cpu utilization.

WS-C3650-24TD is in a stack i dont know if that have any effect on this switch, because when i run thecpmCPUTotalEntry oid it return 2 cpu when on the 3750 stack it only return 1

SNMPv2-SMI::enterprises.9.9.109.1.1.1.1.8.1000 = Gauge32: 6
SNMPv2-SMI::enterprises.9.9.109.1.1.1.1.8.2000 = Gauge32: 1

so 3/4 solve so faar :)