cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2961
Views
0
Helpful
10
Replies

DHCP 3750

yogesh1
Beginner
Beginner

We have a multiple dhcp pool in 3750 as I observed we have no of ip free but system not getting ip from them and getting apipa.

After doing ip release/ renew then system getting ip so can you please suggest a solution how can we solve this problem. we are getting this problem once in two days .

there is only two to three user who are getting this problem.

Every time there is a d/f user who get this problem and some time I also write  one command clear ip dhcp binding* on core switch  to resolve this issue.

 

10 Replies 10

Meheretab Mengistu
Rising star
Rising star

Are the switch ports configured with "spanning-tree portfast"? The case could be that those ports are not configured as portfast and are going through the 30 seconds wait time (if you are still running pvst+ spanning tree) before transferring to Forward sate. In the meantime, dhcp request failed.


HTH,
Meheretab
HTH,
Meheretab

Yes its already configure with port fast. can you please suggest some other solution

You said two to three users are facing the problem. Are those users the same users? Or, randomly different users? Could you also share the configuration on the switch interface with the problem?

Generally, if you run ipconfig /release and ipconfig /renew on the PC side and it works, it indicates the problem could be on the computer side as well.

HTH,
Meheretab
HTH,
Meheretab

Dear Meheretab,

We have deploy our dhcp on core switch from where distributed and access layer switch has been connected if you want I can share my core switch config.

Every time there is d/f user from d/f department.

If there is a problem on pc side can you please suggest how can we identify and proof that there is a problem on pc side. how can we resolve this problem. 

 

Please find the core switch config below.

 


Tech-B-BCore01#sh run
Building configuration...

Current configuration : 13865 bytes
!
! Last configuration change at 22:54:43 IST Fri Oct 13 2017 by panasoniclevel15
!
version 15.0
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname Tech-B-BCore01
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$EL7M$tM9vGuQoIevJkZeTuBG8e0
!
username panasoniclevel7 privilege 7 password 7 072E027C6E2739564543
username panasoniclevel15 privilege 15 password 7 107E2937294424582024797975
aaa new-model
!
!
aaa group server radius PSRS
 server name AD1
!
aaa authentication login default group PSRS local
aaa authorization exec default group PSRS local
aaa accounting network default start-stop group PSRS
!
!
!
!
!
aaa session-id common
clock timezone IST 5 30
switch 1 provision ws-c3750x-24
switch 2 provision ws-c3750x-24
system mtu routing 1500
no ip source-route
ip routing
ip dhcp remember
no ip dhcp conflict logging
ip dhcp conflict resolution interval 1440
ip dhcp excluded-address 10.85.48.69
ip dhcp excluded-address 10.85.48.133
ip dhcp excluded-address 10.85.48.66
ip dhcp excluded-address 10.85.48.67
ip dhcp excluded-address 10.85.48.68
ip dhcp excluded-address 10.85.48.194
ip dhcp excluded-address 10.85.48.195
ip dhcp excluded-address 10.85.48.196
ip dhcp excluded-address 10.85.48.13
ip dhcp excluded-address 10.85.48.130
ip dhcp excluded-address 10.85.48.131
ip dhcp excluded-address 10.85.48.132
ip dhcp excluded-address 10.85.48.66 10.85.48.76
ip dhcp excluded-address 10.85.49.2 10.85.49.8
ip dhcp excluded-address 10.85.49.9
ip dhcp excluded-address 10.85.49.10
ip dhcp excluded-address 10.85.49.11
ip dhcp excluded-address 10.85.49.12
ip dhcp excluded-address 10.85.49.13 10.85.49.15
ip dhcp excluded-address 10.85.48.134 10.85.48.137
ip dhcp excluded-address 10.85.48.77 10.85.48.80
ip dhcp excluded-address 10.85.49.21 10.85.49.30
ip dhcp excluded-address 10.85.48.73
ip dhcp excluded-address 10.85.49.19
ip dhcp excluded-address 10.85.49.16 10.85.49.23
ip dhcp excluded-address 10.85.49.67
ip dhcp excluded-address 10.85.49.87
ip dhcp excluded-address 10.85.49.97
ip dhcp excluded-address 10.85.48.85
ip dhcp excluded-address 10.85.49.252
ip dhcp excluded-address 10.85.48.201 10.85.48.202
ip dhcp excluded-address 10.85.48.250
ip dhcp excluded-address 10.85.48.198
ip dhcp excluded-address 10.85.93.1 10.85.93.10
ip dhcp excluded-address 10.85.48.200
ip dhcp excluded-address 10.85.48.203
ip dhcp excluded-address 10.85.48.204
!
ip dhcp pool PI
   network 10.85.48.64 255.255.255.192
   default-router 10.85.48.65
   dns-server 137.40.35.12 10.85.28.33 10.81.248.31
   netbios-name-server 137.40.35.12 10.85.28.33
   lease 0 10
!
ip dhcp pool PWSI
   network 10.85.48.128 255.255.255.192
   default-router 10.85.48.129
   dns-server 137.40.35.12 10.85.28.33 10.81.248.31
   netbios-name-server 137.40.35.12 10.85.28.33
   lease 0 10
!
ip dhcp pool AC
   network 10.85.49.0 255.255.255.0
   default-router 10.85.49.1
   dns-server 137.40.35.12 10.85.28.33 10.81.248.31
   netbios-name-server 137.40.35.12 10.85.28.33
   lease 0 10
!
ip dhcp pool WM
   network 10.85.48.192 255.255.255.192
   default-router 10.85.48.193
   dns-server 137.40.35.12 10.85.28.33 10.81.248.31
   netbios-name-server 137.40.35.12 10.85.28.33
   lease 0 10
!
ip dhcp pool PASI
   network 10.85.93.0 255.255.255.128
   default-router 10.85.93.1
   dns-server 10.85.28.33 137.40.35.12
!
!
ip domain-name panasonic.com
!
!
crypto pki trustpoint TP-self-signed-1448264960
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1448264960
 revocation-check none
 rsakeypair TP-self-signed-1448264960
!
!
crypto pki certificate chain TP-self-signed-1448264960
 certificate self-signed 01
  30820254 308201BD A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31343438 32363439 3630301E 170D3933 30333031 30303031
  34305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 34343832
  36343936 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C5A7 C307DD96 C6456A4C 42E69D38 0B73DCCE 55ABAACA 140A442B F8290354
  6684B8CE EC5ACB32 CD2C81CD 4C765608 0CF1BCCC 8B44F00E 4344041A A87454A1
  B6E29997 71D4BABE 6810FD16 C842488F 1E6E0420 D199E4D5 7F762C18 A8A7AF1F
  D30BBC56 4BDE547F 31BACA25 61B913D0 44944E86 A70554AE B99778F4 98AA68CA
  701F0203 010001A3 7C307A30 0F060355 1D130101 FF040530 030101FF 30270603
  551D1104 20301E82 1C546563 682D422D 42436F72 6530312E 70616E61 736F6E69
  632E636F 6D301F06 03551D23 04183016 8014CDA9 00DD5012 8319FE21 CBE8F239
  255283BE AF1C301D 0603551D 0E041604 14CDA900 DD501283 19FE21CB E8F23925
  5283BEAF 1C300D06 092A8648 86F70D01 01040500 03818100 4692804A 830A05A6
  F4B481B9 E7312131 B9AF825C FD637B85 76C56E66 7F8B94DF 29F1BB7A B944A81D
  8560ED7B 43D9A557 0F7556FC 72155FB5 0016F253 A1B6BCDB 14FAAD9B B390E1C0
  7EC21A77 94F6A61E 7FD39F9B CC19B338 71363EF2 34DD56EF 0533DF91 43583406
  5E432F66 50B0F464 9ABBC88F A6874CE0 981206FD F0FBE0D7
        quit
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 5,10,20,30,40,50,60,70 priority 4096
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0
 no ip address
 no ip route-cache
!
interface GigabitEthernet1/0/1
 description connected to Tech-B-SFarm01
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!
interface GigabitEthernet1/0/2
 description connected to Tech-B-SFarm01
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!
interface GigabitEthernet1/0/3
 description connected to PACKET-SW
 switchport access vlan 60
 switchport mode access
 load-interval 30
 speed 100
 duplex full
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet1/0/11
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet1/0/12
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet1/0/13
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet1/0/14
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet1/0/15
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet1/0/16
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet1/0/17
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet1/0/18
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet1/0/19
 description ""SG300 AP Sw""
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet1/0/20
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
 switchport access vlan 10
!
interface GigabitEthernet1/1/1
 description connected to Tech-C1-FCore01
 switchport trunk encapsulation dot1q
 switchport mode trunk
 udld port
!
interface GigabitEthernet1/1/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/1/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/1/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface TenGigabitEthernet1/1/1
!
interface TenGigabitEthernet1/1/2
!
interface GigabitEthernet2/0/1
 description connected to Tech-B-SFarm01
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode desirable
!
interface GigabitEthernet2/0/2
 description connected to Tech-B-SFarm01
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode desirable
!
interface GigabitEthernet2/0/3
 description ****Link to Secondary Router****
 switchport access vlan 60
 switchport mode access
 speed 100
 duplex full
!
interface GigabitEthernet2/0/4
 switchport access vlan 20
!
interface GigabitEthernet2/0/5
 switchport access vlan 20
!
interface GigabitEthernet2/0/6
 switchport access vlan 20
!
interface GigabitEthernet2/0/7
 switchport access vlan 40
 switchport mode access
!
interface GigabitEthernet2/0/8
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet2/0/9
 switchport access vlan 20
!
interface GigabitEthernet2/0/10
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet2/0/11
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet2/0/12
 switchport access vlan 20
 switchport mode access
 load-interval 30
!
interface GigabitEthernet2/0/13
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet2/0/14
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet2/0/15
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet2/0/16
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet2/0/17
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet2/0/18
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet2/0/19
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet2/0/20
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet2/0/21
!
interface GigabitEthernet2/0/22
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet2/0/23
!
interface GigabitEthernet2/0/24
 switchport access vlan 50
 switchport mode access
!
interface GigabitEthernet2/1/1
 description connected to Tech-C2-FCore01
 switchport trunk encapsulation dot1q
 switchport mode trunk
 udld port
!
interface GigabitEthernet2/1/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/1/3
 description Connected Tech-D-FCore01
 switchport trunk encapsulation dot1q
 switchport mode trunk
 load-interval 30
 udld port
!
interface GigabitEthernet2/1/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface TenGigabitEthernet2/1/1
!
interface TenGigabitEthernet2/1/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan5
 ip address 10.85.48.14 255.255.255.248
 no ip redirects
 no ip unreachables
 no ip proxy-arp
!
interface Vlan10
 ip address 10.85.48.33 255.255.255.224
 no ip redirects
 no ip unreachables
 no ip proxy-arp
!
interface Vlan20
 ip address 10.85.48.65 255.255.255.192
 no ip redirects
 no ip unreachables
 no ip proxy-arp
!
interface Vlan30
 ip address 10.85.48.129 255.255.255.192
 no ip redirects
 no ip unreachables
 no ip proxy-arp
!
interface Vlan40
 ip address 10.85.48.193 255.255.255.192
 no ip redirects
 no ip unreachables
 no ip proxy-arp
!
interface Vlan50
 ip address 10.85.49.1 255.255.255.0
 no ip redirects
 no ip unreachables
!
interface Vlan60
 ip address 10.85.48.4 255.255.255.248
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 load-interval 30
!
interface Vlan70
 ip address 10.85.93.1 255.255.255.128
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 load-interval 30
!
no ip http server
ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 10.85.48.3
!
ip radius source-interface Vlan10
logging esm config
logging trap debugging
logging 10.85.48.79
logging 137.40.35.161
access-list 77 permit 10.85.48.67
access-list 77 remark Hosts allowed to request SNMP data
access-list 77 remark PANASONIC SUMMIT PROXY
access-list 77 permit 10.85.48.66
access-list 77 permit 137.40.35.102
access-list 101 permit tcp any any eq 22
snmp-server community panasonic RO
snmp-server community Nw3P@NAS0 RO 77
snmp-server location Panasonic TechnoPark
snmp-server contact Panasonic
snmp-server enable traps snmp authentication linkdown linkup
snmp-server enable traps config
snmp-server enable traps envmon fan shutdown supply temperature status
snmp ifmib ifindex persist
!
!
radius server AD1
 address ipv4 10.85.48.67 auth-port 1645 acct-port 1646
 key 7 051B152F701E1D
!
!
banner motd ^CC

********************************************************************************
This Switch you are about to use is company owned and is intended to be used for
official company business. As such, the company reserves the right to monitor all
activity on all company provided equipment and services. Use of the company
provided information systems and networks in violation of company guidelines
will result in disciplinary action, up to and including termination.
********************************************************************************

^C
!
line con 0
 exec-timeout 5 0
 password 7 06362F0F6C1F5B4A51
line vty 0 4
 access-class 101 in
 exec-timeout 5 0
 logging synchronous
 length 0
 transport input ssh
line vty 5 15
 access-class 101 in
 exec-timeout 5 0
 transport input ssh
!
ntp source Vlan60
ntp server 10.85.48.3
end

 

Please remove "ip dhcp remember" command, and reload the switch. Could you also share the output of "show version" if it is not fixed after reloading?

HTH,
Meheretab
HTH,
Meheretab

Dear Meheretab,

I have already reload a switch one week ago but still facing this issue.

can you please let mw know how to remove ip dhcp remember command and what is a use of this command .

Its been very helpful if you explain me this and resolve this problem.

Also find the sh ver output below.

Tech-B-BCore01#sh ver
Cisco IOS Software, C3750E Software (C3750E-UNIVERSALK9-M), Version 15.0(1)SE3, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2012 by Cisco Systems, Inc.
Compiled Wed 30-May-12 13:41 by prod_rel_team

ROM: Bootstrap program is C3750E boot loader
BOOTLDR: C3750E Boot Loader (C3750X-HBOOT-M) Version 12.2(53r)SE2, RELEASE SOFTWARE (fc1)

Tech-B-BCore01 uptime is 5 days, 11 hours, 52 minutes
System returned to ROM by power-on
System restarted at 23:10:06 IST Tue Oct 10 2017
System image file is "flash:/c3750e-universalk9-mz.150-1.SE3/c3750e-universalk9-mz.150-1.SE3.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

License Level: ipbase
License Type: Permanent
Next reload license Level: ipbase

cisco WS-C3750X-24 (PowerPC405) processor (revision A0) with 262144K bytes of memory.
Processor board ID FDO1636P1CW
Last reset from power-on
9 Virtual Ethernet interfaces
1 FastEthernet interface
56 Gigabit Ethernet interfaces
4 Ten Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address       : 6C:20:56:52:C5:00
Motherboard assembly number     : 73-12530-06
Motherboard serial number       : FDO163607XP
Model revision number           : A0
Motherboard revision number     : A0
Model number                    : WS-C3750X-24T-S
Daughterboard assembly number   : 800-32727-03
Daughterboard serial number     : FDO163602HV
System serial number            : FDO1636P1CW
Top Assembly Part Number        : 800-31327-03
Top Assembly Revision Number    : B0
Version ID                      : V03
CLEI Code Number                : COMJV00ARC
Hardware Board Revision Number  : 0x04


Switch Ports Model              SW Version            SW Image
------ ----- -----              ----------            ----------
*    1 30    WS-C3750X-24       15.0(1)SE3            C3750E-UNIVERSALK9-M
     2 30    WS-C3750X-24       15.0(1)SE3            C3750E-UNIVERSALK9-M


Switch 02
---------
Switch Uptime                   : 5 days, 11 hours, 52 minutes
Base ethernet MAC Address       : 6C:20:56:52:EC:80
Motherboard assembly number     : 73-12530-06
Motherboard serial number       : FDO1636081W
Model revision number           : A0
Motherboard revision number     : A0
Model number                    : WS-C3750X-24T-S
Daughterboard assembly number   : 800-32727-03
Daughterboard serial number     : FDO16360GG0
System serial number            : FDO1636P1EQ
Top assembly part number        : 800-31327-03
Top assembly revision number    : B0
Version ID                      : V03
CLEI Code Number                : COMJV00ARC
License Level                   : ipbase
License Type                    : Permanent
Next reboot licensing Level     : ipbase


Configuration register is 0xF

Tech-B-BCore01#

 

can you please let mw know how to remove ip dhcp remember command and what is a use of this command .

 

I got the following explanation from https://www.cisco.com/c/en/us/td/docs/switches/lan/smart_install/configuration/guide/smart_install/tasks.html#65488

 

If the Smart Install DHCP server is the director or another device running Cisco IOS and the network reloads, the server might assign new IP addresses to participating switches. If a switch IP address changes, it might no longer be reachable. If the director IP address changes, it is no longer the Smart Install director, which could break the director and client switch relationships. This is an unlikely but possible corner-case occurrence. To prevent this occurrence, you should enable DHCP remembering by entering the ip dhcp remember global configuration command or the remember DHCP-pool configuration command on the DHCP server, Note The remember keyword is supported in Cisco IOS Release 12.2(53)SE or later.

 

I believe "no ip dhcp remember" will remove it. Following that, you will need to reload the switch. It could also be related with this bug --  CSCtl12389 .

 

HTH,

Meheretab

HTH,
Meheretab

Dear Meheretab,

If we do no ip dhcp remember then its clear remember addresses after the lease time is over.

it did not effect our dhcp excluded address is it right ?

Also its renew the  ip address to client when we reload the switch.

I dis not understand how it help when we already have free ip in our pool and some system still not getting ip automatically

 

Dear Meheretab,

If we do no ip dhcp remember then its clear remember addresses after the lease time is over.

it did not effect our dhcp excluded address is it right ?

Also its renew the ip address to client when we reload the switch.

I did not understand how it help when we already have free ip in our pool and some system still not getting ip automatically


@yogesh1 wrote:
Dear Meheretab,

If we do no ip dhcp remember then its clear remember addresses after the lease time is over.

it did not effect our dhcp excluded address is it right ?

Also its renew the ip address to client when we reload the switch.

I did not understand how it help when we already have free ip in our pool and some system still not getting ip automatically

I apologize for the delayed response. The command ip dhcp remember configures the DHCP pool to remember the IP bindings of a device. If the network or device reloads, the DHCP server issues the same IP address to a client that it had before the reload. I suggested to remove ip dhcp remember and reload is to check whether it is a software bug.

 

Please post the output of 'sh ip dhcp binding' and 'sh ip dhcp conflict'. By the way, is the problem related with a single dhcp pool or all pools? Also, are the customers with a problem plugged in to intermediate devices? If you move the customer device to a different port, will it get IP address without issuing release/renew or clear ip dhcp binding *?

 

HTH,

Meheretab

HTH,
Meheretab
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers