cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1276
Views
10
Helpful
3
Replies
Highlighted
Beginner

DHCP failed. APIPA being used. Please help!

I'm very new to networking and I just can't figure out why my PC isn't able to get DHCP ip address as it works for my Web server.

Any help would really be appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

 

Assuming that Router should not provide IPs to hosts (not be DHCP server), here is what I found so far:

Server PT DHCP has wrong IP address; IP is in vlan 30 but I think it should be in 80, not in 30; Also, i think one or two settings in dhcp network ranges were wrong on Server PT dhcp service tab. 

then, if you change IP of Server PT, you will need to correct ip helper-address to point to IP of server, I think it should be 128.1.1.2.

interface GigabitEthernet0/1.30

encapsulation dot1Q 30

ip address 128.1.0.1 255.255.255.0

ip helper-address 128.1.1.2

 

Regards, ML
**Please Rate All Helpful Responses **

 

 

 

 

View solution in original post

3 REPLIES 3
Highlighted
VIP Engager

 

Web server gets IP from DHCP you set up on router, not from server.  you can see that with show ip dhcp pool or bindings on router.

if you add dhcp pool for vlan 30 on router, it should work

 

ip dhcp pool net_30
 network 128.1.0.0 255.255.255.0
 default-router 128.1.0.1

 

but, i think, the goal to get IPs via dhcp from Server-PT, not from router, right?

 

Regards, ML
**Please Rate All Helpful Responses **

Highlighted

 

Assuming that Router should not provide IPs to hosts (not be DHCP server), here is what I found so far:

Server PT DHCP has wrong IP address; IP is in vlan 30 but I think it should be in 80, not in 30; Also, i think one or two settings in dhcp network ranges were wrong on Server PT dhcp service tab. 

then, if you change IP of Server PT, you will need to correct ip helper-address to point to IP of server, I think it should be 128.1.1.2.

interface GigabitEthernet0/1.30

encapsulation dot1Q 30

ip address 128.1.0.1 255.255.255.0

ip helper-address 128.1.1.2

 

Regards, ML
**Please Rate All Helpful Responses **

 

 

 

 

View solution in original post

Highlighted
Beginner

Omg, it works! Thank you so much, really appreciate your help :)

Content for Community-Ad