cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1267
Views
5
Helpful
2
Replies

INTER VLAN ROUTING

balde
Level 1
Level 1

hello everyone !!!

i've have successfully configured LACP etherchannel on both layer 3 switches, i have assigned them both ip address of every vlan, i've enabled IP ROUTING and NO SWITCH PORT on the interfaces connected to the router. I have also configured OSPF but i still cannot PING from the Admin laptop (VLAN Gestion) to other VLANs but the opposite works...does anyone know what might be the problem ?

please i need HELP !!!

 

hostname layer3-1

ip routing

no ip domain-lookup

spanning-tree mode pvst

interface Port-channel2

 switchport access vlan 99

 switchport trunk native vlan 99

 switchport trunk encapsulation dot1q

 switchport mode trunk

interface Port-channel3

 switchport trunk native vlan 99

 switchport trunk encapsulation dot1q

 switchport mode trunk

interface FastEthernet0/1

 no switchport

 ip address 172.16.48.1 255.255.255.248

 duplex auto

 speed auto

interface FastEthernet0/19

 switchport trunk native vlan 99

 switchport trunk encapsulation dot1q

 switchport mode trunk

 channel-protocol lacp

 channel-group 2 mode active

interface FastEthernet0/20

 switchport trunk native vlan 99

 switchport trunk encapsulation dot1q

 switchport mode trunk

 channel-protocol lacp

 channel-group 2 mode active

interface FastEthernet0/21

 switchport trunk native vlan 99

 switchport trunk encapsulation dot1q

 switchport mode trunk

 channel-protocol lacp

 channel-group 2 mode active

interface FastEthernet0/22

 switchport trunk native vlan 99

 switchport trunk encapsulation dot1q

 switchport mode trunk

 channel-protocol lacp

 channel-group 3 mode active

interface FastEthernet0/23

 switchport trunk native vlan 99

 switchport trunk encapsulation dot1q

 switchport mode trunk

 channel-protocol lacp

 channel-group 3 mode active

interface FastEthernet0/24

 switchport trunk native vlan 99

 switchport trunk encapsulation dot1q

 switchport mode trunk

 channel-protocol lacp

 channel-group 3 mode active

interface GigabitEthernet0/1

interface GigabitEthernet0/2

interface Vlan1

 no ip address

 shutdown

interface Vlan10

 mac-address 00e0.f9ae.ec01

 ip address 172.16.57.123 255.255.255.128

interface Vlan20

 mac-address 00e0.f9ae.ec02

 ip address 172.16.56.251 255.255.255.0

interface Vlan30

 mac-address 00e0.f9ae.ec03

 ip address 172.16.57.136 255.255.255.192

router ospf 1

 router-id 4.4.4.4

 log-adjacency-changes

 redistribute static

 redistribute connected

 network 172.16.56.0 0.0.0.255 area 0

 network 172.16.57.0 0.0.0.127 area 0

 network 172.16.57.128 0.0.0.63 area 0

 network 172.16.48.0 0.0.0.7 area 1

ip classless

ip route 172.16.57.0 255.255.255.128 Vlan10

ip route 172.16.57.128 255.255.255.128 Vlan30

ip flow-export version 9

layer3-1(config)#

 

 

hostname layer3-2

ip routing

no ip domain-lookup

spanning-tree mode pvst

!

interface Port-channel3

switchport trunk native vlan 99

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Port-channel4

switchport trunk native vlan 99

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/1

no switchport

ip address 172.16.48.3 255.255.255.248

duplex auto

speed auto

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

switchport trunk native vlan 99

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 4 mode active

!

interface FastEthernet0/20

switchport trunk native vlan 99

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 4 mode active

!

interface FastEthernet0/21

switchport trunk native vlan 99

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 4 mode active

!

interface FastEthernet0/22

switchport trunk native vlan 99

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 3 mode active

!

interface FastEthernet0/23

switchport trunk native vlan 99

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 3 mode active

!

interface FastEthernet0/24

switchport trunk native vlan 99

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 3 mode active

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

mac-address 00d0.9704.b901

ip address 172.16.57.124 255.255.255.128

!

interface Vlan20

mac-address 00d0.9704.b902

ip address 172.16.56.252 255.255.255.0

!

interface Vlan30

mac-address 00d0.9704.b903

ip address 172.16.57.137 255.255.255.192

!

router ospf 1

router-id 3.3.3.3

log-adjacency-changes

network 172.16.57.128 0.0.0.63 area 0

network 172.16.57.0 0.0.0.127 area 0

network 172.16.56.0 0.0.0.255 area 0

network 172.16.48.0 0.0.0.7 area 1

neighbor 172.16.48.4

!

ip classless

ip route 172.16.57.0 255.255.255.128 Vlan10

ip route 172.16.57.128 255.255.255.128 Vlan30

!

ip flow-export version 9

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

End

 

layer3-2(config)#

1 Accepted Solution

Accepted Solutions

luis_cordova
VIP Alumni
VIP Alumni

Hi @balde ,

 

I see that the two L3 have the same network, being that when entering the command no switchport those interfaces are left with a router port.

If you can, create a new network and assign different networks. One for the connection of a switch with his router and another one for the connection of the other switch with his router.

Now, if you must use a single network for the two switches, I recommend creating a communication vlan, which would make the two switches, through SVI, belong to the same network (same number of vlan). For this, you must configure subinterfaces in the two routers, encapsulated with the vlan number of the communication vlan.

 

I hope you can understand me.

 

Regards

View solution in original post

2 Replies 2

luis_cordova
VIP Alumni
VIP Alumni

Hi @balde ,

 

I see that the two L3 have the same network, being that when entering the command no switchport those interfaces are left with a router port.

If you can, create a new network and assign different networks. One for the connection of a switch with his router and another one for the connection of the other switch with his router.

Now, if you must use a single network for the two switches, I recommend creating a communication vlan, which would make the two switches, through SVI, belong to the same network (same number of vlan). For this, you must configure subinterfaces in the two routers, encapsulated with the vlan number of the communication vlan.

 

I hope you can understand me.

 

Regards

thank you a lot !!!

I changed the L3 switches interfaces from routing to switch with the command swithcport then the following commands 

interface FastEthernet0/1

switchport access vlan 99

switchport trunk native vlan 99

switchport trunk allowed vlan 10,20,30

switchport trunk encapsulation dot1q

switchport mode trunk

now i the inter vlan routing problem is solved

Thanks angain !!!