cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1360
Views
0
Helpful
1
Replies

L2TP in GNS not working

Hello Everyone,

 

I can't seem to find what is the problem with my config. I get my client to connect to the LAC, the virtual iface connection is established and is visible from the sh users command. However, the connection doesn't even reach the LNS.

 

Can you please browse my config and let me know what is the problem?

 

Thank you in advance!

-----------------------------------------------------------------------------------------------------

 

Exert; full runnig configs attached as .txt

 

CE1 = Client

 

 

CE1#sh users
Line User Host(s) Idle Location
* 0 con 0 idle 00:00:00

Interface User Mode Idle Peer Address
Vi2 PPPoE 04:28:17

CE1#sh run int di1
Building configuration...

Current configuration : 204 bytes
!
interface Dialer1
ip address negotiated
ip mtu 1492
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp authentication chap callin
ppp chap hostname USER1
ppp chap password 0 123456
end

CE1#

 

LAC#
LAC#sh run | s user
username USER1 password 0 123456
LAC#
LAC#

LAC#sh run | s vpdn
vpdn enable
vpdn search-order domain
vpdn-group 1
request-dialin
protocol l2tp
domain asd4khd.org
initiate-to ip 80.156.137.244 priority 1
local name LAC
l2tp tunnel password 0 qweasd
l2tp tunnel receive-window 1024
LAC#

 

LNS#sh run | s user
username LAC password 0 qweasd
username USER1 password 0 123456

LNS#sh run | s vpdn
vpdn enable
vpdn-group 1
accept-dialin
protocol l2tp
virtual-template 1
terminate-from hostname LAC
source-ip 80.156.137.244
local name LNS
l2tp tunnel password 0 qweasd
l2tp tunnel receive-window 1024
LNS#

1 Reply 1

Hi Guys,

 

I'm happy to inform you that we've found the solution.

 

There needs to be an IP pair between LAC and LNS (on this topology at least).

The LAC DOESN'T need to contain the usernames, only the LNS needs to.

 

You need to add the domain to the CHAP user name within the LNS username config

of you use domain-search on the LAC.

 

After correcting these my dialer finally got the IP address from the LNS pool and thus the connection

is working.

 

Dialer1 77.0.0.1 YES IPCP up up


Gateway of last resort is 0.0.0.0 to network 0.0.0.0

80.0.0.0/32 is subnetted, 1 subnets
C 80.156.137.244 is directly connected, Dialer1
77.0.0.0/32 is subnetted, 1 subnets
C 77.0.0.1 is directly connected, Dialer1
S* 0.0.0.0/0 is directly connected, Dialer1
CE1#

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: